locked
Upgrading network card on homeserver RRS feed

  • Question

  • Hi,
    Can anyone advise me how to get WHS to use my new gigabit network card.
    I have installed and loaded the drivers and the network card seems to work fine but the WHS console will not let me see any of the other computers on the network.
    I have tried the obvious and disabled the on board network adapter in the BIOS and uninstalled the old driver but still no joy with connecting through the console.
    The new card connects to the network and I can see other hard wired computers on the network when I go through network places.

    I am just missing something simple?

    I look forward to hearing from anyone who can may be give some advise.

    Thanks
    Tuesday, October 27, 2009 8:27 PM

Answers

  • You may have revealed the problem in your last post "apart from the IP address being different"...this could be keeping the "clients" from even trying to connect to the server. Have you tried to "remove" the clients from the home server and also remove the connector software from the clients. Then re-install the connector software on the clients from the server by connecting to it using the IP address of the "new" adapter.

    ie, "http://(new adapter IP address ***.***.***.***):55000"

    also, make sure by going into Control Panel -> Network Connections that your new adapter is "enabled" and properly configured for all the protocols needed (Client for Microsoft Networks, File and Printer Sharing for Microsoft Networks, Internet Protocol) by checking the Properties (right click on device). Check that this all matches the "old" adapter settings.
    • Marked as answer by johncooper70 Friday, October 30, 2009 9:42 PM
    Friday, October 30, 2009 2:29 PM

All replies

  • To make the other computers visible in the console, you install the console on the intended client PCs.
    This can be done via http://yourservername:55000.
    After performing this you can start the console from one of your client PCs (logging in to the server desktop is unsupported).

    Best greetings from Germany
    Olaf
    Tuesday, October 27, 2009 8:38 PM
    Moderator
  • Thanks Olaf, I have tried what you stated on your thread and I still have no joy connecting the client to the server using the new network card fitted in the server. If I swap over the ethernet connection on the server back to the original port then all features between WHS and clients work perfectly. Do I need to tell WHS which network adapter to use as default? If I connect both network adapters to the home network all features still work but the networking monitor in task manager only shows data transfer through the original onboard adapter. Thanks John
    Tuesday, October 27, 2009 9:54 PM
  • Thanks Olaf, I have tried what you stated on your thread and I still have no joy connecting the client to the server using the new network card fitted in the server. If I swap over the ethernet connection on the server back to the original port then all features between WHS and clients work perfectly. Do I need to tell WHS which network adapter to use as default? If I connect both network adapters to the home network all features still work but the networking monitor in task manager only shows data transfer through the original onboard adapter. Thanks John

    Are you able to ping your server from a client (either by name or by IP address) when using only the Gb NIC?
    Wednesday, October 28, 2009 1:17 AM
    Moderator
  • Please review the configuration of both network connections on your server, paying particular attention to DHCP, IP address, subnet mask, DNS server(s), and gateway.
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, October 28, 2009 3:01 PM
    Moderator
  • Hi,
    I have tried to remote desktop over to the server using only the Gb NIC and it fails to even logon and tells me that I can't see it from a client pc
    I then plugged back into the on board NIC and try logging on through remote desktop and still no joy, but unplug the Gb NIC then I can remote straight into it from the client PC.
    If I then plug back in the Gb NIC to the server the network card connects, then I minimise the remote desktop window and go to command prompt on the client PC I can now ping the Gb NIC no problems and get < 1ms on all 4 pings, this is the same for the onboard NIC.
    I have checked both network cards on the server and apart from the IP address being different the rest of the gateway numbers and subnet mask numbers match and both cards are assigned by DHCP and all IP & DNS addresses are obtained automatically.

    Hopefully the above makes sense!
    I look forward to hearing from you all soon.

    Thanks again

    John


    Wednesday, October 28, 2009 9:35 PM
  • Hi John,
    try to disconnect the cable and disable the unused network adapter in the network environment of the server.
    Multihomed usage is not supported by Windows Home Server (and may also be troublesome with some home routers). The old adapter, if not deactivated, may still be the prefered adapter. Also ensure, that the network drivers and the router firmware are up to date.
    Best greetings from Germany
    Olaf
    Wednesday, October 28, 2009 9:58 PM
    Moderator
  • You may have revealed the problem in your last post "apart from the IP address being different"...this could be keeping the "clients" from even trying to connect to the server. Have you tried to "remove" the clients from the home server and also remove the connector software from the clients. Then re-install the connector software on the clients from the server by connecting to it using the IP address of the "new" adapter.

    ie, "http://(new adapter IP address ***.***.***.***):55000"

    also, make sure by going into Control Panel -> Network Connections that your new adapter is "enabled" and properly configured for all the protocols needed (Client for Microsoft Networks, File and Printer Sharing for Microsoft Networks, Internet Protocol) by checking the Properties (right click on device). Check that this all matches the "old" adapter settings.
    • Marked as answer by johncooper70 Friday, October 30, 2009 9:42 PM
    Friday, October 30, 2009 2:29 PM
  • Hi,
    This did the trick.

    Thanks to all who helped.

    John
    Friday, October 30, 2009 9:44 PM
  • I found this thread when I had a similar problem, cured by using a Cat6 cable so anyone else having this problem and using newer hardware make sure to at least have a CAT5e or CAT6 best.
    Saturday, March 26, 2011 1:50 PM