none
Errors while syncing directory with & character in name RRS feed

  • General discussion

  • Hi there,

    I've been using synctoy for a while now and I think I found an error. I was syncing a directory structure between 2 laptops and I repeatedly got errors about "access denied", "could not write to target",  nd similar kind of messages for a (sub)directory named "bevestigingen & contracten". I retried it several times, recreated the folder pair, but the error kept appearing. After renaming the directory to "bevestigingen en contracten" the tool ran without any error.

    As far as I know the & is a legal character for directory and file names (at least Windows itself does not complain)

    Thanks,
    Erwin
    Monday, August 25, 2008 10:27 AM

All replies

  • To help us investigate further - what operating system were you running this on? And were you sync'ing from to a network share or an external drive?

     

    Thanks

    Deepa

     

    Monday, August 25, 2008 4:30 PM
    Moderator
  • I should have added - are you also trying this SyncToy 2.0?

     

    Thanks

    Deepa

    Monday, August 25, 2008 4:31 PM
    Moderator
  • I doubt that the '&' character in the name had much to do with the errors you were getting. Maybe chaning the name just caused something on the file system to stop returning errors. Many times there are apps that scan the file system that hold locks on files or directories which cause write errors and just renaming the file makes the errors go away. Weare continuing to investigate the sporadic Access Denied errors that folks are reporting. However, we have tested with special characters in file names and it should work just fine.

     

    Wednesday, August 27, 2008 5:43 PM
    Answerer