locked
OCS 2007 R2 and Application Sharing Service RRS feed

  • Question

  • ***Never mind. I found the problem. The Front End server was also using TCP/5065 probably during testing for the phone integration. I removed it and all is well.



    I have a new OCS 2007 R2 I am getting ready to migrate to from RTM and am having a weird problem.

    Before explaining the problem, we setup a gateway for our phone system and all is working well but we used port 5065 for it and I noticed the App Sharing service never starts. We changed the phone gateway to 5067 today.

    Now the issue. 2 days ago I could not get the Front End service to start after restarting the server for MS updates so I restored from the previous day and all was well. However after noticing the Application Sharing Service was not starting and found our phone gateway using the same port, we changed the gateway to use port 5067 today and I after only restarting the services, a lot of them did not start back up. I chose to wait till tonight and restart.

    Now, I restarted and every service started except the Front End. I stopped each OCS service one by one, starting the Front Front each time which failed until I stopped the Application Sharing Service. Viola, after it started, I could not get the App Sharing to start again. OK, all ports are default from the installation but it appears Front End is somehow using 5065. I even saw it trying to use 5065 in the Event Log while starting the Front End service. I changed App Sharing to use port 5069 and now it starts.

    So, a few questions:
    1. Is App Sharing supposed to be started automatically?
    2. How will changing its port affect operations?
    3. What exactly does it do? I read it does a lot, I also read all it does is enable desktop sharing (desktop sharing always worked even when the service was stopped)

    ***Never mind. I found the problem. The Front End server was also using TCP/5065 probably during testing for the phone integration. I removed it and all is well.

     

    Wednesday, March 18, 2009 1:49 AM