locked
Cleanup fails at 5% RRS feed

  • Question

  • I have noticed that my WHS is not cleaning the backups. I upgraded my desktop and needed to delete all the backups because the hardware was different. I changed them all to delete at next cleanup and manually started it from the backup settings tab in the console. It failed at 5%. So i deleted the computer and re-added it. All the backups were gone. Good so far.. The other clients have around 5 months of backups and aren't getting cleaned even ones marked for deletion.

    All clients backup on schedule.
    DBDD addin completes successfully.
    Database repair works and reports no errors but
    Cleanup fails at 5% with the error ' An error in the Backup service is preventing the Cleanup Operation' and in event viewer i get an application error
    Event ID: 1000 - Faulting application whsbackup.exe, version 6.0.2030.0, faulting module whsbackup.exe, version 6.0.2030.0, fault address 0x0001d13.

    I have changed a hard drive and sata controller card as they kept timing out and resetting but the error still persists.

    Any thoughts?
    Thanks
    Tom.
    Saturday, July 18, 2009 1:57 PM

All replies

  • I have noticed that my WHS is not cleaning the backups. I upgraded my desktop and needed to delete all the backups because the hardware was different. I changed them all to delete at next cleanup and manually started it from the backup settings tab in the console. It failed at 5%. So i deleted the computer and re-added it. All the backups were gone. Good so far.. The other clients have around 5 months of backups and aren't getting cleaned even ones marked for deletion.

    All clients backup on schedule.
    DBDD addin completes successfully.
    Database repair works and reports no errors but
    Cleanup fails at 5% with the error ' An error in the Backup service is preventing the Cleanup Operation' and in event viewer i get an application error
    Event ID: 1000 - Faulting application whsbackup.exe, version 6.0.2030.0, faulting module whsbackup.exe, version 6.0.2030.0, fault address 0x0001d13.

    I have changed a hard drive and sata controller card as they kept timing out and resetting but the error still persists.

    Any thoughts?
    Thanks
    Tom.

    Did you run chkdsk /r on each drive in your server?  If that doesn't help, some part of your backup database may be corrupted and you might have to delete the entire database and start over.
    Saturday, July 18, 2009 3:56 PM
    Moderator
  • chkdsk has just finished, took over 6 hours and no chane. I still get the error. I'm just backing up the database again and then i'll delete the original.
    I was hoping to avoid the drastic measure. Once it's done i'll do a load of manual backups and see if they can be cleaned.
    Saturday, July 18, 2009 8:51 PM
  • How do you delete the backup database?
    Tuesday, October 27, 2009 9:52 PM
  • How do you delete the backup database?

    Typically, you run the Repair function and if it can't fix it, it should delete it for you.  If that doesn't work, you can delete the entire backup database manually by logging into the server desktop (which is unsupported) and deleting everything in D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}.
    Wednesday, October 28, 2009 1:28 AM
    Moderator