locked
Wont install RRS feed

  • Question

  • I just installed a Evaluation Version of HomeServer and tried to install PP3.

    I forgot to install PP2 before and it failed with a message "Update doesnt apply to installed version" after installing all the Windows and Search fixes.

    So I went back and tried to install PP2. Same error.

    Any tip?
    Friday, July 17, 2009 8:03 PM

Answers

  • Yeah, that was my issue. I had a prerelease version of PP2 running. These betas are really stable considering I've been running a beta of pp2 since December. ;-) Thanks WHS team.
    Saturday, July 18, 2009 6:18 AM

All replies

  • Hi Jobohel,
    It looks to me like some parts of PP3 may still be installed.  Can you try following the PP3 uninstall process as described in the release documentation and see if you still get the same error?

    The uninstall process is on page 4 of the release documenation and I have copied it below.

    Un-Installation:

    Warning!  When the final version of Power Pack 3 is released, you will need to manually uninstall the Power Pack 3 Beta.  When Power Pack 3 is released it will be automatically installed on your home server via Windows Update.  If Power Pack 3 Beta is still on your home server, the Windows Update installation will fail.

     

    1.       Access the Windows Home Server Administrator’s Desktop (How to connect to the Windows Home Server Administrator’s Desktop)

    2.       Navigate to the Windows Home Server Power Pack 3 Beta folder at Start > My Computer > D:  > Shares > Software > Windows Home Server Power Pack 3 Beta.

    3.       Run the Uninstall.cmd file to un-install Power Pack 3 Beta.  After reboot, your Home Server will revert back to your previous version.

    4.       Re-install the updated Windows Home Server Connector software on your home computer. (Windows Home Server Connector installation)


    Jonas Svensson [MSFT] Windows Home Server Community Program Manager
    Windows Home Server Team Blog
    Connect Windows Home Server
    Windows Home Server
    Friday, July 17, 2009 8:11 PM
  • Jonas,
    I have the same issue as reported above. When I ran the Uninstall.cmd command the command window flashed on the screen and closed. Since the third phase of installation didn't complete does the uninstall fail because "%SystemRoot%\$NtUninstallKB968349$\spuninst\spuninst.exe /quiet /forcerestart" is not there? Should I go in and manually remove the Windows Search v 4 and KB969949 before trying to install again?

    Thanks,

    Todd Spatafore
    Friday, July 17, 2009 10:08 PM
  • The exact Error is:
    ---------------------------
    KB968349 Setup Error
    ---------------------------
    Update does not apply to installed version.
    ---------------------------
    OK  
    ---------------------------


    I tried removing WDS 4.0 and the Hotfix and retrying the install. Got the same error. When I was uninstalling I noticed that I had installed WDS 4 on July 1 along with a host of other updates (like IE8).
    Friday, July 17, 2009 11:40 PM
  • Jonas,
    I have the same issue as reported above. When I ran the Uninstall.cmd command the command window flashed on the screen and closed. Since the third phase of installation didn't complete does the uninstall fail because "%SystemRoot%\$NtUninstallKB968349$\spuninst\spuninst.exe /quiet /forcerestart" is not there? Should I go in and manually remove the Windows Search v 4 and KB969949 before trying to install again?

    Thanks,

    Todd Spatafore

    I would (and 940157 if it's there as well).
    Saturday, July 18, 2009 4:34 AM
    Moderator
  • Actually, I think I still have an OLD build of PP2 on this WHS. I'll remove that and try installing the RTW version. OOPS. Sorry.
    Saturday, July 18, 2009 5:51 AM
  • Yeah, that was my issue. I had a prerelease version of PP2 running. These betas are really stable considering I've been running a beta of pp2 since December. ;-) Thanks WHS team.
    Saturday, July 18, 2009 6:18 AM