locked
Manual backup repeatedly fails on one client (2 others successful) RRS feed

  • Question

  • I have tried chkdsk c: /f /r but still the Manual backup fails.

    If I run Repair on the Console it immediately says that the Backup service is not running then prooceeds with the repair. The repair completes O.K. and says the Backup service was restarted but on running the Manual backup agan it once again fails almost immediately.

    On the client I have noted the following in the Event logs:-

    Application

    Event Type: Error
    Event Source: COM+
    Event Category: Unknown
    Event ID: 4689
    Date:  17/10/2008
    Time:  05:52:04
    User:  N/A
    Computer: DELL2
    Description:
    The run-time environment has detected an inconsistency in its internal state. This indicates a potential instability in the process that could be caused by the custom components running in the COM+ application, the components they make use of, or other factors. Error in f:\xpsp3\com\com1x\src\comsvcs\events\evregistrar.cpp(503), hr = 80040155: Failed to delete subscriptions.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Event Type: Warning
    Event Source: COM+
    Event Category: (105)
    Event ID: 4445
    Date:  17/10/2008
    Time:  05:52:04
    User:  N/A
    Computer: DELL2
    Description:
    An incompletely initialized CRM log file was detected. It has been re-initialized. If this warning appears when the CRM log file is being initially created then no further action is required.
    Server Application ID: {02D4B3F1-FD88-11D1-960D-00805FC79235}
    Server Application Instance ID:
    {10E7AA1A-9959-4398-AEAC-F4F2BC662958}
    Server Application Name: System Application
    Comsvcs.dll file version: ENU 2001.12.4414.702 shp

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Event Type: Error
    Event Source: COM+
    Event Category: (98)
    Event ID: 4822
    Date:  17/10/2008
    Time:  05:52:05
    User:  N/A
    Computer: DELL2
    Description:
    A condition has occurred that indicates this COM+ application is in an unstable state or is not functioning correctly. Assertion Failure: SUCCEEDED(hr)

    Server Application ID: {02D4B3F1-FD88-11D1-960D-00805FC79235}
    Server Application Instance ID:
    {10E7AA1A-9959-4398-AEAC-F4F2BC662958}
    Server Application Name: System Application
    The serious nature of this error has caused the process to terminate.
    Error Code = 0x8000ffff : Catastrophic failure
    COM+ Services Internals Information:
    File: f:\xpsp3\com\com1x\src\comsvcs\tracker\trksvr\trksvrimpl.cpp, Line: 3000
    Comsvcs.dll file version: ENU 2001.12.4414.702 shp

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    System

    Event Type: Information
    Event Source: Service Control Manager
    Event Category: None
    Event ID: 7035
    Date:  17/10/2008
    Time:  05:52:04
    User:  NT AUTHORITY\SYSTEM
    Computer: DELL2
    Description:
    The COM+ System Application service was successfully sent a start control.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Event Type: Error
    Event Source: Service Control Manager
    Event Category: None
    Event ID: 7032
    Date:  17/10/2008
    Time:  05:52:04
    User:  N/A
    Computer: DELL2
    Description:
    The Service Control Manager tried to take a corrective action (Restart the service) after the unexpected termination of the COM+ System Application service, but this action failed with the following error:
    An instance of the service is already running.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Please could someone advise?
    Thanks

    Nigel

    Friday, October 17, 2008 4:56 AM

Answers

  • Hi Nigel,
    please execute following commands in the cmd prompt:
    net stop vss
    net start vss
    Does it work now?
    Do you have any SQL databases installed on that machine (could also be MSDE or SQL Express Editions)?
    If yes, check http://support.microsoft.com/kb/912414
    You can also try to reregister all the VSS writer components (put the following lines into a cmd file and execute it):

    cd \Windows\system32
    Net stop vss
    Net stop swprv
    regsvr32 ole32.dll
    regsvr32 vss_ps.dll
    vssvc /register
    regsvr32 /i swprv.dll
    regsvr32 /i eventcls.dll
    regsvr32 es.dll
    regsvr32 stdprov.dll
    regsvr32 vssui.dll
    regsvr32 msxml.dll
    regsvr32 msxml3.dll
    regsvr32 msxml4.dll


    Reboot your PC. Open a command prompt again and run:
    vssadmin list writers
    Check, if all your writers are displayed w/o errors.

    Best greetings from Germany
    Olaf

    Friday, October 17, 2008 10:51 AM
    Moderator

All replies

  • Hi Nigel,
    run regedit and search the registry (press key F3) for the GUIDs in the brackets. Try to figure out, what they stand for or from which application they are coming and try to uninstall/reinstall these components, if possible.
    Try also to delete the .crmlog file in C:\Windows\Registration.
    (Maybe you need to stop some services to do this or start Windows in safe mode.)
    Best greetings from Germany
    Olaf
    Friday, October 17, 2008 9:11 AM
    Moderator
  • Olaf,

    Thank-you (again!)

    I have tried the backup again and find the first errors are these below. Does this change your suggestion?
    Otherwise I will follow you last, but please what are the GUID's

    Application

    Event Type: Error
    Event Source: VSS
    Event Category: None
    Event ID: 8193
    Date:  17/10/2008
    Time:  10:46:21
    User:  N/A
    Computer: DELL2
    Description:
    Volume Shadow Copy Service error: Unexpected error calling routine IEventSystem::Query.  hr = 0x80040155.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 57 52 54 57 52 54 49 43   WRTWRTIC
    0008: 32 31 37 33 00 00 00 00   2173....
    0010: 57 52 54 57 52 54 49 43   WRTWRTIC
    0018: 32 31 31 31 00 00 00 00   2111....


    Event Type: Error
    Event Source: VSS
    Event Category: None
    Event ID: 5013
    Date:  17/10/2008
    Time:  10:46:21
    User:  N/A
    Computer: DELL2
    Description:
    Volume Shadow Copy Service error: Shadow Copy writer Microsoft Writer (Bootable State) called routine CVssWriterShim::Subscribe which failed with status 0x8000ffff (converted to 0x800423f4).

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 57 53 48 43 4f 4d 4e 43   WSHCOMNC
    0008: 32 32 39 32 00 00 00 00   2292....
    0010: 57 53 48 57 53 48 4d 43   WSHWSHMC
    0018: 33 31 36 30 00 00 00 00   3160....

    Nigel

    Friday, October 17, 2008 10:03 AM
  • Hi Nigel,
    please execute following commands in the cmd prompt:
    net stop vss
    net start vss
    Does it work now?
    Do you have any SQL databases installed on that machine (could also be MSDE or SQL Express Editions)?
    If yes, check http://support.microsoft.com/kb/912414
    You can also try to reregister all the VSS writer components (put the following lines into a cmd file and execute it):

    cd \Windows\system32
    Net stop vss
    Net stop swprv
    regsvr32 ole32.dll
    regsvr32 vss_ps.dll
    vssvc /register
    regsvr32 /i swprv.dll
    regsvr32 /i eventcls.dll
    regsvr32 es.dll
    regsvr32 stdprov.dll
    regsvr32 vssui.dll
    regsvr32 msxml.dll
    regsvr32 msxml3.dll
    regsvr32 msxml4.dll


    Reboot your PC. Open a command prompt again and run:
    vssadmin list writers
    Check, if all your writers are displayed w/o errors.

    Best greetings from Germany
    Olaf

    Friday, October 17, 2008 10:51 AM
    Moderator
  • Olaf,

    Thanks

    I ran the net stop vss and net start vss O.K., but the manual backup still failed.

    I don't believe I have any SQL databases, I certainly haven't created or knowingly used any.

     

    I ran the batch process you listed

    Line

    C:\WINDOWS\system32>regsvr32 vssui.dll
    gave an error
    LoadLibrary("vssui.dll") failed - The specified module could not be found.

    However all the other lines succeeded

    Please can you advise on the 'error' line and I will run the batch again.

    Thanks again
    #
    Nigel

    Friday, October 17, 2008 11:59 AM
  • Hi Nigel,
    seems this file does only exist on server, but not on client PC.
    So no reason to worry about that error message.
    Best greetings from Germany
    Olaf
    Friday, October 17, 2008 2:17 PM
    Moderator
  • Olaf,

    I have now tried the manual backup on that same client and it is running!

    Is there anything I can do to make sure that the manual and auto backups will continue to work on this client?

    I thank-you once again for you help.

    Nigel
    Friday, October 17, 2008 2:27 PM
  • Hi Nigel,
    I don't think that you can do much yourself here, sometimes a system instability or some weird programmed application do their best to disturb things in their task. If this happens, you are welcome to return to this place and as us further questions ;-)
    Have a nice weekend
    Olaf
    Friday, October 17, 2008 6:05 PM
    Moderator