locked
Cant send emails from CRM web client due to Data Encryption error RRS feed

  • Question

  • Hi All,

    We have recently done an upgrade from CRM 2011 to CRM 2013. And have been testing the Outlook integration with it.

    I have the Outlook plugin (UR2)installed on my machine. When I try to send an email from CRM, it gives the below error. This same error pops up when I try to navigate to CRM Personal Options in Outlook to check the email settings. 

    Data Encryption error when sending email from CRM

    When we try to go to above path to activate encryption, another error pops up:

    Protocol error

    Our on-premise instance doesnt use HTTPs, so what option do i have to get past this error.

    I know there is a work around through which I can get past this HTTPs dialog by setting DisableSSLCheckForEncryption to 1 in DeploymentProperties table in the database. However, after doing so, I will still need an encryption key to activate Data Encryption. We do not have any encryption key and generating one only for the purpose of Outlook integration seems too much to me.

    How have others been able to send email from CRM without actiating data encryption. Or is it mandatory?

    Regards,

    Yogesh


    • Edited by yogeshfd Monday, April 14, 2014 1:05 PM
    Monday, April 14, 2014 1:02 PM

Answers

  • Figured out that disabling HTTPs through database (as mentioned above) and using the Encryption Key of CRM 2011 Email Router is one of the ways to resolve this issue. 

    Thank you all!

    Regards,

    Yogesh

    • Marked as answer by yogeshfd Wednesday, April 23, 2014 7:57 AM
    Wednesday, April 23, 2014 7:57 AM

All replies

  • I'm pretty sure you can't turn it off. You don't have to buy a certificate or anything to get the encryption key, you can just generate a key. You will eventually come across other things (not just Outlook) that tell you an encryption key is needed as well, so I'd recommend just creating a key and setting it up.
    Tuesday, April 15, 2014 5:36 PM
  • do you have the correct outlook plugin version for the CRM version? Try downloading the plugin as supplied by the CRM organization, and configure that one. I suspect you might be running an incorrect outlook plugin version.

    Also, HTTPS is only required when having an IFD deployment, but if you use Outlook in an internal scenario, that is not a problem. 

    • Proposed as answer by Nico-TMVP Wednesday, April 16, 2014 2:47 AM
    Wednesday, April 16, 2014 2:47 AM
  • Hi Ken,

    Unfortunately, we are at a stage in this project where we do not have any scope to generate certificate and get it signed from certificate authority (I assume thats what is needed). And neither can we create our 'own certificate authority' as that would be risky. Anyway, thanks for replying and confirming that this cant be turned off.

    Wednesday, April 16, 2014 10:05 AM
  • Hi Nico-T,

    Below is the screenshot of Outlook plugin version and I believe its the correct one.

    We do not have an IFD deployment, but still not able to send emails from inside CRM or even make the email router work because of Data Encryption issue. Any clues?

    Thanks,

    Yogesh

    Wednesday, April 16, 2014 10:08 AM
  • Figured out that disabling HTTPs through database (as mentioned above) and using the Encryption Key of CRM 2011 Email Router is one of the ways to resolve this issue. 

    Thank you all!

    Regards,

    Yogesh

    • Marked as answer by yogeshfd Wednesday, April 23, 2014 7:57 AM
    Wednesday, April 23, 2014 7:57 AM