none
YouTube becomes an image

    Question

  • Hello,

    I am working with the Umbraco CMS which uses the Metaweblog API to allow editors to editor their web pages in WLW.

    I am able to add a YouTube video in WLW which is totally dynamic in both editing and preview mode.

    However, when I publish the page all I see is a screenshot of the video which links to the YouTube page instead of a dynamic playable video.

    Does anyone know what could be causing this and how I can fix this?

    Thanks!

    This is the HTML code generated by WLW, when checking the source:
    <div style="padding-bottom: 0px; margin: 0px; padding-left: 0px; padding-right: 0px; display: inline; float: none; padding-top: 0px" id="scid:5737277B-5D6D-4f48-ABFC-DD9C333F4C5D:e3751a4c-29f6-4ef0-8c3e-3e2497d92c3b" class="wlWriterEditableSmartContent">
    <br/>
    <embed src="http://www.youtube.com/v/mOvoO6eQDms" type="application/x-shockwave-flash" wmode="transparent" width="425" height="355"></embed>
    <br/>
    </div>
    This is what the Umbraco editor shows as its html source:
    <div class="wlWriterEditableSmartContent" id="scid:5737277B-5D6D-4f48-ABFC-DD9C333F4C5D:e3751a4c-29f6-4ef0-8c3e-3e2497d92c3b" style="margin: 0px; display: inline; float: none; padding: 0px;">
    <a href="http://www.youtube.com/watch?v=mOvoO6eQDms" target="_new">
    <img style="border-style: none" src="/media/224/WindowsLiveWriter_Test_11B22_video3e034d2a7541.jpg" alt="" rel="425,355" />
    </a>
    </div>
    
    And this is what IE8 shows once I open the page:
    <div style="display: inline; float: none; margin: 0px; padding: 0px; padding-bottom: 0px; padding-left: 0px; padding-right: 0px; padding-top: 0px" id="scid:5737277B-5D6D-4f48-ABFC-DD9C333F4C5D:e3751a4c-29f6-4ef0-8c3e-3e2497d92c3b" class="wlWriterEditableSmartContent">
    <a href=http://www.youtube.com/watch?v=mOvoO6eQDms target="_new">
    <img src="/media/224/WindowsLiveWriter_Test_11B22_video3e034d2a7541.jpg" style="border-style: none" galleryimg="no" onload="var downlevelDiv = document.getElementById('9e15df3e-c906-4ce9-8052-2f0c20baf228'); downlevelDiv.innerHTML = &quot;&lt;div&gt;&lt;object width=\&quot;425\&quot; height=\&quot;355\&quot;&gt;&lt;param name=\&quot;movie\&quot; value=\&quot;http://www.youtube.com/v/mOvoO6eQDms&amp;hl=en\&quot;&gt;&lt;\/param&gt;&lt;embed src=\&quot;http://www.youtube.com/v/mOvoO6eQDms&amp;hl=en\&quot; type=\&quot;application/x-shockwave-flash\&quot; width=\&quot;425\&quot; height=\&quot;355\&quot;&gt;&lt;\/embed&gt;&lt;\/object&gt;&lt;\/div&gt;&quot;;" alt="" /></a>
    </div>
    • Edited by Mujinja Wednesday, May 13, 2009 9:29 PM
    Wednesday, May 13, 2009 11:17 AM

Answers

All replies

  • Can you try this:

    Blog | Edit Blog Settings | Advanced

    Set both Scripts and Embeds to "Supported". Then republish the blog post.
    Wednesday, May 13, 2009 5:42 PM
    Owner
  • Thanks for your reply.

    However, they are both already on 'supported'.

    Got any other idea's?
    Wednesday, May 13, 2009 8:45 PM
  • OK, let's try Embed=supported, Scripts=not supported.
    • Marked as answer by Mujinja Thursday, May 14, 2009 8:21 PM
    Thursday, May 14, 2009 12:02 AM
    Owner
  • That was unexpected: it works! :D

    What did I just do/disable?

    Thanks!

    Thursday, May 14, 2009 8:21 PM
  • Well, it is quite complicated, Brandon goes into some (not all) of the details here.

    But the main gist of what the original HTML you saw was trying to accomplish, was to show an interactive YouTube player on your blog but let RSS readers (who generally strip embeds, JavaScript, etc.) see a static image with a link to the YouTube page. Since that didn't actually work (it looks like Umbarco stripped an empty div we intentionally put in there), the next best thing we can do is to just embed the player. That's what happened when you changed those settings.

    There shouldn't really be any other sideeffects, unless you use a plugin that happens to pay attention to those settings (seems pretty unlikely).

    Thursday, May 14, 2009 9:08 PM
    Owner
  • I am having the exact same problem, but I have tried changing the Advanced setting as you mentioned, If I set Scripts=not supported, I always lose the video on the blog, and If I have scripts set to suppoted, I get an image on the Blog that links to youtube.
    Shon
    Thursday, May 14, 2009 10:41 PM
  • Hi Shon,

    What kind of blog are you on? (Blogger, WordPress, Windows Live Spaces, Movable Type, etc.)

    Thanks
    Thursday, May 14, 2009 11:42 PM
    Owner
  • MOSS (SharePoint)
    Shon
    Thursday, May 14, 2009 11:58 PM
  • I'm also having this problem and I'm using Expression Engine 1.6.7.

    Sunday, May 17, 2009 4:13 AM