locked
OneCare requires that File and Printer Sharing be on? RRS feed

  • Question

  • Why is this?  I'd like to use OnceCare's circle backup, but I don't want my kids to have access to my documents and files.

    Monday, March 24, 2008 2:04 AM

Answers

  • Just because File and Printer Sharing is enabled, that does not mean that you actually have to Share anything. If the folders that you use to store data on are Shared, you can disable sharing or set sharing to require and ID and password.

    The exception to this, if you are going to use Centralized backup on a Hub PC, you need to create a Share on your external drive (or wherever you plan to use for backup) that is available to all users - with the setting to allow all users to be able to change files. The folder created by OneCare within that Share for each backup plan will be protected, so the kids won't be able to access them, though they may be able to "see" the folder if they choose to poke around in Windows Explorer.

    -steve

     

    Monday, March 24, 2008 12:49 PM
    Moderator

All replies

  • Just because File and Printer Sharing is enabled, that does not mean that you actually have to Share anything. If the folders that you use to store data on are Shared, you can disable sharing or set sharing to require and ID and password.

    The exception to this, if you are going to use Centralized backup on a Hub PC, you need to create a Share on your external drive (or wherever you plan to use for backup) that is available to all users - with the setting to allow all users to be able to change files. The folder created by OneCare within that Share for each backup plan will be protected, so the kids won't be able to access them, though they may be able to "see" the folder if they choose to poke around in Windows Explorer.

    -steve

     

    Monday, March 24, 2008 12:49 PM
    Moderator
  • Stephen:

     

    <<Just because File and Printer Sharing is enabled, that does not mean that you actually have to Share anything.>>

     

    It does in Windows Vista.  In XP, you could right click a directory and "Not Share" it, but Vista has you set Permission Levels for directories that it ignores.  This would be a more flexible system if it worked.  Directories that have permission levels set for me as Owner only can be viewed by anyone on the network if File and Printer sharing are enabled.

     

    For example, my son can browse all my document directories on his Playstation 3 which I want to use for Media Sharing only.  That's how I found you can't make anything private in Vista.

     

    Monday, March 24, 2008 3:22 PM
  • If you do not have any folders Shared on your PC you will not be able to access those folders from any other PC in either Vista or XP.

     

    To be clear, what versions of XP and Vista are we talking in your case?

     

    What Shares are shown on the Vista machine that you wish to keep private?

    -steve

    Monday, March 24, 2008 4:00 PM
    Moderator
  • Steve,

     

    Thanks for the reply.

     

    The Sony Playstation can view the document files and sub-directories on my Vista Home Premium x64 machine, it cannot see document files on the XP machines on the home network.  These are my files (Word, Excel, etc.) that reside in Vista's default "Documents" folder.  XP called this the "My Documents" folder.  The Playstation doesn't run Windows as far as I know.

     

    I want to keep everything on my Vista machine private except for the Public folders which contain my media files - music,  videos and pictures.    The Playstation allows me to view pictures and play music files on the TV.  Some refer to this as "media sharing".  I'll admit, I do not fully understand the differences between 1)  file sharing, 2) public folders, 3) media sharing, and 4) Media Center sharing and 5) Media Extenders.  What was wrong with just  having network shared folders like a normal operating system? 

     

    I can access my entire Documents folder on the Vista machine from the Playstation, even though the Documents folder is set for myself as owner having the only permission.  The Documents folder is not shared per Vista.  The only way to stop the Playstation from being able to view the Documents folder on my Vista machine is to turn File and Printer sharing off.  I suspect File and Printer sharing overrides all the individual sharing permissions set for each folder and makes everything accessible - an amazingly suspect idea in my eyes.

    Monday, March 24, 2008 5:47 PM
  • I am using Vista Home Premium on this laptop and no other PC can access my files without providing login credential.

    In Windows Explorer, right click on the C: drive and select Properties and then the Sharing tab. At the bottom of that tab, in the section called Password Protection, it should say "People must have a user account and password for this computer to access shared folders." And a link to the Network and Sharing Center for changing these settings.

     

    Click on the Network and Sharing Center link open it. Scroll down and look for Password Protected Sharing. If it is off, turn it on. (expand the entry for the item to see the options for on and off).

     

    Have you created a Share or shared the C drive or your Users folder? My drive on this PC is Shared, but only to my User ID from other computers. That means when it is on the home network, I can access the PC from any other PC, but no other User ID can access the files other than the Public folders or the Media folders (which are shared via Media sharing).

     

    -steve

    Monday, March 24, 2008 6:17 PM
    Moderator
  • Steve,

     

    Thank you for the good advice!  In your last paragraph, you mention "Media Folders (which are shared via Media Sharing)".  Where are the Media folders located, and how are they different than Public Folders?  How does File Sharing differ from Media sharing?  Media files are well . .  files after all.

     

    Thank you!

     

    Edited to add that no, my C: drive is not shared.  If I right click on it, it shows up as not shared.  I have not activated the password feature because then the Public folders aren't shared either, another strange decision by Microsoft.    I want the Public folders to be shared.

     

    Monday, March 24, 2008 6:29 PM
  • You can configure the media sharing and Public folder sharing in the same place - the Network and Sharing Center. Set the password protected sharing feature and enable public folder sharing if you wish. The settings can be configured in the same way - expand the entry and select the desired option. When connected to your home network, identified in OneCare as Home or Work, with File and Printer Sharing enabled by default, this will allow access to the public folders and media sharing. You can also explicitly share folders as desired and grant access to specific user accounts or *everyone* by using the Properties/Share tab for each folder you wish to Share - after you have set up Password Protected sharing. Good luck!

    -steve

     

    Monday, March 24, 2008 6:58 PM
    Moderator