locked
CRM 2013 - Import Organization issue RRS feed

  • Question

  • Hi All,

    We are trying to upgrade our onpremise version of CRM 2011 to CRM 2013  Onpremise.

    while running import Org wizard we are facing issue while user mapping and import org is not running.

    Please find the attached log file.

    Crm Exception: Message: LookupAccountNameW failed with error, ErrorCode: -2147214038
    [2015-12-22 17:23:18.990] Process: w3wp |Organization:00000000-0000-0000-0000-000000000000 |Thread:   12(Deployment-WebService-QueuedOperationProcessor) |Category: ADUtility |User: 00000000-0000-0000-0000-000000000000 |Level: Error |ReqId:  | SecurityUtils.GetSidFromAccount  ilOffset = 0x35
    >Error while retrieving SID from account <DomainName>\<UswerID>. Exception: Microsoft.Crm.CrmSecurityException: LookupAccountNameW failed with error
       at Microsoft.Crm.SecurityUtils.GetSidFromAccount(String accountName)
    [2015-12-22 17:23:19.000] Process: w3wp |Organization:00000000-0000-0000-0000-000000000000 |Thread:   12(Deployment-WebService-QueuedOperationProcessor) |Category: Exception |User: 00000000-0000-0000-0000-000000000000 |Level: Error |ReqId:  | CrmException..ctor  ilOffset = 0x7
    	at CrmException..ctor(String message, Exception innerException, Int32 errorCode, Boolean isFlowControlException)  ilOffset = 0x7
    	at CrmException..ctor(String message, Int32 errorCode)  ilOffset = 0x5
    	at SecurityUtils.GetSidFromAccount(String accountName)  ilOffset = 0x34
    	at ADUserMappingHelper.GetSidForExistingUser(User userFromDatabase)  ilOffset = 0x10
    	at KeepExistingUserMapper.MapUserAccountInfo(User user)  ilOffset = 0x0
    	at ImportUserMapper.MapUser(User user)  ilOffset = 0x29
    	at DBImportHelper.ReadUsers(IProgressEventSource progressHandler, UserAccountMapper mapUserAccountInfo, String sqlServerName, String databaseName)  ilOffset = 0x34A
    	at ImportUserMapper.MapUsers()  ilOffset = 0x14
    	at BeginImportOrganizationRequest.PerformUserMapping()  ilOffset = 0x75
    	at BeginImportOrganizationRequest.PerformDeferredProcessing()  ilOffset = 0x6
    	at QueuedOperationProcessor.ProcessingMethod()  ilOffset = 0xE3
    	at ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)  ilOffset = 0x70
    	at ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)  ilOffset = 0x4
    	at ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)  ilOffset = 0x2F
    	at ThreadHelper.ThreadStart()  ilOffset = 0x25

    Any pointers on this, please do advise us.

    Thanks!
    Siva


    Siva Polisetty||My Blog|| If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Wednesday, December 23, 2015 6:44 AM

All replies

  • This looks like it it is failing on the LDAP call to AD.  Does the user this is failing to find actually exist in AD for the domain?

    Can you attempt to map the CRM user account to another AD user?  Try creating a new test AD user account.

    If this is only happening for a single user that is being looked up, you should be able to continue past the user mapping screen.  You just need to make sure that the account being used to import the organization is mapped to a CRM user record in the organization database, and that the user record has the sys admin security role assigned.  You can always update the user record in CRM later after the import.


    Jason Peterson

    Wednesday, December 23, 2015 7:57 PM