locked
SRSS Installer not using FQDN for report server URL RRS feed

  • Question

  • Environment

    Single Win2008r2 server

    SQL 2008r2 Std - Default Instance

    Dynamics 2011 Server

     

    When I installed Dynamics the report server URL defaulted to https://hostname/reportserver.  This would generate an error.  I changed the url to https://hostname.domain.com/reportserver (which I verified was correct) and the install went without a flaw.  I also verified that http and https://hostname/reportserver would 404. 

    Now when I try to install report extensions I get the Reports will not be published for some organizations because the Report Server instances used by these organizations differ from the instance selected during MicrReports will not be published for some organizations because the Report Server instances used by these organizations differ from the instance selected during Microsoft Dynamics CRM Reporting Extensions Setup error.

    I looked at my rsreportserver.config and this is what I see (I blanked out other sensitive info)

    <Name>ReportServerWebService</Name>
                <VirtualDirectory>ReportServer</VirtualDirectory>
                <URLs>
                    <URL>
                        <UrlString>http://+:80</UrlString>
                        <AccountSid>BLANKEDOUT</AccountSid>
                        <AccountName>BLANKEDOUTr</AccountName>
                    </URL>
                    <URL>
                        <UrlString>https://HOSTNAME.DOMAIN.com:443</UrlString>
                        <AccountSid>BLANKED OUT</AccountSid>
                        <AccountName>BLANKEDOUT</AccountName>

    I tried changing http://+:80 to the FQDN but then would get a 503 error.

    Any thoughts on how to force the SRSS to used the FQDN?  I couldn't see an option in the config.xml for command line installation.

    Or is there something I can do to have RS show up using Hostname only?

     

    Thanks

    Thursday, July 7, 2011 4:34 PM

Answers

  • I finally figured out how to get past this.  I used SQL's  Reporting Services Configuration Manager and deleted the non ssl port.  The SSL url was working and I made sure it was the only one in the list.  The install went without a flaw and reports were published
    • Marked as answer by Bagomojo Friday, July 8, 2011 2:10 AM
    Friday, July 8, 2011 2:09 AM