locked
*SOLVED* WHS 2011 Connector Install - Cannot connect this computer to the network - not DNS issue RRS feed

  • Question

  • I am trying to install a the connector on a Windows 7 64 bit machine. It gets to the 'enter password' section. After entering the password, I get a 'Cannot connect this computer to the network - The server is not available. Try connecting this computer again....

    I viewed the log file and this is what comes up:

    [5352] 120927.151139.6700: ClientSetup: MachineIdentityManager.GetMachineStatus had errors: ErrorCatalog:NetworkError ErrorCode:-1
    BaseException: Microsoft.WindowsServerSolutions.Devices.Identity.MachineIdentityException: MachineIdentityManager.GetMachineStatus ---> System.ServiceModel.CommunicationException:
    An error occurred while making the HTTP request to https://media-1:65500/CertWebservice.svc. This could be due to the fact that the server certificate is not configured properly with HTTP.SYS in the HTTPS case. This could also be caused by a mismatch of the security binding between the client and the server. ---> 
    
    System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a send. ---> System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host
       at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)



    This is not the OpenDns issue that most have had as it sees the server. Plus, I have added all the entries into the hosts file as well as turned off using openDns and it doesn't help.

    Any ideas?



    • Edited by RobDiablo Friday, September 28, 2012 5:51 PM Solved
    Friday, September 28, 2012 4:48 PM

Answers

  • I fixed this issue. It seems that the connector service relies on an SSL connection to the server to get to the certwebservice.svc. However, if the connection is not bound to an SSL cert, you get this error. Here is how to fix it:

    1. I logged into the WHS server as and admin.

    2. I opened up IIS Manager.

    3. I found WSS Certificate Web Service under Sites.

    4. I right clicked it to get a menu and selected edit bindings.

    5. A Site Bindings window opens and I select the listed binding and clicked Edit.

    6. Edit Site Bindings window opens and you most likely will see that the connection is not bound to an SSL certificate and this is why we are getting the error in the first place. Select a proper certificate and Click OK then close out of all the windows except IIS manager.

    7. Right click on WSS Certificate Web Service under Sites again to get a menu and choose Manage Web Site -> Restart.

    You should now be able to use the connector service.

    Friday, September 28, 2012 5:50 PM

All replies

  • I just tried it on 2 more Windows 7 clients and I get the same issue.
    Friday, September 28, 2012 5:21 PM
  • I fixed this issue. It seems that the connector service relies on an SSL connection to the server to get to the certwebservice.svc. However, if the connection is not bound to an SSL cert, you get this error. Here is how to fix it:

    1. I logged into the WHS server as and admin.

    2. I opened up IIS Manager.

    3. I found WSS Certificate Web Service under Sites.

    4. I right clicked it to get a menu and selected edit bindings.

    5. A Site Bindings window opens and I select the listed binding and clicked Edit.

    6. Edit Site Bindings window opens and you most likely will see that the connection is not bound to an SSL certificate and this is why we are getting the error in the first place. Select a proper certificate and Click OK then close out of all the windows except IIS manager.

    7. Right click on WSS Certificate Web Service under Sites again to get a menu and choose Manage Web Site -> Restart.

    You should now be able to use the connector service.

    Friday, September 28, 2012 5:50 PM
  • I have tried this option, tried the powershell command that the microsoft site recommeds, tried the find my server program, disabled ipv6 that other forums have suggested, but nothing works. I am at my wits end with this, I can't believe something so basic is completely unusable!
    Tuesday, January 22, 2013 7:11 AM
  • I had the same error but in my case it wasn't the cert not being selected it was that the binding had the wrong IP in it. I had re-IPed my WHS a while back and didn't think about it but when checking the cert because of this post I noticed the old IP in the binding.
    Sunday, June 18, 2017 12:26 AM