locked
Cannot Restore the Backup on 2 of 5 computers RRS feed

  • Question

  • I posted in a previous thread, but did not want to hijack that fellows thread in case these problems are different, so I made my own :)

     

    Been troubleshooting this problem all day, I have made limited progress, but feel I am close to a solution. Just bought a HP mediaSmart 690, after a nightmare network setup everything seemed to be working well. Backups of three computers happened over night, and everything was in the green.

     

    Until I went to restore them. I get an error at 81 percent saying "cannot mount the backup". After searching here it's a big prob, yep got it. I think I have it solved in my situation "kinda". Is that I have 3 of my 5 computers able to restore the backups on the home server.

     

    First two when I installed the connect software, and tried to restore in the console it prompted me at 6 percent to install a "microsoft system" driver, first two machines (that restore does not work on), I just clicked ok and not "trust all devices from Microsoft. This I think is the key. The next system I clicked "no" to install the driver and realized WHS gave me the exact same error "cannot restore the Backups" interesting.  

     

    So the next three systems when I tried to restore, when it prompted me at 6 percent to install the "microsoft System" driver, I clicked yes and "trust all devices from Microsoft" and all three I did this magically worked, and restores galore!

     

    So I went back and uninstalled the first two WHS software, and have made multiple attempts to uninstall the "home server restore driver 2" driver on the first two systems, but no luck at all. I am stumped at this point.

     

    I think if I can get the restore software to give me that prompt to install the "microsoft system" driver, and check the "always trust from" that it will work on the other machines as well?

     

    Does anyone know how I could go about doing this? Or how to solve this problem?

     

    Thanks



    Thursday, December 24, 2009 12:13 AM

All replies

  • Should mention all systems are running win 7 64bit
    Thursday, December 24, 2009 12:23 AM
  • There are different methods to restore the backup - booting from the Client Restore CD for entire volumes or restoring selected files/folders from the console.
    Which version does the console show in Settings/Resources?
    Best greetings from Germany
    Olaf
    Thursday, December 24, 2009 9:53 AM
    Moderator
  • Hi Olaf,

    Console shows:

    Windows Home Server Console: 6.0.2423.0
    Windows Home Server Backup & Restore: 6.0.2423.0
    Windows Home Server Drive Extender: 6.0.2423.0
    Windows Home Server Remote Access: 6.0.2423.0
    Windows Home Server Storage Manager: 6.0.2423.0

    I can open any of the backups on the other machines, just the first two (ironically my main workstations) give me the 81 percent error. I am somewhat reassured that the backups are good, because I can restore them on the other machines.

    Also if I use the "client restore wizard" in the program files/Home server folder, it sees the backups, but I have not tried to restore them as I don't have a free drive to test this out on. My suspicions would be that it would work, and this is something to do with the mounting of the virtual drive on the (2) host computers that cannot restore properly.

    Thanks

    Thursday, December 24, 2009 3:42 PM
  • One other thing of note:

    Taking a look at the event view in the home server, it reports that the Backups have been restored sucessfully each time I attempt to look at the backup files on the 2 computers that cannot restore. Even though on the host computer it says "cannot mount the Backup" the home server is saying that everything went fine and reporting in the event viewer it went ok.
    Thursday, December 24, 2009 3:57 PM
  • Since this is already the latest version of Windows Home Server, I would recommend to register on Connect, as described in one of the pinned posts on top of this forum and issue a bug report as well as the cabs from client and server?
    Best greetings from Germany
    Olaf
    Thursday, December 24, 2009 4:35 PM
    Moderator
  • Use system restore to revert the problematic systems to a point in time before you first tried to open a backup, then try again.
    Friday, December 25, 2009 12:06 AM
    Moderator
  • Tried system restore, doesn't work in my case.

    Although I did test using the "clientRestoreWizard.exe" in the ProgramFiles/WindowsHomeserver directory on the Two computers that cannot mount the backup and it worked! So I am confident that backups are good.

    Seems to be an issue with the restore program on WHS (the driver it installs) and mounting the virtual drive. It is definitely a bug. Being so close to having a perfect backup solution, I am still going to try somethings, see if I can fix it myself.

    Maybe someone reading this has the same problem and figured out a work around?

    Friday, December 25, 2009 6:02 PM
  • In the past several of the occurences of failing access to backups through the console for single file restore have been fixed by the Windows Home Server team through patches via Windows Update. So maybe your systems have an issue with a driver or software, which intercepts in the loading process and is still not known by the team. So I stay with my recommendation to issue a bug report on Connect.
    Best greetings from Germany
    Olaf
    Saturday, December 26, 2009 10:43 PM
    Moderator
  • Yeah, I logged the bug report a few days ago. Made a link to this thread as well!
    Sunday, December 27, 2009 1:32 AM