none
Printer 'special permission' using powershell RRS feed

  • General discussion

  • Hi

    I want to enable special permission for a printer using powershell. I used subinAcl.exe to set full permission however 'special permission' is not enabled. I need your help. Thank you.

    • Changed type Bill_Stewart Wednesday, December 12, 2018 5:09 PM
    • Moved by Bill_Stewart Wednesday, December 12, 2018 5:09 PM This is not "scripts on demand"
    Friday, August 10, 2018 12:56 PM

All replies

  • Hi

    I want to enable special permission for a local printer using powershell. I used subinAcl.exe to set full permission however 'special permission' is not enabled. I need your help. Thank you.


    Friday, August 10, 2018 12:57 PM
  • Please read this first:

    This forum is for scripting questions rather than script requests

    It is the first post right at the top of this forum.


    -- Bill Stewart [Bill_Stewart]

    Friday, August 10, 2018 1:56 PM
  • help Set-Printer -Param PermissionSDDL

    \_(ツ)_/

    Friday, August 10, 2018 3:01 PM
  • Thanks for your response. how do I specify SDDL string. can I set the permission manually and take the string.
    Tuesday, August 14, 2018 4:25 AM
  • Yes, you can copy the string from one printer to another.


    \_(ツ)_/

    Tuesday, August 14, 2018 4:28 AM
  • Thank you Jrv..
     I have got the SSDL using (Get-Printer 'RightFax Fax Printer' -Full).PermissionSDDL | Out-File "C:\perms.txt".

    $perms = Get-Content "perms.txt"

    Set-Printer 'RightFax Fax Printer' -PermissionSDDL $perms

    when applying the same to printer in another machine. "Manage printer" permission is enabled but special permission is enabled now.

    am I missing something.

    • Edited by GMKarthik87 Wednesday, August 15, 2018 7:13 AM
    Wednesday, August 15, 2018 6:34 AM