locked
CRM 2011 - Enabling IFD Disables Internal Claims Based Access RRS feed

  • Question

  • Hello,

    I have CRM dev and production environments setup, both using IFD/Claims Based authentication. 

    On on of these servers, when IFD is enabled users can no longer use the internal address to access CRM, they are forwarded and prompted with the IFD login screen instead of just being logged into CRM through Claims based token.

    On our other CRM server which is setup exactly the same (we believe....), users internally can access CRM using an internal URL, it doesn't prompt for credentials and just logs them into CRM directly, and external users have the option to user the IFD url and login remotely.  Essentially Claims and IFD are both enabled and both different URLs work.

    What setting our configuration area would I look in to troubleshoot this issue?  Checking the configuration, relying parties etc. etc. on both machines, visually they are setup the same.

    I have exhausted my troubleshooting on this one and don't know where else to look, any help would be greatly appreciated!

    Thursday, October 18, 2012 2:32 PM

All replies

  • How many bindings does your CRM website have? Is there a binding to both http and https? Check both environments. Internal users can add put these urls in the intranet zone.

    I hope this helps. If my response answered your question, please mark the response as an answer and also vote as helpful. Michael Mayo

    Thursday, October 25, 2012 11:28 AM
  • We have only the HTTPS binding available. 

    On the production environment where it is working fine, internal users access CRM through:

    https://servername.domain.com:444/orgname

    External users access through:

    https://orgname.domain.com:444/

    Thursday, October 25, 2012 1:42 PM