Synctoy Echo does not seem to delete enough RRS feed

  • Question

  • I'm using SyncToy 2.1 to backup my (Window 7) main system's main data HD to a same size HD on a secondary (XP) PC. That 1.3 TB HD is about 95% full, and sees about 30% of files changing per month, which is my backup frequency.

    I'm doing an ECHO Sync, from my local D: to L: which is mapped to my backup PC's data drive.

    I've checked, D: and L: have the same size (+/- a handful of megs).

    SyncToy keeps failing with Disk Full errors. It does the 'checking" phase OK, then starts copying a bunch of files, but fails in the end.

    It seems SyncToy is too conservative about deletions, and runs out of space for new files on the backup drive because it doesn't mirror the deletions from the source drive early enough.

    I've gone back to doing xxcopy d:\ l:\ /CLONE... That's delightfully 90s, and I'm glad to see that good old command line again, but I'd still prefer SyncToy to work for me.

    Thursday, March 4, 2010 1:39 AM

All replies

  • Before doing the sync with SyncToy, did you check the files size on destination? Are you sure the delete changes did not be synced to destination previously? I think, most possible reason for your problem is that as SyncToy will delete some file when it detect some files updates/changes then re-create a new one. The deleted files will move into Recycle bin, that made disk run out of space. You may could resolve this by configuring Recycle bin setting to "Do not move files to Recycle bin. Remove file immediately when deleted". Could you please have a try with SyncToy, let me know if this workaround could help or not. Thanks, Ping
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, March 12, 2010 9:05 AM