locked
Severe CRM 3/4 reinstallation issues RRS feed

  • Question

  •  

    we had CRM 3.0, developed our solution and all was great.

    After a year, the client wants to upgrade to CRM4.0 including our solution, so I did just that except that the installation failed immediately which left CRM 3.0 and our solution in a very bad state (service unavailable in IIS for CRM site)

     

    so, I uninstalled everything, CRM 3.0, SQL Server 2000 and 2005 and restarted.

     

    Installed SQL Server 2000 Ent and SP4

    installing CRM 3.0 and I get an error on MS SQL Server Reporting Services:

     

     

    Could not find row in sysindexes for database ID 7, object ID 1, index ID 1. Run DBCC CHECKTABLE on sysindexes.

    Could not open new database '216d57737043518ae33a376d8833cf'. CREATE DATABASE is aborted.

     

     

    I have NEVER had this before nor do I know what to do

     

    any ideas?

    Thursday, July 3, 2008 2:41 PM

All replies

  • Sorry to hear about your upgrade troubles.

    did you backup your crm 3.0 database and metabase prior to the upgrade.  I recommend restoring a backup then when you install CRM 3.0, choose the connect to exsisting database option.

    Once you get your crm environment restored, I would recommend upgrading it to a SQL 2005 database prior to performing the 4.0 upgrade.  I've found it goes better this way because you don't have to do a CRM upgrade and a SQL upgrade at the same time.  Here's a white paper with all of the details:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=709F9CC7-8D53-45E8-B853-1F9E733F9774&displaylang=en

    During the upgrade there are changes made to the database and if something fails, you cannot roll it back in some cases.  That's why backing up is critical.

    When upgrading to 4.0, always back up the database and metabase first, and always test the upgrade on a test environment or a virtual first to identify any potential upgrade problems and avoid crm outages for users.

    Since you are down, I would strongly recommend setting up a Microsoft support case and letting them know it is urgent--they will help get you back up.
    Thursday, July 3, 2008 3:41 PM
    Moderator
  • Thanks Joel, I appreciate this.

     

    Well this is the thing here. I should have the database files, I'm not sure. I located them in the SQL Server directory, whether they are the original database files, or new ones I am not sure because I didn't do a backup myself. I do have the entire system backup...so guess I can retrieve it from that.

     

    Now, I DID upgrade SQL Server to 2005, applied SP2, then started CRM 4.0 upgrade installation. I told it to download the updates, it did this, went through the entire wizard then IMMEDIATELY after the last screen on the summary page it failed. This was without file copying or anything.

     

    So, I then re-ran the setup but without downloading the updated files. Went through it, then half way through it failed (can't remember the error now) and left CRM 3.0 in a bad state (unavailable service) so some of CRM 4.0 overwrote 3.0 files and didn't rollback.

     

    So then, I uninstalled CRM3.0, SQL Server 2000 and SQL Server 2005, rebooted, then installed SQL Server 2000 Enterprise with SP4, then ran the CRM3.0 setup and this is the error I get above and cannot continue.

     

    what can I do now? I just don't get why it's throwing that error on Reporting Services when I stated for it to install new reporting service

     

     

    edit: I restored the database (attached it) and STILL Get the same error on Reporting Services.

    Thursday, July 3, 2008 7:33 PM
  •  

    fixed it.

    delete the ReportServices database files in the Data directory in SQL Server folder..... now im installing CRM 3.0 - yay!

    Thursday, July 3, 2008 8:04 PM
  • Just wanted to add my 2 cents to this fiasco...

    Ran into the same issue with the upgrade to CRM 4 but I had backed up everything.

    After atempts of full restores of DB (from both .bak and detached ldf's and mdf's), was still getting service/server unavailable. Went through full check of permissions and access to DB and still no luck.

    Went the route of full uninstall and reinstall and still, damn 503 server unavailable but here is the kicker...finally decided to look up error WITHOUT reference to CRM 3 and pointed me to look at the httperror log %systemfolder%/system32/logfiles/httperr (C:\WINDOWS\system32\LogFiles) and voila...the CRMAppPool application pool was disabled!!!!! So went into IIS -> Application Pools -> CRMAppPool right clicked and click start...the web came back up!

    Not too sure if this would have saved me right from the beginning (i.e. right after CRM 4 failed upgrade) but it's a possible heads up for all to look at.

    HTH

    Dave

     

    Saturday, September 6, 2008 4:16 PM
  • Starting the application pool will work with out the reinstall of 3.0.  This lets the install move forward.  I have encountered other issues, not sure if they are related.

    Wednesday, September 24, 2008 4:56 PM