locked
wrong language assigned to webpages RRS feed

  • Question

  • My page is showing up as being in Spanish in the Webmaster Center, even though it is English and that is clearly indicated in the header info of the page. My site shows up fine in Google and Yahoo, but will not show up in Live searches because of this language problem. Is there any way to get this corrected? My site does have one Spanish page, but that one is marked as Spanish and correctly indexed by other engines.

    Wednesday, September 17, 2008 2:50 AM

Answers

  • Hi,

     

    It is possible that it is confused due to the amount of Spanish on the homepage. Have you tried seperating this and just adding a link to the Spanish version?

     

    Brett
    Friday, November 14, 2008 4:39 PM

All replies

  • Hi,

     

    Can you verify that your servers aren't hosted in a spanish speaking region?

     

    Wednesday, September 17, 2008 6:06 PM
  • The site is http://westernamazon.org

    Here is the <head> of the index.html page:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta name="verify-v1" content="aE2Jnm8WI/om/EJPZrZEfH10itcxOSlZVtQ7+unxzkQ=" />
    <meta name="y_key" content="77135757658dba61" />
    <meta name="msvalidate.01" content="276C3C7243C74A6CBDEE90692831F9BE" />
    <title>Western Amazon home page</title>

    <style type="text/css">
    <!--
    @import url("testing.css");
    -->
    </style>
    <link href="testing.css" rel="stylesheet" type="text/css" />
    <style type="text/css">
    <!--
    body {
    background-color: #333333;
    margin-top: 0px;
    }
    a:link {
    text-decoration: none;
    }
    a:visited {
    text-decoration: none;
    }
    a:hover {
    text-decoration: underline;
    color: #0000FF;
    }
    a:active {
    text-decoration: none;
    }
    .style86 {color: #FF0000}
    .style87 {color: #660000}
    .navbar {color: white;}
    .style88 {
    font-size: 18px;
    font-weight: bold;
    }
    -->
    </style>
    <meta name="Keywords" content="amazon, oil, gas, roads, hydrocarbons, rainforests, indigenous, biodiversity, forests, Peru, Ecuador, Colombia, Bolivia, Brazil" />
    <meta name="Description" content="The latest information on biodiversity conservation, oil development, and indigenous rights issues in the western Amazon." />
    </head>
    Thursday, September 18, 2008 1:16 PM
  • The servers shouldn't be in a Spanish region, unless something is very odd. Also, I see that more pages are now indexed by Live, and at least one of them is showing up as Portuguese. It could be because there are links to Portuguese news articles, and there is some Portguese on that page, but there are also other languages.
    Thursday, September 18, 2008 1:21 PM
  • Thanks! I've added the tag and will see if Live picks up on it.
    Friday, September 19, 2008 6:00 PM
  • The site was finally recrawled again, but no luck in the language being detected correctly. This is really lame. It seems such a basic thing to get correct since search engines often filter by language.
    Wednesday, October 8, 2008 2:46 PM
  • Hi,

     

    It is possible that it is confused due to the amount of Spanish on the homepage. Have you tried seperating this and just adding a link to the Spanish version?

     

    Brett
    Friday, November 14, 2008 4:39 PM