sticky
Known issues for Microsoft Hyperlapse Pro RRS feed

  • General discussion

  • Here is a list of known issues for version 1.0 of Microsoft Hyperlapse Pro:

    • When opening a video, Hyperlapse Pro reports "We're sorry but we couldn't open the video file. Error was: Could not load file or assembly 'Hyperlapse.Native.dll' or one of its dependencies. The specified module could not be found."
      Hyperlapse Pro requires the Visual C++ Redistributable Packages for Visual Studio 2013 to be installed on your system.  Hyperlapse Pro's installer should prompt you to install this package if you don't have it, but if you see this error you can install it manually from this location:
      http://www.microsoft.com/en-us/download/confirmation.aspx?id=40784

    • Hyperlapse Pro hangs on "Opening video" if you have never launched Windows Media Player.
      If you haven't run Windows Media Player and accepted its license agreement, then Hyperlapse Pro will appear to hang on the "Opening video" page.  To fix this problem, just close Hyperlapse Pro, launch Windows Media Player, accept the license agreement, and restart Hyperlapse Pro.

    • Hyperlapse Pro hangs on "Opening video" when running over remote desktop.
      Sometimes the video preview doesn’t appear when running Hyperlapse Pro over a remote desktop connection.  To work around this problem, try the following:
      • Start the Remote Desktop Connection but don’t connect to the remote computer.
      • Select “Show Options.”
      • Select the “Local Resources” tab.
      • Under “Remote audio,” click the “Settings…” button.
      • Under “Remote audio playback,” select “Play on remote computer.”
      • Now try connecting to the remote computer and running Hyperlapse Pro.

    • Hyperlapse Pro cannot load videos with resolution greater than 1920x1080 on Windows 7.
      This is currently a limitation when running Hyperlapse Pro on Windows 7.  For best results on Windows 7, we recommend shooting your videos at 1920x1080 resolution or lower.

    • Hyperlapse Pro cannot save videos with resolution greater than 1920x1440 on Windows 8+.
      This is currently a limitation when running Hyperlapse Pro on Windows 8 or Windows 8.1.  Hyperlapse Pro can load videos with higher resolution, but it can only save videos with resolution 1920x1440 or lower.

    • Windows 10 is officially supported in Hyperlapse Pro version 1.2, but make sure your drivers are up to date.
      We have verified that Hyperlapse Pro 1.2 works on Windows 10, but we have seen GUI problems with buggy drivers.  If the GUI stops responding, try updating your video drivers.

    • Hyperlapse Pro may fail when processing very short videos.
      Hyperlapse Pro is designed to make long videos shorter.  It may fail when processing videos that are already very short in duration.

    • Advanced Smoothing may fail when processing videos with little or no camera motion.
      Hyperlapse Pro’s Advanced Smoothing mode is designed to process videos in which the camera is predominately moving forward.  It may fail when the camera is not moving much, such as when shooting with a tripod.  If Advanced Smoothing fails, select Standard Smoothing and restart the processing.

    • Hyperlapse Pro cannot auto-detect all types of action cameras.
      In order to apply Advanced Smoothing, Hyperlapse Pro needs to know the camera model that shot the video.  For many camera models (e.g., most GoPro cameras), Hyperlapse Pro can detect the camera model from metadata in the video file.  If Hyperlapse Pro does not detect your camera model, try selecting your camera model and shooting mode from the drop-down menus under Camera Options.  If your camera is not listed, you must use Standard Smoothing.

    • Hyperlapse Pro cannot auto-detect the camera after the video has been processed with some other software.
      Processing your videos in other software (e.g., to trim the length) might remove the metadata that Hyperlapse Pro uses to detect the camera model that shot the video.  If this happens, you can manually select the camera model and shooting mode by using the drop-down menus under Camera Options.

    • Hyperlapse Pro's installer might report that the Visual C++ 2013 runtime libraries are not installed even though they are installed.
      If this problem occurs, try installing Hyperlapse Pro using an elevated command prompt.  Start cmd.exe using "Run as Administrator" and execute the command "msiexec.exe /i path-to-hyperlapse-msi" to install Hyperlapse Pro as Administrator.

    • Opening a Hyperlapse Pro project (.hyp file) while another project is already open can cause inconsistent back-button behavior.
      This is a bug in Hyperlapse Pro, and it will be fixed in a future release.  In the meantime, try not to open project files while another project is already opened.

    If you have a problem with Hyperlapse Pro that is not listed here, please post a new message using a subject line that is specific to your issue.  It's also helpful to describe what you were doing when the problem occurred, which operating system you use, what type of camera you're using (e.g., GoPro HERO3+ Black), and what settings you selected (e.g., 10x speedup).







    • Edited by Chris Buehler Friday, July 31, 2015 10:41 PM Updates for version 1.2
    Wednesday, May 13, 2015 9:12 PM

All replies

  • Hi Chris, 

    Consider amending the first issue regarding Window Media Player to include that "if the app just hangs on 'Opening video'".  As that was my problem and installing WMP fixed it for me.

    Thank you,

    John

    P.S. Feel free to delete this.

    Friday, May 15, 2015 12:53 AM
  • I am using it on Windows 8.1 x64 Pro

    Settings was Sony HDR AS100VR, STD, Housing on, Speed up 10x, Advanced, Resolution 1280x720, 60 FPS.

    It started doing its magic but after a while it just closes


    • Edited by LembitM Friday, May 15, 2015 11:44 AM
    Friday, May 15, 2015 11:42 AM
  • Windows 7 64-bit

    Gopro Hero 3 Black Edition, Speed 8x, Advanced, Resolution 1280x720, 30 FPS

    Tried with a 7 min recording of a paragliding trip, took it time to work through the process phase, and ended up with a all-black video of the right length with the watermark and the Microsoft ending. Tried to change the settings to 10x in the same project and it this time the process was faster, but I only got a shorter dark movie.

    Friday, May 15, 2015 8:56 PM
  • I have a similar problem on Windows 7 x64 Home Premium with the following settings: GoPro HERO3 Black; Wide; 8x; Advanced; 1280x720; and 60FPS. Both input and output video files are located on the local disk. I can also reproduce this error with two separate machines and with multiple video files.

    My problem

    Hyperlapse starts to process input video, but after a while it closes (without any message). From application log I found the following error:

    Application: Microsoft.Research.Hyperlapse.Desktop.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.AccessViolationException
    Stack:
       at <Module>.Hyperlapse.process(Hyperlapse*, std.shared_ptr<HyperlapseParams>*, std.shared_ptr<VideoSfM::VideoTrackerParams>*, std.shared_ptr<PathParams>*, std.shared_ptr<ProxyRenderParams>*, std.shared_ptr<WarpParams>*, std.shared_ptr<SelectParams>*, std.shared_ptr<FuseParams>*, std.function<void __cdecl(std::basic_string<wchar_t,std::char_traits<wchar_t>,std::allocator<wchar_t> >,float)>*)
       at <Module>.Hyperlapse.process(Hyperlapse*, std.shared_ptr<HyperlapseParams>*, std.shared_ptr<VideoSfM::VideoTrackerParams>*, std.shared_ptr<PathParams>*, std.shared_ptr<ProxyRenderParams>*, std.shared_ptr<WarpParams>*, std.shared_ptr<SelectParams>*, std.shared_ptr<FuseParams>*, std.function<void __cdecl(std::basic_string<wchar_t,std::char_traits<wchar_t>,std::allocator<wchar_t> >,float)>*)
       at HyperlapseNative.HyperlapseEngine.Process(Int32, System.String, System.String, System.String, System.String, Int32, Int32, Int32, Int32, Int32, Int32, Int32, System.String, Int32, Boolean, Boolean, Single)
       at Microsoft.Research.Hyperlapse.Desktop.HyperlapseEngine+<>c__DisplayClass4.<RunHyperlapse>b__3()
       at System.Threading.Tasks.Task.Execute()
       at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
       at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
       at System.Threading.Tasks.Task.ExecuteWithThreadLocal(System.Threading.Tasks.Task ByRef)
       at System.Threading.Tasks.Task.ExecuteEntry(Boolean)
       at System.Threading.ThreadPoolWorkQueue.Dispatch()

    I would be very keen to test this software, but because of this bug (?) I am not able to do it at all.

    Thank you!

    Marko

    Saturday, May 16, 2015 5:40 PM
  • Hello there, I'm very pleased that the software is finally out as a beta, been waiting for ages!!!

    Slight problem though, I'm unable to load MOV files into it, both Gopro Cineform codec & Avid DNxHD.

    Both give the error- "Error was: Cannot open video file" (not exactly massively descriptive).

    All files I try are 1920x1080, but the application will only so far load mp4 files.

    Is this a fault or a feature?

    Cheers

    Mark

    Saturday, May 30, 2015 4:00 AM
  • Did any resolution get advised for this.  I have exactly the same issue.  Bit frustrating when the Hyperlapse app is clearly reading and displaying all the frames, and 3 hours later you get a 1:45 black video.
    Tuesday, June 16, 2015 10:59 PM