locked
WHS shows antivirus as not installed or out of date when windows 7 PC's are turned off RRS feed

  • Question

  • since upgrading all my home PC's to windows 7, they all get reported as having critical antivirus status when they are turned off. i did think it was an AVG issue as they all run AVG, but i recently added a PC running McAfee and have the same problem! i have tried disabling the action centre monitoring of antivirus... Am i doing something silly?
    Sunday, December 27, 2009 10:04 AM

Answers

  • Here is a Workaround:

    Stop the WHS Connecter Service prior to shutting down your computer.

    Open an elevated Command Window and type:

    sc stop WHSConnector


    The WHS Notification App will turn grey and you should able to shut down your computer without getting any warnings about your AV.


    William Crawford
    Sunday, January 17, 2010 8:46 PM

All replies

  • since upgrading all my home PC's to windows 7, they all get reported as having critical antivirus status when they are turned off. i did think it was an AVG issue as they all run AVG, but i recently added a PC running McAfee and have the same problem! i have tried disabling the action centre monitoring of antivirus... Am i doing something silly?
    Does it ever show your clients' AV apps as being up-to-date?  In other words, does it show the clients are up-to-date while they are on, then go to critical only after turning the clients off?
    Monday, December 28, 2009 3:00 AM
    Moderator
  • Yes, that's exactly what happens. provided all the pc's are on i have no errors at all. i can click to ignore the errors, but as soon as a pc is turned on i get the error back for a few seconds and then it clears. when the pc is turned off again the error returns and i have to click ignore again!
    Monday, December 28, 2009 9:54 AM
  • I'm having the same problem!  I just replied to this thread about the same topic:

    http://social.microsoft.com/Forums/en-US/whssoftware/thread/cb8d9efa-22fb-43cf-a14c-189ff88b6d5b

    Unfortunately, it looks like neither of these threads has a solution or any indication that MS is working on fixing the problem :-(
    Sunday, January 17, 2010 12:23 PM
  • Here is a Workaround:

    Stop the WHS Connecter Service prior to shutting down your computer.

    Open an elevated Command Window and type:

    sc stop WHSConnector


    The WHS Notification App will turn grey and you should able to shut down your computer without getting any warnings about your AV.


    William Crawford
    Sunday, January 17, 2010 8:46 PM
  • Seriously though... shouldn't the connector software do this for you!

    To have to do this everytime you shutdown a PC is ludicrous.

    WHS is meant to be a "simple" home user solution. So far for me, its been anything but simple.

    Its these little things like this that take away from the whole experience...

     

     

    Tuesday, June 15, 2010 4:01 AM
  • It's not as good as a REAL solution, of course, but here's another workaround that's pretty straightforward:

    Disclaimer: This is really only feasible for laptops.

    Before shutting down the laptop, disconnect its networking first. If it is wired, unplug the ethernet cable. If it is wireless, switch off the antenna or disconnect from the wireless network using the network tray icon. With the networking yanked, the WHS connector cannot "phone home" while the computer shuts down, and nobody gets critical alerts.

    I know it's irritating to have to change your behaviour for a piece of buggy software, but I figure you're going to be unplugging cables when you pack up the laptop anyway - so just change the order in which you pack it up - remove the ethernet cable BEFORE you shut down instead of AFTER. With wireless, it's an extra step I guess, but my laptop has a wireless antenna switch on the right side of the laptop. It's very easy to flip that switch before shutting down. The hard part is remembering to do so.

    I tried setting the Security Center service to depend on the WHSConnector service, so that when Security Center shuts down, it takes WHSConnector down with it, but that didn't seem to work. Did the same with the individual antivirus services. No joy there either.

    The core of the problem is that when this software was released, XP and Security Center behaved a certain way, and WHS Connector was written to use that process. Now Vista and 7 are in the mix, and they behave differently, and MS has not adjusted for that yet.

    Saturday, June 19, 2010 5:10 AM
  • I know that this problem has been discussed on various forums for quite some while, but in case somebody is looking for a solution, here is one that worked for me:

    Change the Security Center service from startup "Automatic Delayed" to "Automatic":

    • Start
    • Run
    • Type "services.msc"
    • Find "Security Center"
    • Stop the service
    • Change the startup mode to "Automatic"
    • Restart the service.

    It only needs to be done on clients running Windows 7 or Vista, as XP already has the Security Center starting up in Automatic mode.

    Now what happens, is that when one of the connected computers are shutting down, the health indicator on the other computers briefly turns red, but as soon as the shutdown sequence is finished, the indicator turns green again.

    //Tom

     

    Tuesday, August 24, 2010 12:59 PM
  • I wish that worked for me, but it doesn't. Whenever I shut down my Windows 7 PCs, the connector icon turns red and stays that way on all my other PCs. Eight hours later, it will still be red on any PC that is on.

    I can go into the WHS Console and check the alert to ignore it, but it gets old when PCs are getting turned on and off many times during the day. 

    Wednesday, August 25, 2010 1:08 AM