none
hard to get to the msdn forums home

    Question

  • i cannot find the MSDN forums home (the home for the developers forum). when i click on the "forums home" on this page it takes me to a different forum (something with CRM, blabla). i think it should be easier to go to the forum i want
    Lucian Baciu, http://studentclub.ro/lucians_weblog
    Saturday, March 28, 2009 1:32 PM

All replies

  • It is an old problem, this forum is shared between the different "brands".  It frequently forgets where "home" is.  The best way to find home back is through a bookmark on your browser toolbar.  I used My Threads as home until it fell apart.  The new My Forums could be a good target.
    Hans Passant.
    Saturday, March 28, 2009 2:24 PM
  • Hi Lucian,

    Hans is correct in that this forum is a shared forum between brands (we have 5 brands right now: MSDN, TechNet, Expression, Microsoft and Answers).
    Each forum has a "default" brand as well for this forum it happens to be the generic "Microsoft" brand, this is used for crawling and alerts, so if you get an email alert for a thread in this forum the link will take you to the Microsoft branded version.   Whenever you press the link for "Forums Home" you're going to get the default brand in this case Microsoft.

    Since I'm a heavy user of MSDN brand I have a bookmark for the MSDN home page.
    Sam Jarawan - Senior Development Lead - Server and Tools Online
    Saturday, March 28, 2009 5:45 PM
  • Sam, can't this be fixed? If I come here form my Inbox to a MSDN forum, I'd expect that when I click on Forums Home I will go to MSDN Forum home.

    Also, I'm no sure if changeing the forum's address so often is a good idea. I used to come here from Google. Now google points me to another page (the default page you were talking about in your post). I think users should be able to find these forums the way they're used to, I do not want to save the page's address to every computer I use.

    Lucian Baciu, http://studentclub.ro/lucians_weblog
    Saturday, March 28, 2009 9:06 PM
  • The problem is we don't know you want to go to the MSDN version of this, other users of this forum may be users of Expression/Technet or one of the other brands. 

    This should be very low impact to our users since very few forums are shared across brand besides this suggestion forum.

    We try to provide redirects if a page is changed, we have missed some cases and will try hard to limit and changes in the future. 


    Sam Jarawan - Senior Development Lead - Server and Tools Online
    Saturday, March 28, 2009 9:25 PM
  • I don't know.  It seems to work for me.

    What is near the top of the page is:  Microsoft TechNet > Forums Home > Using Forums > Suggestions and Feedback for the Forums >, not Microsoft > Forums Home > Using Forums > Suggestions and Feedback for the Forums >.

    But I am not sure what the default, or alternative paths would be.
    Saturday, March 28, 2009 9:40 PM
  • The problem Lucian is having is that the email alerts will take you to the microsoft brand where the URL looks like http://social.microsoft.com/forums but he's an MSDN user so he'd prefer it take him to http://social.msdn.microsoft.com/forums.

    So his breadcrumg looks like different than yours and when he clicks "Forums Home" it takes him to the first URL and not the MSDN one.

    Maybe you'll get an email alert for my reply and then click on the link and you'll see what we mean.
    Sam Jarawan - Senior Development Lead - Server and Tools Online
    Saturday, March 28, 2009 9:45 PM
  • Sam:

    Maybe this is tricky for the breadcrumb.

    But I have suggested elsewhere that you add Forums Home to the My Forum Links list on the right side. For this usage, you could then add an entry in My Settings that specified what your preferred brand was.

    Or you could add the home page for all the brands in the My Forum Links.

    The right hand column is greatly underused, IMHO, and most of what is there is (for me) useless -- Tag Cloud, Recent XXX, Statistics...


    David Wilkinson | Visual C++ MVP
    Saturday, March 28, 2009 10:20 PM
  • Ya that's interesting I'll chat with our PM about it next week and have him do some research on it.
    BTW you can turn off tag cloud now, we'll also have the ability to turn off statistics and recent XXX soon as well.
    Sam Jarawan - Senior Development Lead - Server and Tools Online
    Saturday, March 28, 2009 10:30 PM
  • The original issue reported was "when i click on the "forums home" on this page it takes me to a different forum (something with CRM, blabla)."...this doesn't sound like a default brand issue, unless I'm not understanding it. I like the idea of letting the user declare their default brand to preserve context when coming from a live alert url however another place we use default brand is for search crawling, so we don't expose the same cross brand forum as duplicate search results. In that search result case, we'll always go to the default brand. But a default user brand preference would solve the rss and live alerts issue where a user wants to define brand context. I think once you are in the browser looking at the forums "Forums Home" in the eyebrowe should always take you to the forums home for the current brand you are in.


    Brent Serbus STO Forums Program Manager
    Saturday, March 28, 2009 10:42 PM
  • I don't know.  It seems to work for me.

    What is near the top of the page is:  Microsoft TechNet > Forums Home > Using Forums > Suggestions and Feedback for the Forums >, not Microsoft > Forums Home > Using Forums > Suggestions and Feedback for the Forums >.

    But I am not sure what the default, or alternative paths would be.

    Hi!

    Yeah, it seems like the problem is when I come here from a Live Alert. Instead of Microsoft Technet or MSDN i have Microsoft as the first link. If this could be fixed with a breadcrumb or something in the mail, it would be great.

    Also, I cannot find the MSDN Forum in the search engine. Probably because the link is changed so often. The changeing of the link should be stopped.
    Lucian Baciu, http://studentclub.ro/lucians_weblog
    Sunday, March 29, 2009 12:48 PM
  • Also, I cannot find the MSDN Forum in the search engine. Probably because the link is changed so often. The changeing of the link should be stopped.
    Lucian Baciu, http://studentclub.ro/lucians_weblog

    Let's get rid of "social" in the URL and then stop changing it :-).

    David Wilkinson | Visual C++ MVP
    Sunday, March 29, 2009 2:21 PM
  • I see what you mean, now.

    After following a link in "My Threads", the thread I was in was shown at the top as being under Microsoft > Forums Home > Windows 7 Miscellaneous.

    None of the Windows 7 forums appear on Microsoft > Forums Home.

    The ones I participated in were under Technet Forums.  There are others under MSDN.

    This needs to be cleared up for those who use forums on more than one brand.  You could at least have links to the other brands from Microsoft > Forums Home.

    By the way, http://social.msdn.microsoft.com/Forums/en-US/categories.

    Sunday, March 29, 2009 9:17 PM
  • I see what you mean, now.

    After following a link in "My Threads", the thread I was in was shown at the top as being under Microsoft > Forums Home > Windows 7 Miscellaneous.

    None of the Windows 7 forums appear on Microsoft > Forums Home .

    The ones I participated in were under Technet Forums.  There are others under MSDN.

    This needs to be cleared up for those who use forums on more than one brand.  You could at least have links to the other brands from Microsoft > Forums Home .

    By the way, http://social.msdn.microsoft.com/Forums/en-US/categories .


    This is Correct. You can get your forums via this way.
    asp development
    Tuesday, March 31, 2009 8:07 AM
  • This is a real problem.

    There needs to be a path to all of the branded forums from the "main" forum, http://social.microsoft.com/Forums/en-US/categories.

    To me, it would make sense to have paths such as Microsoft > Forums Home > MSDN > . . . , and Microsoft > Forums Home > Technet > . . . .

    Do away with the same forums appearing under multiple brands.  It is too confusing.
    Tuesday, March 31, 2009 5:30 PM
  • > Do away with the same forums appearing under multiple brands.

    In one way this would be a good idea. You could search on the MSDN forums and search on the TechNet forums without getting the same answers ...

    But as far as forum moderation goes (given the present Move system) it would be a disaster.

    Some of the forums I want to move to are in TechNet and some of them are in MSDN. With my forums (SharePoint) in both MSDN and Technet it's a nuisance as I have to change from TechNet to MSDN and vice versa but I can move off-topic posts to the correct forum.

    If the SharePoint forums were only (say) in TechNet then I couldn't move off-topic posts to any MSDN forum. They would (if the forum I wanted to move them to was in MSDN) have to go to Off-Topic.

    Off-Topic of course would have to be in both :)

    WSS FAQ sites: WSS 2.0: http://wssv2faq.mindsharp.com WSS 3.0 and MOSS 2007: http://wssv3faq.mindsharp.com
    Total list of WSS 3.0 and MOSS 2007 Books (including foreign language titles) http://wssv3faq.mindsharp.com/Lists/v3%20WSS%20FAQ/V%20Books.aspx
    Wednesday, April 1, 2009 5:22 AM