Home Server pc restore fails - but fixed! :)

    General discussion


    Hi all!

    I've been running Home Server since Beta 1, and absolutely love it. I tried restoring a couple of pc's on the early versions, and it usually worked like a charm. Now the other day, I had the family's main Vista (Home Premium) computer fail on me, something Apple/Quicktime/iTunes-related I guess: It started with the iTunes Helper app failing on every user logon, and then iTunes not starting at all.

    I tried uninstalling Quicktime and iTunes, but those uninstalls would fail/not start - even going to the Apple website to download a newer version would crash the browser, so I was getting fed up and wanted to restore the whole pc without any more hassle..


    (now to the real problem.. thanks for still reading.. Smile)

    I'm running the OEM version of WHS, btw, not beta! The WHS computer is an older AMD-based 1.6GHz machine with 1,2GB RAM and two IDE HDDs (80, 320GB) and one USB (200GB).

    The Vista computer is a newer AMD based computer, MSI K9N Neo motherboard and Nvidia Nforce 550 chipset, sporting a SATA RAID controller which caused me a bit of hassle when I initially installed it with two 250GB HDDs in RAID 1 mode:

    I had to provide drivers during the Vista install. OK.

    Later, the mirror would break, which caused all partitions (C, D, E) to show up TWICE (as F, G and H!) - sometimes files were updated on the first set, sometimes on the last, causing data loss when the mirror was rebuilt... Frustrating!

    Windows Update (nvidia) later supplied updated driver which solved this problem.

    However, I found myself in need of more storage, so I decided to abandon the whole RAID setup and disabled it in BIOS. Doesn't really need the RAID; I've got WHS, right!? Smile


    Anywho, this time I was in need of a complete restore, and is where the fun begins.

    I popped in the Windows Home Server Restore CD, booted and proceeded with choosing the correct backup set and partition (C) to restore. Everything went fine, the computer restored ok and after the restore, restarted ok.

    Then the computer refused to boot, displaying an error message "A disk read error occurred. Press Ctrl-Alt-Del to reboot"

    I later tried the process again, this time providing drivers on a USB stick from the "Windows Home Server Drivers for Restore" folder in a backup set on the WHS, thinking that the storage driver was somehow causing the partition to restore corrupted, but I got the same result.


    After trying restoring a couple of times, I gave up and starting googling the error. Couldn't really find any discussion of this same problem, but I tried a few pointers, like confirming that the HDD's were set up with LBA mode instead of LARGE. This was the case.


    In the end, I popped the Vista install CD, it listed NO partitions available for repair. I tried loading drivers from the aforementioned "Windows Home Server Drivers for Restore", but couldn't load a single one. However, I was able to continue, and chose "Repair". The HDD started working for a few seconds, Vista reported that it had done it's thing and I restarted the computer. Chkdsk kicked in, listing a LOT of bad sectors and lost indexes, so I had no hopes of it starting. However, it DID restart, and seemed to be working like a charm! Not sure if there's any data missing, though.


    I logged on and there was no iTunes Helper error! I updated Vista with the latest tirage of QFE's, and iTunes was running just fine...


    Now, what have I learned from this experience? Well, for one thing - Windows Home Server doesn't solve any and all problems for everyone. Sometimes the local computer-wiz will have to step up and solve some problems that "most people" just can't solve for themselves.


    The second thing was that, despite all this calamity with the restore, I've still saved a huge amount of time as opposed to reinstalling and setting everything up as it was, for five people! And just in time too, the kids are back tomorrow! Smile


    Now I'm just gonna enjoy the rest of my weekend...


    All the best,


    Sunday, February 17, 2008 4:26 PM

All replies

  • Glad you got it fixed.  My Restore also didn't work and I had to resort to "system restore" and redo a project (6 hours).  Honestly I spent 30 hrs trying to get WHS "restore" to work.  The latest updates (Feb12th) seemed to fix the problem.  I also got a note from Microssoft..."Known Issue"...Wish they had let me know before I wrote them, or posted something in the "know Issue" section.  Might have saved both of us alot of time and frustration???
    Sunday, February 17, 2008 5:18 PM