Do I need the "Drive Extender Migrator Service" (or mrxsmb)? RRS feed

  • Question

  • Can anyone tell me what this service does exactly?

    It (and mrxsmb) are not running. The only results I know of so far are that the console won't open for me and Remote Nofification has stopped sending out nightly reports.
    I haven't been on-site there yet to see if PCs are backing up or not (but then again, how would I know?).
    It seems users CAN get to their shares & files or they'd have called mew by now!

    The full text of my original (unanswered question) is below.


    I recvd an error from my WHS "Remote Notification" plugin that "The Drive Extender Migrator Service is not running".  I tried to restart the service it but it will not start. (Error 1053: Did not respond.)

    When I look in the event viewer, under SYSTEM, I see that the mrxsmb service not starting.  Also now my WHS console will not run.

    I rebooted the server and still see a warning before logging in that a service did not start but now in the event viewer I don't see any NEW failures, but of course the Drive Extender Migrator Service is still not running and the console still will not start.

    I WAS having a problem where a .NETframework update failed to install over and over again and the only way I 'fixed' it was to uninstall the .NETframework. (Which now shows up as an OPTIONAL update.)

    Any ideas?  So far all I've seen is folks reinstalling the OS for this sort of error fix.

    BIG QUESTION: Come tomorrow, Monday am, can users start using the server to get their shared folders or should I not allow them to work tomorrow if this is not resolved?

    Thx all.

    Tuesday, May 24, 2011 2:16 PM

All replies

  • Sounds like you have some serious problems. Could be both issues (mrxsmb and demigrator service) are unrelated, AFAIK both of them do not depend on each other. Also AFAIK both services are not dependant on .NET framework. You may first ry reinstalling .NET framework.

    Most likely cause for demigrator service failing to start is missing or failing harddrive. When you have duplication enabled for all shares users will still be able to access the shares, however if demigrator service is not running newly added or changed files will no longer be duplicated. If possible please logon to the home server desktop and check for issues with disks (Start, Run, diskmgmt.msc). If there's issues with a disk shut down the server, remove disk and reboot, check if demigrator service is running again and if you can connect to WHS console. Also please check if there's sufficient free space on each of the drives / partitions, especially C and D partitions.

    Also please check eventlogs on the server in detail, especially just before this issue first occurred. Please post detailed content of event log entries (errors or warnings)  If there's no other issues in any of the event logs pointing to a possibly related issue I suggest you try running chkdsk on all disks / partitions in your server. Please note this may take a significant amount of time, especially if serious errors are found.

    If this doesn't resolve the problem I suggest you try a server reinstall (after running chkdsk).

    Henk Panneman - http://www.homeserverweb.nl
    Wednesday, May 25, 2011 3:13 PM
  • Had to wait til tonight to open the server and explore a bit to see what is going on and try your notes above.
    (It is Friday night, nobody needs access to the files til Monday)

    There are (3) 1T drives in the server.
        drive0 has the OS on (Drive C) and a Data (Drive D)
        drive1 just part of the data pool
        drive2 just part of the data pool

    Disk Management shows 3 healthy drives.

    With all 3 drives connected clients can access files.
    Connect drive0 only, disconnect drives 1 & 2, client cannot open a recent file. Permissions error.
    Connect drive0 & drive2 only, same thing, client cannot open a recent file. Permissions error.
    Connect drive0 & drive1 only, and now that file is accessable for the client.

    As long as drive1 is connected this client can open a recent file.

    Sounds like drive1 is the only one worth keeping.
    (I wonder if using 1 client with 1 recent file is a good enough test of a drive's worthiness!)

    I plan on returning next Friday w/ 2 new 1T drives.

    2 questions:
        1- Is this a good situation in which to run that checkall.cmd - Seems like it is, but I do not want to take any chances.
        2- Assuming I shouldn't run checkall.cmd or I do and it fails to help:
        What would be my best procedure to follow to reinstall WHS OS and have it use files from my known(?) good drive?

    Thank all.

    Friday, June 3, 2011 10:46 PM