locked
Additional sites on WHS V1 IIS - Authentication RRS feed

  • Question

  • I have added a couple of web sites to my WHS.  Nothing too big, just a basic HTML web page for a course my son takes.

    First, I created a new share on my WHS so that my son can go on, update his HTML then test his work.  Then I used IIS and created the site.  I pointed the site to use the web share I created for him.  I aso selected "Allow anonymous access to this web site"

    Finally, I copied a test html in the web share.

    DNS and URL all works fine.  But, when trying to connect to the site, I keep being asked to authenticate with a user name and password. 

    If I create that same site under the C:\Inetpub then everything works.So, I am pretty sure this has something to do with folder security but I am not sure.  Can anyone help me?

    Sunday, February 26, 2012 3:00 AM

Answers

  • Well I am getting closer,  In IIS under the Directory Security tab, there is a"Enable Anonymous Access" check box.  By default, it enables access to IUSR_SIMBA.  But because I am using a shared folder, this is not acceptable. Instead, by changing this to a user who has read access to my share, it works!

    The only catch is that I would like to be able to run asp pages as well.  with plain html, this is a good solution. but for running server side script, it does not work :(  Nor does inserting a user with full access.

    any ideas?

    • Marked as answer by Capt_J Sunday, February 26, 2012 5:26 AM
    Sunday, February 26, 2012 5:17 AM
  • An alternative, that worked for the folder since I wanted to make it run .asp was to create a new user in WHS console, only give it read only access to the website folder.  but then using Windows explorer security tab, add him to the list of users and give him Read&Execute, List folder content, read.
    • Marked as answer by Capt_J Sunday, February 26, 2012 5:30 AM
    Sunday, February 26, 2012 5:30 AM

All replies

  • All files in the shares are covered by the permissions you set in the console, which means that the "user" that IIS uses to access them won't have permission to do so. Thus the authentication prompt you're seeing.

    I'm not on the WHS team, I just post a lot. :)

    Sunday, February 26, 2012 3:09 AM
    Moderator
  • Well, it stands to reason that I can find the folder "WebSite" that is the actual share then using Windows explorer, adjust the security setting but to what?

    Sunday, February 26, 2012 3:57 AM
  • You should not attempt to modify permissions on any share managed by Windows Home Server, other than by using the Windows Home Server console application. This application won't allow you to add the required permissions, I'm afraid.

    Have you looked into the whiist add-in for V1? It might give you just enough flexibility to do what you want...


    I'm not on the WHS team, I just post a lot. :)

    Sunday, February 26, 2012 4:32 AM
    Moderator
  • Well I am getting closer,  In IIS under the Directory Security tab, there is a"Enable Anonymous Access" check box.  By default, it enables access to IUSR_SIMBA.  But because I am using a shared folder, this is not acceptable. Instead, by changing this to a user who has read access to my share, it works!

    The only catch is that I would like to be able to run asp pages as well.  with plain html, this is a good solution. but for running server side script, it does not work :(  Nor does inserting a user with full access.

    any ideas?

    • Marked as answer by Capt_J Sunday, February 26, 2012 5:26 AM
    Sunday, February 26, 2012 5:17 AM
  • An alternative, that worked for the folder since I wanted to make it run .asp was to create a new user in WHS console, only give it read only access to the website folder.  but then using Windows explorer security tab, add him to the list of users and give him Read&Execute, List folder content, read.
    • Marked as answer by Capt_J Sunday, February 26, 2012 5:30 AM
    Sunday, February 26, 2012 5:30 AM
  • An alternative, that worked for the folder since I wanted to make it run .asp was to create a new user in WHS console, only give it read only access to the website folder.  but then using Windows explorer security tab, add him to the list of users and give him Read&Execute, List folder content, read.

    Windows Home Server may (eventually almost certainly will) eventually reset permissions on a folder if you modify them outside of the Windows Home Server console. That's why I recommended whiist, which doesn't do anything that Windows Home Server doesn't do itself. Your alternative is to manage a share yourself, father than creating and managing it using the console.


    I'm not on the WHS team, I just post a lot. :)

    Sunday, February 26, 2012 1:19 PM
    Moderator