locked
Help in csv file RRS feed

  • Question

  • Hi,

    I have an Excel file containing data in arabic.

    When i convert it to a csv file, the arabic letters become all "?"

    How can i keep them arabic letters in the csv file in order to import them to CRM 4.0?

    Thanks in advance

     

    Wednesday, September 17, 2008 10:12 AM

Answers

  • I may be wrong but surely a CSV file is unformatted text.  In Excel your Arabic text will be formatted which you will lose when you export to CSV.  Have you tried importing a sample into CRM to see if it converts back to Arabic?  Just a thought.

     

    Regards,

     

    Douglas

    Wednesday, September 17, 2008 12:14 PM
  • My guess is its a unicode issue. csv is not unicode compliant. Your best bet would be to save as a unicode-compliant text file (when you go to Save As... you'll see the option). I've used these with the CRM v3.0 importer to import Chinese, Korean and Japanese contacts and it worked without a problem. I'm confident it will also work with the v4 import tools.

    Leon Tribe
    Thursday, September 18, 2008 12:08 AM

All replies

  • I may be wrong but surely a CSV file is unformatted text.  In Excel your Arabic text will be formatted which you will lose when you export to CSV.  Have you tried importing a sample into CRM to see if it converts back to Arabic?  Just a thought.

     

    Regards,

     

    Douglas

    Wednesday, September 17, 2008 12:14 PM
  • My guess is its a unicode issue. csv is not unicode compliant. Your best bet would be to save as a unicode-compliant text file (when you go to Save As... you'll see the option). I've used these with the CRM v3.0 importer to import Chinese, Korean and Japanese contacts and it worked without a problem. I'm confident it will also work with the v4 import tools.

    Leon Tribe
    Thursday, September 18, 2008 12:08 AM