none
How to uninstall Microsoft MPI v6 completely? RRS feed

  • Question

  • Hello all, sorry for my bad english,

    I faced with the problem when I wanted to uninstall Microsoft MPI,
    after running MSMpiSetup.exe from Redist folder I saw a window with the text:
    "MS-MPI Installation failed with error code 4317. The currently installed version can not be upgraded. It must be manually uninstalled from Add/Remove Programs before this installation can continue".
    Ok, I went to Programs and Features in the Control Panel, but have not found any program that would have similar name.

    How I can remove it? It prevents using Microsoft HPC Pack 2012, as everytime when I run my programs in cmd, the message apears: "Check version between mpiexec.exe msmpi.dll and smpd.exe". There are same files in MPI v6 and Microsoft HPC Pack 2012 directories, so it must be a conflict between them.
    Saturday, October 17, 2015 8:43 PM

All replies

  • Microsoft HPC Pack 2012 R2 was the first release of HPC Pack that supported upgrading the MPI component.  The MPI redistributable in HPC Pack 2012 was called "Microsoft HPC Pack 2012 MS-MPI Redistributable Pack" (or something along those lines), but uninstalling it and then installing MS-MPI v6 won't work if you're using the job scheduler (the service to launch MPI jobs with the HPC Scheduler only support the version of MS-MPI that was shipped with that version of HPC Pack, until HPC Pack 2012 R2.)

    When you report that running jobs from the cmd window fails, are you trying to submit them to the HPC Scheduler (via job submit), or just run them manually?

    Can you report the output of:
    where msmpi.dll
    where mpiexec.exe
    where smpd.exe

    Getting the file version of these would also be helpful, though the date would likely tell you which of these is the wrong version.

    -Fab

    Sunday, October 18, 2015 9:09 PM
  • Hey,

    could you solve the error 4317?! I get the same error and can't find <g class="gr_ gr_145 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar only-ins replaceWithoutSep" data-gr-id="145" id="145">previous</g> version installed!

    Friday, February 1, 2019 2:49 PM