locked
"no radio discovered" Error RRS feed

  • Question

  • Hello,

    We installed SDK 2.0 and hwtest driver in our WinXP machine. Radio front end is WBX daughter board.

    When we execute the program called "HwVeri.exe", it always gives us message: "error: no radio discovered". In the same time, we can see following print out from Dbgview,
    00000001 0.00000000 [UExtK]Physical Radio starting
    00000002 0.00001844 [UExtK] SoraKHandleUExtReq return 4
    00000003 0.00011789 [UExtK] SoraKHandleUExtReq return 16
    00000004 0.00012097 [UExtK]Physical Radio starting
    00000005 0.00013689 [UExtK] SoraKHandleUExtReq return 4
    00000006 0.00014220 [UExtK] SoraKHandleUExtReq return 16
    00000007 0.00014527 [UExtK]Physical Radio starting
    00000008 0.00016119 [UExtK] SoraKHandleUExtReq return 4
    00000009 0.00016650 [UExtK] SoraKHandleUExtReq return 16
    00000010 0.00016930 [UExtK]Physical Radio starting
    00000011 0.00018550 [UExtK] SoraKHandleUExtReq return 4
    00000012 0.00019025 [UExtK] SoraKHandleUExtReq return 16
    00000013 0.00019304 [UExtK]Physical Radio starting
    00000014 0.00020897 [UExtK] SoraKHandleUExtReq return 4
    00000015 0.00021455 [UExtK] SoraKHandleUExtReq return 16
    00000016 0.00021707 [UExtK]Physical Radio starting
    00000017 0.00023327 [UExtK] SoraKHandleUExtReq return 4
    00000018 0.00023886 [UExtK] SoraKHandleUExtReq return 16
    00000019 0.00024193 [UExtK]Physical Radio starting
    00000020 0.00025757 [UExtK] SoraKHandleUExtReq return 4
    00000021 0.00026260 [UExtK] SoraKHandleUExtReq return 16
    00000022 0.00026623 [UExtK]Physical Radio starting
    00000023 0.00028272 [UExtK] SoraKHandleUExtReq return 4
    00000024 0.00028747 [UExtK] SoraKHandleUExtReq return 16

    When we execute umxsdr.exe, Dbgview produce following information
    00000001 0.00000000 [UExtK] search NO. 524288 signal
    00000002 0.00136721 [UExtK] SoraKHandleUExtReq return 4
    00000003 0.00138817 [UExtK] search NO. 524288 signal
    00000004 0.00275566 [UExtK] SoraKHandleUExtReq return 4
    00000005 0.00277745 [UExtK] search NO. 524288 signal
    00000006 0.00414969 [UExtK] SoraKHandleUExtReq return 4
    00000007 0.00417288 [UExtK] search NO. 524288 signal
    00000008 0.00554149 [UExtK] SoraKHandleUExtReq return 4
    00000009 0.00556579 [UExtK] search NO. 524288 signal
    00000010 0.00693552 [UExtK] SoraKHandleUExtReq return 4
    00000011 0.00695787 [UExtK] search NO. 524288 signal
    00000012 0.00832759 [UExtK] SoraKHandleUExtReq return 4
    00000013 0.00834743 [UExtK] search NO. 524288 signal
    00000014 0.00971744 [UExtK] SoraKHandleUExtReq return 4
    00000015 0.00973839 [UExtK] search NO. 524288 signal
    00000016 0.01110700 [UExtK] SoraKHandleUExtReq return 4
    00000017 0.01112739 [UExtK] search NO. 524288 signal
    00000018 0.01249572 [UExtK] SoraKHandleUExtReq return 4

    We tries unload new firmware and had no luck.

    Thanks
    Muye


    Saturday, November 16, 2013 3:03 AM

All replies

  • LOG: [UExtK] search NO. 524288 signal

    The log tells that umxsdr is trying to find specific signal and send it out.

    Can you figure out if the signal is really sent out?

    If yes, which means Radio is found in umxsdr.

    It may be an issue of HwVeri tool.

    Thanks.

    Tuesday, November 26, 2013 9:50 AM
  • I used another Sora machine and tried dump operation. However, I could not see anything. We currently work with three Sora machines, all of them have the same issue. However, seems like the open source driver SDR mini port driver works fine. We can do ping, iperf, and simple udp socket program after we installed this driver. Also, I found out that LED D2 in one of our Sora boards never light up. Thanks Muye
    Wednesday, November 27, 2013 6:41 AM