locked
My reports are not viewable by others !!! RRS feed

  • Question

  • Hi all,

     

    here is the situation,

     

    i have created a customized report using a system view (All cases) i've tried to share it with another user that have less privileges but unfortunately when this user try to run the report it displays a reporting error

     

    first i was thinking that it's an access rights issue so i've tried to modify its security role but nothing works !!

    so i gave this user the administrator access rights but the same erro persist.

    Then i' ve created another report with customized condition, but the same error still displays fo this user !!

     

    could any body please suggest about where the error is ??

     

    thanks in advance :)

    Wednesday, October 27, 2010 9:21 PM

Answers

  • Hard to know your exact configuration.

    Cause 1

    However my thought is that you have configured the data connect to connect as your user. This would cause other people to not have the ability to use the reports.

    The following KB describes the right configuration. I suggest you review to ensure your have the right config.

    http://support.microsoft.com/kb/946585

    Cause 2

    This problem may occur because one of the following is not added to the PrivUserGroup group:

    • The account that is running the CRMAppPool application pool
    • The application pool under which Reporting Services is running
    • The account that is running the SQL Server Reporting Services service

    http://support.microsoft.com/kb/909509

    Finally, this KB may provide more guidance if you still have not resolved the issue:

    http://support.microsoft.com/kb/946289


    Jeff Loucks | Available Technology | 888-474-2237 | http://msmvps.com/blogs/jeffloucks
    • Proposed as answer by Jeff Loucks Thursday, October 28, 2010 3:07 PM
    • Marked as answer by Jim Glass Jr Thursday, October 28, 2010 7:11 PM
    Thursday, October 28, 2010 3:06 PM

All replies

  • How do you know it is the same error? Could you not provide the error message so that we might be able to devine a direction to water?
    Jeff Loucks | Available Technology | 888-474-2237 | http://msmvps.com/blogs/jeffloucks
    Wednesday, October 27, 2010 10:26 PM
  • you should use FilteredViews
    Julio
    Wednesday, October 27, 2010 10:46 PM
  • When you say customized report, you mean SSRS Report. Make sure you are using Filtered Views in your query.

    Can you give any more detail on the error message?


    MS CRM MVP :: uMar Khan :: Microsoft CRM Consultant (Blog :: http://umarkhan.wordpress.com)
    Thursday, October 28, 2010 12:09 AM
    Moderator
  • Check if the report is personal report. if it is , change it organisation report or share the report with the user.

    I hope it helps


    Amreek singh Senior CRM Consultant CDC Praxa Sydney, Australia http://mscrmshop.blogspot.com
    Thursday, October 28, 2010 3:12 AM
  • Dear Umar,

     

    I've created the report using the report wizard, and i've used a builtin filtered view,

    the error says:

    Reporting Error

    The report cannot be displayed.

     

    with a tray again and cancel buttons

     

    have you any suggestions about the error ??

     

    thanks in advance :)

    Thursday, October 28, 2010 7:42 AM
  • Dear Amreek,

     

    the report is personal but i've shared it with the other user.

    Thursday, October 28, 2010 7:43 AM
  • Dear Jeff,

     

    the error says:

     

    Reporting Error

    The report cannot be displayed.

     

    with a try again and cancel buttons

     

    any suggestions ??

     

    thanks in advance :)

    Thursday, October 28, 2010 7:45 AM
  • Dear Julio,

     

    I've already used a FilteredViews,

     

    any suggestions ??

     

    thanks in advance :)

    Thursday, October 28, 2010 7:47 AM
  • Can you please enable the tracing and check.. refer the article to enable tracing  http://support.microsoft.com/kb/907490

    Jai Ho CRM http://mscrmkb.blogspot.com Skype - amol.gholap

    Mark as answer if a post has answered the question
    Thursday, October 28, 2010 8:42 AM
  • Additional information:

     

    I've tried to create the reports on a different environement and i've added the same users with the same access rights

     

    and i've shared the report and everything works perfectly

     

    hope this may help you solving the problem

     

    thanks in advance:)

    Thursday, October 28, 2010 10:08 AM
  • any help ??
    Thursday, October 28, 2010 1:05 PM
  • Hard to know your exact configuration.

    Cause 1

    However my thought is that you have configured the data connect to connect as your user. This would cause other people to not have the ability to use the reports.

    The following KB describes the right configuration. I suggest you review to ensure your have the right config.

    http://support.microsoft.com/kb/946585

    Cause 2

    This problem may occur because one of the following is not added to the PrivUserGroup group:

    • The account that is running the CRMAppPool application pool
    • The application pool under which Reporting Services is running
    • The account that is running the SQL Server Reporting Services service

    http://support.microsoft.com/kb/909509

    Finally, this KB may provide more guidance if you still have not resolved the issue:

    http://support.microsoft.com/kb/946289


    Jeff Loucks | Available Technology | 888-474-2237 | http://msmvps.com/blogs/jeffloucks
    • Proposed as answer by Jeff Loucks Thursday, October 28, 2010 3:07 PM
    • Marked as answer by Jim Glass Jr Thursday, October 28, 2010 7:11 PM
    Thursday, October 28, 2010 3:06 PM
  • I don't know if this could really help me!!

     

    cause the same users with the same access rights and the same reports are in another environment and everything works perfectly

     

    anyway thanks for your efforts

    Thursday, October 28, 2010 7:14 PM