locked
CRM 2011 Performance Toolkit and https RRS feed

  • Question

  • Hi,

    We have an environment of 4 Frontend servers and two backup servers and the access to the crm system is configured as https only, like https://crm.domain.com

    Everything is working so far and we planned to use the CRM 2011 performance toolkit for a performance test.

    Installing and configuring it you have to enter the web server, api server etc. which I’ve done regarding the documentation with: crm.domain.com – notice that you have here no chance to say http or https. After that, I’ve modified the ConfigSettings.xml file where I’ve exchanged the http:// entries with https://

    Running the dbpopulator.exe tool afterwards throughs an error: System.InvalidOperationException: Metadata contains a reference that cannot be resolved: 'http://crm.domain.com/XRMServices/2011/Discovery.svc?wsdl'. ---> System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a receive. --->

    This is valid as here http:// is used instead of https://

    Anyone who tried to use this tool against https and managed to do that? Any help will be appreciated.

    Thanks.

    Wednesday, December 5, 2012 8:50 AM

Answers

  • OK. We solved this. You have to specify an additional parameter (could be found in the source code of the populator tool).

    Another learning was, that not only the test users need the same password - also the setup user has to have the same pwd (or you have to modify the configFile settings)

    • Marked as answer by tugay econnex Wednesday, December 5, 2012 1:56 PM
    Wednesday, December 5, 2012 1:56 PM