locked
alg.exe RRS feed

  • Question

  • One care just asked me whether I wanted to stop alg.exe form accessing the internet (from C:\windows\system32 (so it wasn't another alg.exe)). I allowed it, but I just want to make sure it does actually use the internet. It's never asked before for alg.exe. I'm aware what alg.exe is and was wondering if it's accessing of the internet had anything to do with the automatic updates that happened shortly afterwards.

    I searched google for an answer, and one was on here at somepoint, but must've been deleted.

    Thanks,

    LM.
    Tuesday, December 11, 2007 7:00 PM

Answers

  • I should add that I've *never* been prompted to allow access for this and would expect that it should be recognized and allowed unless you've set OneCare to warn you about *all* access requests.

    -steve

     

    Wednesday, December 12, 2007 2:07 AM
    Moderator

All replies

  • To be honest, I'm not aware if the Application Layer Gateway service requires Internet access or not. It is used by the Windows Firewall, which should be off with OneCare on and also works with Internet Connection Sharing. So, if you are using Internet Connection Sharing, I suspect that it would need network access, at the very least.

    -steve

     

    Wednesday, December 12, 2007 2:06 AM
    Moderator
  • I should add that I've *never* been prompted to allow access for this and would expect that it should be recognized and allowed unless you've set OneCare to warn you about *all* access requests.

    -steve

     

    Wednesday, December 12, 2007 2:07 AM
    Moderator
  • I'm not at my computer right now, but I think I do have it set to warn about all access requests.

    I'm not using ICS from one computer to another, though I do have a PDA which access the internet via USB, which was plugged in at the time and am using printer sharing.

    When I try and block alg.exe it says that it isn't blockable because it's a protected windows file, and OneCare scans reveal that there are no virus etc on my computer.

    It's just a bizarre one really, as it's never asked before. Plus the automatic windows updater ran after I allowed it.

    I've read in a few places that it might be a trojan, but OneCare says the file is fine, and there's nothing in my msconfig startup that is suspicious.

    I'm wondering if it was to do with the Automatic updates, or even maybe active sync.

    If it was malicious, OneCare hasn't picked anything up.
    Wednesday, December 12, 2007 9:15 AM
  • I'm going to guess that it was ActiveSync that triggered it. I don't think AU would be involved, but if you could confirm the always prompt setting, that would be good.

    -steve

     

    Wednesday, December 12, 2007 6:18 PM
    Moderator
  • It's set to always notify me when the firewall blocks an application.
    Wednesday, December 12, 2007 10:58 PM
  • Thanks for the follow-up. While we can't be certain why alg.exe was invoked, though I suspect it was ActiveSync, the allow prompt was because you always want to be prompted for any new app wanting network access.

    -steve

    Thursday, December 13, 2007 3:46 PM
    Moderator
  • hi there,

    I'm having the same problem - a prompt to allow alg.exe to access the internet - every time I start up my computer.  But I checked my settings and they're *not* to always notify me when something attempts access but just to notify me when something is blocked.  I cannot add alg.exe to the list of allowed programs because it says it's a protected file.  How can I disable it, or otherwise get the window to stop coming up at startup?  Thanks.

    Thursday, December 13, 2007 5:33 PM
  • Sounds similar to my problem. Mine isn't all the time though, however it has happened in total twice now. The second time I blocked it (but ask again later) to see what happened.

    I no longer think it's Auto Updates.

    I don't think in my case it's a virus etc, I've done a full scan (clean), my msconfig startup is so empty it's nearly nothing and I've looked about in regedit and found nothing out of the ordinary. I've looked in windows, system and system32 and found nothing strange, and haven't actually downloaded anything recently, or opened up any email attachments.

    I'm gonna try a few things, and I'll report back.

    Oh, and alg.exe is a service, so if you go to the services tab in msconfig you can switch it off. I haven't, but if it's some sort of bug where it keeps asking then it could come down to that. Though obviously a few things wouldn't work.
    Thursday, December 13, 2007 6:06 PM
  • Hello,

     

    I have the same problem on two of my computers, when starting them up a firewall message appears and when I permit the program to be used it does not work, the next time the screen appears again and again. Blocking this is also useless - help me, what can I do???

    Thursday, January 17, 2008 9:24 PM
  • Please contact support for help with this since we never got an answer as to why it was happening.

    How to reach support - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

    Friday, January 18, 2008 1:58 AM
    Moderator
  • OneCare firewall has blocked a program

     

    Microsoft Windows Publisher. C:\Windows\system32\alg.exe Version .1.2600.2180.

     

     

    I got this request this morning when I logged on. It's the first time I've seen it, I've been running OneCare since last June.

    The only thing changed on my computer this week is I've added a new program 'Nuance PaperPoint 10', could it be something to do with that? Eric.

    Saturday, February 2, 2008 12:12 PM
  • It could be. If you remove PaperPoint, does the prompt go away?

    -steve

     

    Monday, February 4, 2008 2:49 PM
    Moderator
  • I clicked on the 'Always allow' button Steve so it hasn't appeared again, hope I did the right thing. E.

    Monday, February 4, 2008 7:21 PM
  • Yes, it should be fine as it is the Application Layer Gateway service for Windows.

    -steve

     

    Tuesday, February 5, 2008 1:24 AM
    Moderator
  •  lm001 wrote:
    One care just asked me whether I wanted to stop alg.exe form accessing the internet (from C:\windows\system32 (so it wasn't another alg.exe)). I allowed it, but I just want to make sure it does actually use the internet. It's never asked before for alg.exe. I'm aware what alg.exe is and was wondering if it's accessing of the internet had anything to do with the automatic updates that happened shortly afterwards.

    I searched google for an answer, and one was on here at somepoint, but must've been deleted.

    Thanks,

    LM.

     

    I just wanted to say that I have had the same experience.

     

    I booted into Windows XP and everything was great. Then I was notified that there were some updates. This was today 4-10-2008. There were 7 updates the first one was a Hotfix for IE7 KB947864, the next five were Windows Security updates: KB945553, KB948590, KB948881, and KB941693.The last one was a Malicious software update. I did not pay attention to what the KB number of the last update was (I guess I should have).

     

    After rebooting I now get the same message as above about alg,exe. I figure that one of the updates caused this to happen. It could be that others had AU turned on and did not know their computers had just updated when their problem began. I have mine set to inform me of updates, so I know it was imediatly after updating that this problem started.

     

    Hope this helps narrow the playing field down.

    Friday, April 11, 2008 4:41 AM
  • I just wanted to add that I just had this same issue arise today.  I'm not sure if updates have been recently installed since they are set to install automatically.  I suppose I'll simply "Allow this program", but it makes me nervous.  Why all of a sudden and why is OneCare Firewall blocking C:\WINDOWS\system32\alg.exe Version 5.1.2600.2180?  I've been using OneCare on this same PC for several months, and besides automatic updates to software, I have not installed any other software or changed my OneCare settings.

    Tuesday, April 15, 2008 2:43 PM
  • I would recommend that you contact support. 

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

     

    Tuesday, April 15, 2008 3:37 PM
    Moderator
  • I now have had this problem for the last few months.

    Previously, this never occurred.

     

    EVERY time I start up lap top, I get Windows Live OneCare Firewall blocking alg.ex.

    EVERY time I click on allow this program.

     

    It does not remember the answer.

    What should i do

     

    Wednesday, October 15, 2008 9:26 AM
  • I suggest reading the post directly above yours which advises that contacting support is the best path to take at this point if you are experiencing this problem.

    -steve

     

    Wednesday, October 15, 2008 2:31 PM
    Moderator
  • I have now corresponded with Customer Services about this issue.

     

    Alg.exe provides support for third-party plugins that allow network protocols to pass through the Windows Firewall and work behind it and Internet Connection Sharing.

     

    They recommend solving my issue by disabling it, as follows:

     

    Click on Start – Run – (Type) Services.msc (Press Ok) – Right click Application Layer Gateway (Alg) service & change the startup type box select Disable, Click Apply & OK. After doing this restart the system.

     

    This has stopped the error message with no ill effects so far.
    Friday, October 24, 2008 3:55 PM
  • Thanks for posting this RichardJW.

    -steve

    Wednesday, October 29, 2008 3:31 PM
    Moderator
  • Also had windows live one care ask if I wanted to block alg.exe. I thought this was a microsoft system program, so it does not seem to make sense, so I blocked it. Each time I log on now it still keeps tellling me I blocked it. Not sure if this is going to cause a problem eventually, but I have also read where this can be a virus.... 
    Sunday, February 1, 2009 1:57 PM