locked
LOST! ie7 has me messed up? RRS feed

  • Question

  • First, I am about 250 miles removed from my WHS.

    Now, I had full access and had tested everything out before I left home after performing a Recovery.

    1. I accessed my WHS in Firefox (my primary browser) to download some files. No big deal because I did not need to remote.

    2. I have a problem with my slingbox so I used ie7 (my desktop) to remote to fix it. BUT, I cannot even get my server page to come up to remote.

    3.  I then attempted to remote using my laptop (ie7) and same thing, I can't access my server page to sign in.

    4. I used my work computer (ie7), I got a certificate error, I accepted it and then signed into my server. I can see everything the way it should be, but because my work blocks ActiveX it would not allow me to remote into my computer or WHS.

    5. I went to the local library here and got the same results as my work computer.

    6. I uninstalled ie7, then uninstalled SP3, and ie6 would not allow me to sign into my server.

    7. I reinstalled SP3 and ie7 and I am back to the same problem.

    I am LOST and confused, some help would be very appreciated, just keep in mind that I am far away and right now I can't get to a computer that can remote into server. But, I don't think it is an issue with my server, rather it must be with ie7.

    Thanks,

    Thursday, November 6, 2008 11:59 PM

All replies

  • What you might try is to connect to your server using Remote Desktop Connection under Start->All Programs->Accessories (vista) and i think it is under  Start->All Programs->Accessories->System Tools in XP, but im not sure of that. Just type [yourname].homeserver.com into it and if you forwarded the right ports in your router at ho0me, it should bring you to the desktop of the server. Then you can check if something is wrong with your server. 

    Other than that, i would try to borrow a computer that is not inside a restricted network. Public computers and office computers are often inside a restricted network which might give you problems to connect to the server.



    Lars
    Friday, November 7, 2008 7:28 AM
  •  Hi,
    Skauber said:

    What you might try is to connect to your server using Remote Desktop Connection under Start->All Programs->Accessories (vista) and i think it is under  Start->All Programs->Accessories->System Tools in XP, but im not sure of that. Just type [yourname].homeserver.com into it and if you forwarded the right ports in your router at ho0me, it should bring you to the desktop of the server. Then you can check if something is wrong with your server. 


    Other than that, i would try to borrow a computer that is not inside a restricted network. Public computers and office computers are often inside a restricted network which might give you problems to connect to the server.

    to add on the remarks of Lars:
    Accessing the machine via Remote Desktop client requires port 3389 forwarded in the router and the Windows Firewall scope for the Remote Desktop exception on the WHS configured to allow access from outside.

    Besides that it could be possible, that the necessary ports 443 and 4125 are blocked by a firewall in the network, from which you try to access. Also WHS Remote relies on ActiveX controls, so Internet Explorer is mandatory. If your client PC is restricted and does not allow the ActiveX controls to be installed, this may be a cause of the problem.
    Did you add the homeserver.com domain to the trusted sites in Internet Explorer?
    It's definitively not a problem of Internet Explorer 7 by its own, since all machines I use to remote Windows Home Server machines are at least at IE 7 level.

    Best greetings from Germany
    Olaf
    Friday, November 7, 2008 8:19 AM
    Moderator
  • I had someone to check my router settings and all of the required ports are correctly configured. I attempted to remote into WHS with the Remote Desktop Connection using my WHS address and no luck. I am beginning to believe that this is an ActiveX / Browser issue on my desktop and laptop computers. I used the validation tool and it said that my ActiveX was good but I don't believe it. How do I check or uninstall / reinstall ActiveX ?

    Thanks,
    Rex
    Saturday, November 8, 2008 2:53 AM
  • Hi,
    what is the exact error message you see?
    As mentioned, Remote Desktop access only works, if port 3389 is forwarded properly in the router and the Windows Firewall on WHS is set to accept Remote Desktop connections from all networks.
    Does your client even resolve the name properly, can you ping the homeserver.com address (and are you sure it is the right one, which the work PCs also tries to use)?
    (Maye that one client tries to connect to the wrong IP address due to some reason.)
    Did you try http://myname.homeserver.com or https://myname.homeserver.com ?
    If you router allows, you could also try to configure a dyndns.org account to circumvent potential temporary name resolution trouble with homeserver.com Live services.
    Best greetings from Germany
    Olaf
    Saturday, November 8, 2008 10:48 AM
    Moderator
  • Ports 80, 443, 3389, 4125 are all forwarded and created as exceptions in the firewalls on all computers, except my work computer (I have no idea what my work computer ports are configured for b/c I have no admin access)

    I have not tried the ping b/c I am not sure how to do that.

    I have tried to login with http & https URL's and no luck.

    I have not tried the dyndns.org solution yet

    Since my work computer and a library computer can get me into my server and but not into RDP becuase they do not allow ActiveX, I am thinking that my computers are not configured correctly for ActiveX?

    How do I confirm ActiveX is setup properly & that my browser is configured properly?

    Thanks for your help so far........

    Tuesday, November 11, 2008 3:13 AM
  • Hello,
    if ActiveX is not installed or configured correctly, you get an error message about this.
    As far as you have added your homeserver.com address to Trusted Sites in IE, the configuration should be properly for your needs.
    But if you see nothing, this sounds more like that name resolution does not work.
    To ping a system, open a command prompt, type
    ping myservername.homeserver.com
    and hit Enter (replace myservername with your domain name).
    Best greetings from Germany
    Olaf
    Tuesday, November 11, 2008 7:55 AM
    Moderator
  • I cannot ping my ip address or server name from my desktop. However, when I use ipaddresslocation.org and enter my ip address or server URL then it pings my server and gives me back all of the correct information to include the city that my residence is in.

    So, if you are not using my desktop or my laptop then you can see my server? This is so messed up and I don't know what to do about it, shor of getting rid of my computers or totally reformatting them.......

    Tuesday, November 11, 2008 4:07 PM
  • Hi,
    some restrictive firewalls block also ping requests. So can you ping other addresses in the Internet?
    You may try to ping my homeserver and test, if you get it loaded in Internet Explorer, use my last name as first section of the domain name.
    Best greetings from Germany
    Olaf

    Tuesday, November 11, 2008 7:00 PM
    Moderator
  • Olaf,

    I wasn't able to pull your server up using internet explorer by URL. However, I could and did ping it using the command prompt. Also, I could use ipaddresslocation.org to ping your server just fine.

    If I knew how to paste a pic of the results I would.

    Still frustrated.......... But thanks for your help........
    Wednesday, November 12, 2008 12:19 AM
  • Umm sorry, forgot, that my machine is down between 1 AM and 9 AM MET.
    So you might try again later.
    Best greetings from Germany
    Olaf

    Wednesday, November 12, 2008 7:46 AM
    Moderator
  • Currently Windows Live Domain communication seems to be messed up (my system doesn't register successfully), so if you want to start another try use mfnv.dyndns.org as address. Downtimes still apply as mentioned above.)
    Best greetings from Germany
    Olaf

    Thursday, November 13, 2008 12:31 PM
    Moderator
  •  Achtung - Private Zone!

    I can see your sever, but not mine?

    Well I guess I really have something messed up? But I don't know where the problem is. Thanks for helping me out. When I return home next weekend I am going to have to get inside my server and make sure everything is adjusted correctly myself and then sign up my server with a DNS service.

    Thursday, November 13, 2008 11:24 PM
  • So we at least know, that your problem is not originated in the client PC.
    Best greetings from Germany
    Olaf
    Friday, November 14, 2008 7:19 AM
    Moderator
  • invisionz said:

    2. I have a problem with my slingbox so I used ie7 (my desktop) to remote to fix it. BUT, I cannot even get my server page to come up to remote.

    [....

    Did you check if Terminal Services ActiveX control is enabled?
    Click on Tools -> Manage Add-Ons -> Enable or Disable Add-Ons in IE to enable the Terminal Services ActiveX control

    Or check out this link XPSP3 IE7 disables WHS remoting ...

    Theo.



    No home server like Home Server
    Monday, November 17, 2008 7:51 PM
    Moderator