locked
Backup: backup service not running RRS feed

  • Question

  • Installed RC, ran OK for a day. Did overnight auto backups OK. Next day, got message that BU service not running. Have been reading other's remarks and answers and tried the suggested procedures.  Went  to firewall exceptions and changed bu service and transport service to "all". No luck there. Did a reinstall by inserting the dvd, not  booting from the dvd.  Still no luck. This problem will not let me install the console on client machines.But server is available on my lan. Also enabled UPnP on my router.

    Related issue: beta client installed and ran like a well oiled machine for a month. Last week, before installing RC, I suddenly couldn't access any web sites while WHS  was running and UPnP was enabled on my router. Prior to that, remote access was working smoothly. The only way to access web sites was to turn off WHS, then disable UPnP. Never could get remote access to work again. Ran a port scan to check if my ISP was blocking any ports; none were.

    Can I reinstall RC by booting from the DVD? Or do you think there are other problems? All drives report healthy.
    Thanks
    Saturday, June 16, 2007 4:43 PM

Answers

  • We were unable to repro your issue internally. My only suggestion would be to back any data up that you have on the server, and then reinstall WHS, put in a key during setup and see what happens with your install.
    Tuesday, June 26, 2007 6:16 PM
    Moderator

All replies

  • I've gotten this message also, more than with CTP.  Everything on the WHS and the connected computers installed without problem.  Sometimes in the middle of a backup of another computer I will check with the console and get the message.
    Saturday, June 16, 2007 6:43 PM
  • We are seeing lots of reports of problems with  backup in this build. Please don't rebuild your server, but run TALQ on your server and post the CAB number here so that our backup team can take a look at these bugs. Also if you have detailed repro steps, they would be very helpful.
    Saturday, June 16, 2007 6:44 PM
    Moderator
  • Ran TalQ, got cab# 350615748.

    re: repro steps

    clean installed rc from home burned dvd.

    installed connect software on client machines, 3xp pro, 2vista home premium

    changed name of whs from server to bobsserver

    changed workgroup to my lan's name

    didn't make any other changes to whs or client machines

    following day: checked server via client console for backup status, OK

    later that day I noticed server icon was red with "backup service not running on server" message. restarted whs several times, each with same result i.e., bu not running.

    reinstalled whs like I said earlier, not booting from dvd, but reinstall. When I inserted the dvd, it did not start automaticly, I had to drill down on the dvd to find a setup.exe prog.

    Current status: server running, bu not running, server is visible and reachable via my lan. I can transfer files to the media folders.

     

    Thanks

    Saturday, June 16, 2007 9:19 PM
  •  

    Does anyone have a clue as to what's happening with the back-up service not running problem?

     

    Thanks

    Wednesday, June 20, 2007 2:32 AM
  • I noticed something in common with the post above.  I installed WHS with 2 hard drives.  After the install I removed one of the drives.  I then renamed the computer and changed the workgroup it was is.  I rebooted, installed the drivers for the LAN and updated the BIOS on the motherboard.  After that I added 5 more drives to the system.  Once they were added to the storage pool, I installed the client on 2 workstations (XP Pro and XP Media Center) which is when I noticed the backup error (the client wouldn't install.)
    Wednesday, June 20, 2007 1:25 PM
  • I had the same issue and rebooted WHS and it started without incident.  I'll keep an eye on it though.

    Jim

    Wednesday, June 20, 2007 2:50 PM
  •  markgm wrote:
    I noticed something in common with the post above. I installed WHS with 2 hard drives. After the install I removed one of the drives. I then renamed the computer and changed the workgroup it was is. I rebooted, installed the drivers for the LAN and updated the BIOS on the motherboard. After that I added 5 more drives to the system. Once they were added to the storage pool, I installed the client on 2 workstations (XP Pro and XP Media Center) which is when I noticed the backup error (the client wouldn't install.)


    Here is the report I submitted for the issue:  351510309

    I ran into the same issue tonight when I set up a new machine.  The solution in another post didn't work for me, so I deleted the file D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}\Commit.dat which removed the other two files in the directory, rebooted, and was back in business.  Before that, no matter what I did, the service would not start.
    Wednesday, June 20, 2007 3:44 PM
  •  

    I'll try this. Out of curiosity, where did you find this info?

     

    Also would like to know if Microsoft is still working on this problem. Haven't seen a post here for about a week.

    Monday, June 25, 2007 3:28 PM
  • OK, I think it's time to give up on WHS.

    So far, no one at MS has given me (or anyone else ) a reason why the back-up service refuses to run on my machine and serveral others.

     

    Previously to installing WHS, I was running Linux on that machine and it seems like a good time to go back to it. I may still buy a copy of WHS when it's released, if the BU issue is resolved. But for now I'm tired of waiting.

     

    Another reason I'm getting tired of playing with it is when I try to activate it, it keeps telling me I've got the wrong product key. It let me install it with the key I've got, why is it now bad? I got another key from the WHS download site, and that one is bad too. WTF?

     

    Thanks for all your help, MS. You've got a decent product idea here, hope you can get it to work and out to market.

    Tuesday, June 26, 2007 5:58 PM
  • We were unable to repro your issue internally. My only suggestion would be to back any data up that you have on the server, and then reinstall WHS, put in a key during setup and see what happens with your install.
    Tuesday, June 26, 2007 6:16 PM
    Moderator
  • This related message was posted in another thread. I'll delete it at the location.

     

    -----------------------------------------------------------------------------------------------------------------------------------------------------

    Back ground:  had CTP ver. running with no issues (except inability to handle an XP Pro 64-bit setup).

     

    Deleted Connect software from clients. Installed RC1. Installed Connector on one client to start with. Ran well.

    Backed up the client. No issues.

     

    Overnight MS Windows updates downloaded then installed this a.m. Clicked on the single client in the console

    (Computers & Backup) and received this message, "The Wizard cannot start because the Windows Home Service

    Backup Service is not running. Please restart Windows Home Server. If the problem persits contact product support."

     

    Restarted. Same result. Restarted again. Same result.

    --------------------------------

    Update:

    After three/four days the backup service was running again. No intervention. No new updates applied.

    Have no idea how it was restarted.  Another update was downloaded and applied. Again the backup

    service shutdown; same error message as above. 

     

    Tried manually restarting it. It started but shut down immediately.

     

    I'm two days post Windows update and am interested to see if b/u service restarts again (maybe only on Sundays?).

    -----------------------------------

    Update:

    Apparently not. After the past two Windows updates the backup services remains shutdown. When manually

    restarted b/u service shuts down immediately.

    Tuesday, June 26, 2007 6:57 PM
  • Hi,

     

    Just to add my voice to the problems with the backup service.  Service does not start, stops immediatly after being manually started.

    Checked event log and got link errors on files in d:/folder/{000000

    Tried the fsutil reparse.....  hint from this forum, next file had the errors

    Tried an upgrade install from the DVD with WHS running - no change

    Tried upgrade install from the DVD - after booting - no change

    Just going back through running more dskchk's and applying updates


    Will notify of any changes (Sunday or otherwise).


    Also noticed that it wants a new key every time you install, even on an upgrade install, so hope that is not going to make it into the final version Wink

     

    Other than that lovely product, just want to be able to set it and leave it.

     

    Thanks


    Dave

    Tuesday, June 26, 2007 7:10 PM
  • as additional information - it always appears to fail with the same pair of errors an event id 272 followed by an event id 267.

     

    Is there anyway of removing all of these files and then cleaning out the existing backups?  It appears to be corrupt configuration data and WHS console will not let me remove machines etc without having the backup service running.  If there is a way of doing it,I would like to clear them all out and then see if the backup service will start without any of these config files getting in the way.

     

    Trying to delete them from the disk just gives me a file link error....

     

    I thought the "rebuildprimary" at the end of an upgrade install would fix this?

    Thanks


    Dave

    Tuesday, June 26, 2007 7:30 PM
  • I have the same issue with it wanting a new key all the time. Very annoying. Like you I hope this doesn't make it into the final version. Of course if the back_up problem ever gets fixed, it won't matter.
    Monday, July 2, 2007 2:42 PM
  • I have a related problem. WHS has been running fine for over a week since it was installed (fresh install), then in the last few days I started to get "Backup service is not running" errors when I tried to look at the backups, or change a backup schedule.

     

    Last night (before midnight and the backups started), I got the same message again, but I left the server running without re-booting.  The same message came up this morning when I checked. However, after re-booting the server this morning (which got rid of the message), I noticed that the backups had been completed successfully anyway.

     

    TalQ (console): 354468328

    TalQ (server): 354469602

     

    Change from default:

    - changed server name

    - changed number of backups to keep

    - changed workgorup name

     

    Any ideas?

    Thanks

    Monday, July 2, 2007 7:04 PM
  • Greetings,
    I have a solution to the "backup service not running" issues cropping up as of late (this is the solution that worked for me anyways). I'll first provide an overview of my WHS build, the events that caused the issue, the steps taken to investigate/correct the issue and what I did which finally got the matter resolved:

    My build consits of an ASUS Teminator T3-M2NC51PV barebones system which uses the Nvidia C51PV/MCP51 chipset with an AMD Athlon 64 3000 AM2 processor and a gig of DDR2-667 Ram. There are two 500GB HDD's with an additional external 500GB drive attached via e-SATA (this acts as the backup drive for the WHS and is therefore not added to the drive pool). The WHS is connected to the network via a gigabit switch, two home PC's (Vista Ultimate) my wife and I use are connected to the switch. This has proven to be a rock solid set-up which has run 24x7 over the past few months of the BETA test of WHS.
    I recently left on vacation and upon my return found that one of the Maxtor 500GB hard drives had failed; the WHS console showed the drive as 'Missing'.
    The first step I took was to physically remove the failed drive and add the e-SATA drive to the drive pool from the WHS console in hopes that this would restore the drive pool. This had no affect, so I attempted to remove the missing drive instance from the console but did not complete the task due to the possibility I may lose personal data on the server. I had by this time recieved a replacement 500GB HDD which was installed into the server and added to the drive pool. I then researched the forum and attempted the "...deleted the file D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}\Commit.dat which removed the other two files in the directory,..." option presented by "markgm" in this thread but recieved "Invalid handle" file errors which prevented the action. I then attempted a re-install of WHS (server update install rather than a full re-install), but this too did not correct the issue at hand. Lastly, I felt that removing the e-SATA drive from the pool in order to copy over the personal data to this external drive and completly reinstalling WHS was my only option.
    I stumbled upon the solution during this last step; I bit the bullet and removed the 'Missing' instance from the drive pool and followed this by removeing the e-SATA drive instance from the drive pool in the WHS console. After the e-SATA drive was removed from the drive pool, and the Windows Home Server was restarted, viola! the network showed 'Healthy' and the backup service was back in action and the the two 500GB HDDs listed as 'Healthy' as well. The e-SATA drive lists as 'Not Added' which I want as this is the server backup. I did lose all of the accumulated backup sets which was not an issue as they were not needed (I'd rather start fresh).

    I hope this wordy post was of benefit to the community. Cheers!
    Sunday, September 23, 2007 5:54 PM
  • Thanks for your post, Mr. Anderson.

    A few months ago, I did a complete reinstall of the WHS OS, and have not had a failure of the bu service since. But after reading your post, I remembered that one of the drives in my machine also died. However, now, I can't remember if this happened before or after I reloaded the OS. In any case, I have a couple of months of back ups, which for me is plenty. I really don't care about the bu's anyway as there isn't much on any of my eight other machines (two of which are LInux boxes) that I can't live without. Anything that's important I back up to the the other systems, i.e. data is redundant on most machines. The bu's could become important however if/ when one of the systems dies.

     btw, Does your remote access work? Mine did for about a month but I haven't been able to get it going since about June. As soon as I start it up, I loose internet access on all my other machines.

     

    On another note:

    I know MS has released the product to OEM's , but is there any word on when (if?) they will release just the software to the public?

     

    Again, thanks for your post.

    Monday, September 24, 2007 2:45 AM
  •  zarum wrote:
    I know MS has released the product to OEM's , but is there any word on when (if?) they will release just the software to the public?

     

    It's already out in some countries (Australia, UK, I believe Denmark and Germany as well).  There are other posts in this forum that have names of sites and links to them.  Or, if you want to check the internet for yourself (and are looking for the English version of it), try searching for CCQ-00015 (which is the part number for it).

    Monday, September 24, 2007 2:51 AM
    Moderator
  • Hello zarum,

    Yes, I have been successful with the Remote Access. What worked for me was the advice to manually configure my broadband router with the port forwarding rules rather than rely on the Universal Plug & Play cababilities. Please remember also to check the domain registration for your server with the MS homeserver.com service via your MS Live log-in. A furthur point to ponder might be the fact your ISP might have traffic restrictions on certain port traffic which will prevent remote access. Check if this is the case and modify the port forwarding rules accordingly on the router's web interface (HTTP - 443 is a port blocked by Telus, a major ISP Provider here in BC, Canada).
    All the research on OEM availability I've seen indicates early October for US and Canadaian customers. I'm a TechNet Direct subscriber so it would be wonderful if Microsoft made available the WHS OEM Build through this channel, but this does not seam likely, though I could be wrong. I'll wait a while to see how this shakes down before purchasing a copy.
    I'll close with a quick note on how great the Diskeeper Home Server Defragmenter application is on WHS. It has made a huge difference on system performance since running the software and defragging the drives.

    Thanks zarum for your kind reply.
    Monday, September 24, 2007 5:01 AM
  • Unfortunately WHS wont be be available to either Microsoft Action Pack subscribers or Tech Net subscribers.

     

    Andrew

    Monday, September 24, 2007 6:10 AM
    Moderator
  • I apparently caused this problem myself.  I have 6+TB storage on an HP EX-470 mediasmart server and 9 computers on a 1 GB network.  I inadventantly disturbed the network connection to a computer that was in the middle of an automatic backup.  This caused an error message from the server that their were inconsistancies in the backup data base and the WHS backup server stopped running....restarts were no help.

     

    The solution that worked for me was to delete all backups (on the settings backup tab) and restart WHS.  The backup server came up normally.  Of course now I have to rebackup all the computers on on the net....the price of stupidity.  Hope this helps.

     

     

    Wednesday, December 26, 2007 9:22 AM