locked
Not able to create user on CRM 2011 on premise RRS feed

  • Question

  • Hi All,

    We have dev & prod environments and both are in different domains(Let's say dev & prod domains). We copied production database to dev environment and connected to dev environment. Now dev users are login with same user account as prod. All existing users in Prod are able to connect to dev environment using their production credentials. Problem came when i am trying to add new user in dev environment with prod/dev domain giving below error.

    For ex: prod\Usera   or dev\usera.

    Error:

    Please let me know how can I add this user ? i gone through few forums not much helpful.

    Regards,



    • Edited by crmpnk1 Monday, March 9, 2015 8:58 PM
    Monday, March 9, 2015 8:57 PM

All replies

  • after the database restore, you have to remap the users, change Guid etc to truly get the CRM working.

    https://msdn.microsoft.com/en-us/library/hh127042%28v=crm.6%29.aspx?f=255&MSPPError=-2147217396

    above URL show how to use organisation import wizard.

    regards

    Jithesh

    Monday, March 9, 2015 9:55 PM
  • Hi,

    Thanks for reply! Now we don't have this option. How to solve this problem? DB size is very big approx 200 GB to restore.

    Regards,

    Thursday, March 12, 2015 7:18 PM
  • you said "We copied production database to dev environment and connected to dev environment. ".

    I am talking about this database. How did you connect?.

    ideally these are the steps.

    1. Take a backup of production <orgname_mscrm> database.

    2. Restore it to dev sql server.

    3. In a server where crm is installed, import the database as new organisation.

    4. You will be provided with an option to re-map the users.

    please let me know if this is how did it.

    regards

    Jithesh

    Thursday, March 12, 2015 10:26 PM