none
Exit Code -2146232576 error in hpc cluster with c# RRS feed

  • Question

  • Hi ,

     

    I have a HPC cluster with 1 head node and some workstation and compute nodes. I am using Visual Studio 2010 to create some parallel program using parallel.for. Now when I submit the job just by selecting the head node a my resource, I get my result. But the problem starts when I try to run the program with other nodes(workstation/compute). I get the error message as "Task failed with the exit code -2146232576".

    My job in this case is a single task with the executable file from the program. the program in inside a shared folder.

    Is there some dlls or reference I need to include  in the shared folder? Can anyone help me with this error message?

     

    Thanks in advance,

    Him

    Saturday, October 30, 2010 2:06 AM

Answers

  • Confirming what pgarvan stated. I had the same error code. Code would work on one computer node, but fail on another compute node. Could not figure it out until I read his note and remembered I upgraded the working compute node to aps.net 4 but not the other node. Very cryptic error code but seems to be directly related to compiling with one asp.net version and running it on a lower version.
    • Edited by dayhiker Friday, January 14, 2011 12:16 AM remove MS Word header data
    • Marked as answer by Don PatteeModerator Saturday, February 5, 2011 12:54 AM
    Friday, January 14, 2011 12:15 AM

All replies

  • Hello,

    On thing you can try is just locally run your app on workstation or compute nodes. If you still get error, that means you may missed some dlls on WN or CN. In that case, you can use some tool, suchn as the one in the link (http://www.dependencywalker.com/) to find which dll missing.

    Hopefully, this info can help you.

    Thanks,

    James

    Friday, November 19, 2010 7:01 PM
  • You might also like to make sure that the .Net version your C# application is expecting is installed on your workstation and compute nodes.
    Friday, December 3, 2010 3:13 AM
  • Confirming what pgarvan stated. I had the same error code. Code would work on one computer node, but fail on another compute node. Could not figure it out until I read his note and remembered I upgraded the working compute node to aps.net 4 but not the other node. Very cryptic error code but seems to be directly related to compiling with one asp.net version and running it on a lower version.
    • Edited by dayhiker Friday, January 14, 2011 12:16 AM remove MS Word header data
    • Marked as answer by Don PatteeModerator Saturday, February 5, 2011 12:54 AM
    Friday, January 14, 2011 12:15 AM