locked
Data drive will not "remove", GUI failing when trying to remove via "Disk Management" RRS feed

  • Question

  • My problem starts with failed client backups with messages indicating bad sectors on a 1.5TB Samsung HD154UI SATA disk (connected thru a SIIG RAID card).  This was determined through the Win2k3 Event Viewer via console login.  I have a 2nd identical Samsung HD154UI plugged into another port on this SIIG card, and (4) WD 500g SATA disks plugged directly into the mainboard, and they are not giving me any trouble. Unfortunately Samsung's internal disk utilities on their website are ... crap ... and I can't see what is really going on with the disk, whether it is physical failures, or block damage that could be cleaned up with a reformat of the drive.

    So I decided to "remove" the disk using the "disk management" GUI and analyze it offline, but when it gets to the last 15gb of data it fails with the message "file conflicts prevented the disk removal operation".  The conflict is "Data error (cyclic redundancy check)", the file name is "GlobalCluster.4096.dat" and the location is d:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}".   My guess is that this is part of the client backup files, not shares.

    I wasnt sure why it wouldn't relocate this file/dir so I made sure every possible WHS and Win2k3 update was up to date, including WHS Powerpack 3.  Just for fun I swapped the SATA cable on this drive, too (with power off).  Then I ran a database cleanup and a purge of old and failed backups and retried the remove.  No good, same error. I then disabled ALL folder duplication, ran another DB cleanup and a purge then tried to remove the disk again.  Same error.

    So I decided to power down and pull this drive's SATA cable and see if I could get past it with recovery tools.  Nope, that really made it mad.  Now when I reboot with the disk disconnected and start the Disk Management gui it shows the drive being out of the storage pool, and when I select it and right mouse click to "remove" it the gui crashes with no errors.  Simply disappears from the screen (console).  This happens via gui from a client as well as console.  Consistently, too.  Even over reboots.

    Now, after reconnecting the SATA cable and rebooting, I am getting the message "The device, \Device\Harddisk5, has a bad block" in the Event Viewer\System log.  This does not surprise me but I still can't get WHS to let go of the disk so I can fix or replace it!  Any ideas on how I can remove this disk and make WHS happy again?  

    This is my buddy's WHS machine and for him its a nice no-brainer to make sure he and his wife's pc's are backed up, and he can store stuff on the shares, so I need to fix this.  

    Unfortunately my own WHS machine tanked a few months ago with constant irritating "file conflicts" for files that haven't been touched in months, which made no sense.  That, combined with the impending removal of Drive Extender from the new version of WHS has caused me to start looking at options to replace WHS on my machine (Freenas, Openfiler, Amahi).

    Now, with WHS turning the process of replacing a failing disk drive, a task that it should do quite simply, into a circus, I have to seriously consider migrating him as well.

    Thanks for letting me vent, but in the meantime I do need to fix this.  Your suggestions are appreciated.  Thanks.


    Monday, February 21, 2011 8:35 PM

All replies

  • So try to remove the disk first physically and later in the console.

    Keep the disk as long as you are not sure, that all non duplicated files are sitting on the other drive(s). The backup database may also be affected (as you have already seen), but this should be recreated by deleting the remains and starting over.

    Best greetings from Germany
    Olaf

    Monday, February 21, 2011 9:01 PM
    Moderator
  • After removing the disk and rebooting, the client gets this error "the backup database has errors Click to run the Backup Database Repair Wizard".  I launched the gui and tried to follow the directions but it would not allow me to continue and told me to either replace the disk or remove it.  When I went into Disk Management the disk was separated from the pool under the "Attention Required" heading with the status "Missing".  When I highlight the drive and right mouse click, the "remove" option is grayed out then the GUI crashes out. The same thing happens whether I run the GUI from a client, or directly from the console.
    Monday, February 21, 2011 9:20 PM
  • Interesting ... I went into the "Server Storage" tab this time (instead of Disk Management) and was able to remove the drive successfully.  What is the difference between the "remove" options in Server Storage vs. Disk Management?

    I have since shutdown and reconnected the disk and will now see if I can get any Samsung or SMART tools to run against it.  Thanks.

    Monday, February 21, 2011 9:41 PM
  • So try deleting the backup database first following the steps described in this thread.
    Maybe the corrupted backup database is causing the console to crash.

    Best greetings from Germany
    Olaf

    Monday, February 21, 2011 9:42 PM
    Moderator