locked
Thoughts/Solutions for OpenDNS Problem RRS feed

  • Question

  • If you are just going to post "Do not use OpenDNS" or "OpenDNS is useless", move on.

    Here is my setup and what I have found.

    WHS w/ 4 Vista clients (two x86 & two x64)
    Linksys Broadband Firewall Router 
    BEFSX4
    Comcast High Speed (Chicagoland)

    - I have disabled "Typo Correction" in OpenDNS settings, this does not work.
    - I have tried setting an exception for "server" in OpenDNS settings, I can't seem to get this to work. 

    - I have tried setting DNS 1 to the router itself (192.168.1.1), this does not work. 
                 Interesting note here, this works on the server; but Vista clients picks up all 3 servers, instead of just the router, therefore failing to correctly resolve internal PC names.  If you force only the 192.168.1.1 DNS entry ONLY in Vista, this solves the problem.

    Anyone else have other results? Ideas?

    EDIT: After enabling the manual/single DNS entry on one Vista box, flushing the DNS, and resetting the router; everything is now working normally.  I HAVE NO IDEA?!?!  But it is working for now.  Typo Correction is still enabled, and the SERVER exception is still active in OpenDNS.

    EDIT: Morning after, broken again.  One of these settings seems to fix it, temporarily, or I am making too many changes too quickly.  Will see if I can get it solved again.  It might be Typo Correction.


    Sunday, September 14, 2008 4:59 AM

Answers

  • FIXED/SOLVED:  The problem is in fact Typo Correction on OpenDNS settings, uncheck and solved.  OpenDNS > Settings > Advanced Settings

    • Marked as answer by sh1ft3rdotcom Thursday, October 2, 2008 8:26 PM
    Thursday, October 2, 2008 8:26 PM

All replies

  • My recommendation would be to contact the folks at OpenDNS for assistance in configuring their product. But I suspect that in the long run, the non-standard way they're handling DNS requests is at the root of your problems; there may not be a viable solution for your situation.
    I'm not on the WHS team, I just post a lot. :)
    Monday, September 15, 2008 12:00 PM
    Moderator
  • FIXED/SOLVED:  The problem is in fact Typo Correction on OpenDNS settings, uncheck and solved.  OpenDNS > Settings > Advanced Settings

    • Marked as answer by sh1ft3rdotcom Thursday, October 2, 2008 8:26 PM
    Thursday, October 2, 2008 8:26 PM