locked
Table is inaccessible / locked after sync ! RRS feed

  • Question

  • I've just synced a scope, containing 3 tables... and about 50-100.000 records.

    the ServerSide Database is now unable to do "select * from ..." on those tables !!!!!

    the ClientSide Database is ok... 

    whats going on ?

     

    The ServerSide database is locked by this wait type : LCK_M_S

    some googling suggest its a shared lock = linked server problem ?

    although the servers are linked... i can't see why this would be the problem, when MSFx is not connecting using Linked Server queries !??!

     

    please - anyone ?

    Monday, November 8, 2010 2:03 PM

All replies

  • Hi, Montago.

    Do you see any error messages when you run the Select * query? Did the sync finish successfully? What products are you using (and which version).

     

    Thanks.

    Monday, November 8, 2010 10:46 PM
  • I got a timeout exception when executing SELECT * ... 

    SQL Excecution Error.
    
    Executed SQL Statement: SELECT yadayada....
    Error Source: .NET SqlClient Data Provider
    Error Message: Timeout expired. The timeout period elapsed blablabla...

     

    I don't know if the sync finished successfully - the server was restartet (soft), therefore undoing the last transactions... although, i have 2 times let the server work/wait during a weekend, and on monday the sync had finished successfully !

     

    i'm syncing between two MS SQL 2005 servers

    i'm using MS Sync Framework SDK 2.0 (don't know if i dare upgrade to 2.1 - last time i tried, lots of features were missing !!)

    Tuesday, November 9, 2010 7:26 AM
  • have you checked in the SQL Activity Monitor which process/user is holding the locks?

    btw, which features did you find missing in 2.1?

    Tuesday, November 9, 2010 4:01 PM
  • The user is the sync account... 

    although while reviewing the screenshot i notice that there are 3 active commands in queue:

    PAGEIOLATCH_SH and 2 times LCK_M_S, all by the sync account...

     

    I kind of solved the issue by deleting the tables on the client, then recreate them and resync... things seem to work now again :-/

     

    when i installed the 2.1 beta, some of the objects was missing, being used in 2.0 ... also many of the Enums was missing a few 'properties'... especially in the conflict management.

    Wednesday, November 10, 2010 7:50 AM
  • Montago,

    the 2.1 release added some new features to the existing 2.0 functionality, but no feature has been removed. Did you give a try to the 2.1 RTM bits (http://www.microsoft.com/downloads/en/details.aspx?FamilyID=ee6af141-79d0-4351-a4a0-ea89bb29dcf5&displaylang=en)?

    Wednesday, November 10, 2010 7:31 PM