locked
Address book not downloading RRS feed

  • Question

  •  

    Thought I'd share this as I've been trying to get our address book downloading for over a week with no success.

     

    We had the usual issue with the address book - unable to download. However looking in the forums I was able to:-

     

    Confirm the URL was accessible via IE - ie I could browse to https://ocs.xxx.com/Abs/Int/Files and see the address book fiels.

    Confirm the certs were ok - ie when I browsed to the above I prompted to download the cert (we've used a standalone root CA and imported the CA and pool certs onto the test PCs manually). The cert path was installed on the OCS Front End and activated in  IIS.

     

    It turns out the problem was the address book URL. It was trying to use https://ocsmeetings.xxx.com/Abs/Int/Files I belive it had picked this up as this was what I entered as the Internal web farm FQDN during the pool setup (I'd either misread or misunderstood the install guide - I belived the internal web farm FQDN has to be different from the pool FQDN).

     

    To fix it I found the article on this forum about using wbemtest and WMI to change the address book settings. Here's the instructions (modified to reflect the address book fields)

    "You can also make changes using the WMI Tester that comes with Windows without needing to restart the server.

    Here are the steps:

    1.  Start -> Run -> wbemtest -> OK
    2.  Click Connect, replace root\default with root\cimv2 and click Connect
    3.  Click Enum Classes and click OK
    4.  Double-Click on MSFT_SIPAddressBookSetting
    5.  Click Instances
    6.  You should get one result that starts with MSFT_SIPAddress...  Double Click on that.
    7.  Double click on anything you want to change, in this case InternalURL
    8.  After you're done making changes, click Save Object.  Double-click on the line that starts with MSFT_SIPAddress (don't click Close here) 
    9. Then click Close, Close, Close, etc. etc. until it's all gone."

     

    Log out and back into Communicator and you should now be able to download the address book.

      

    Thursday, January 24, 2008 10:42 AM

All replies