locked
vista activation issue after failed sp2 install RRS feed

  • Question

  • attempt to activate says 'service not started'

    output of wga tool:
    Diagnostic Report (1.9.0011.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Genuine
    Validation Code: 0

    Cached Validation Code: N/A, hr = 0x80070426
    Windows Product Key: *****-*****-27HYQ-XTKW2-WQD8Q
    Windows Product Key Hash: U8YEZzymoD4DMyaMb32rPrNIS90=
    Windows Product ID: 89578-OEM-7332157-00061
    Windows Product ID Type: 2
    Windows License Type: OEM SLP
    Windows OS version: 6.0.6002.2.00010300.1.0.003
    ID: {4AEF3D5F-9B67-4F0D-9494-3AB5329B1CDE}(1)
    Is Admin: Yes
    TestCab: 0x0
    WGA Version: N/A, hr = 0x80070002
    Signed By: N/A, hr = 0x80070002
    Product Name: Windows Vista (TM) Home Premium
    Architecture: 0x00000000
    Build lab: 6002.lh_sp2rtm.090410-1830
    TTS Error: P:20090811095250951
    Validation Diagnostic:
    Resolution Status: N/A

    WgaER Data-->
    ThreatID(s): N/A, hr = 0x80070002
    Version: 6.0.6002.16398

    WGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    File Exists: No
    Version: N/A, hr = 0x80070002
    WgaTray.exe Signed By: N/A, hr = 0x80070002
    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    OGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002
    OGAExec.exe Signed By: N/A, hr = 0x80070002
    OGAAddin.dll Signed By: N/A, hr = 0x80070002

    OGA Data-->
    Office Status: 100 Genuine
    Microsoft Office Professional Edition 2003 - 100 Genuine
    OGA Version: N/A, 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: B4D0AA8B-604-645_B4D0AA8B-604-645_025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3_E2AD56EA-765-d003_E2AD56EA-766-0_E2AD56EA-134-80004005

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Win32)
    Default Browser: C:\Program Files\Mozilla Firefox\firefox.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>{4AEF3D5F-9B67-4F0D-9494-3AB5329B1CDE}</UGUID><Version>1.9.0011.0</Version><OS>6.0.6002.2.00010300.1.0.003</OS><Architecture>x32</Architecture><PKey>*****-*****-*****-*****-WQD8Q</PKey><PID>89578-OEM-7332157-00061</PID><PIDType>2</PIDType><SID>S-1-5-21-3093981919-2799370980-2279466754</SID><SYSTEM><Manufacturer>Hewlett-Packard</Manufacturer><Model>HP Pavilion dv6700 Notebook PC    </Model></SYSTEM><BIOS><Manufacturer>Hewlett-Packard</Manufacturer><Version>F.58     </Version><SMBIOSVersion major="2" minor="4"/><Date>20080616000000.000000+000</Date></BIOS><HWID>F0303507018400FA</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Central Standard Time(GMT-06:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>HPQOEM</OEMID><OEMTableID>SLIC-MPC</OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>100</Result><Products><Product GUID="{91110409-6000-11D3-8CFE-0150048383C9}"><LegitResult>100</LegitResult><Name>Microsoft Office Professional Edition 2003</Name><Ver>11</Ver><Val>7DF0A25CBEC95DA</Val><Hash>OXIrduchxnME3ZhFAt6UvgNWruo=</Hash><Pid>70145-749-3640267-57054</Pid><PidType>1</PidType></Product></Products><Applications><App Id="15" Version="11" Result="100"/><App Id="16" Version="11" Result="100"/><App Id="18" Version="11" Result="100"/><App Id="19" Version="11" Result="100"/><App Id="1A" Version="11" Result="100"/><App Id="1B" Version="11" Result="100"/><App Id="44" Version="11" Result="100"/></Applications></Office></Software></GenuineResults> 

    Spsys.log Content: 0x80070002

    Licensing Data-->
    Software Licensing service is not running.

    HWID Data-->
    HWID Hash Current: PAAAAAEABgABAAIAAQABAAAAAwABAAEAeqjk675dPF7WdXB6kiQso0aDlMI6WsR98vRUJghi0mSsViqF

    OEM Activation 1.0 Data-->
    N/A

    OEM Activation 2.0 Data-->
    BIOS valid for OA 2.0: yes
    Windows marker version: 0x20000
    OEMID and OEMTableID Consistent: yes
    BIOS Information:
      ACPI Table Name OEMID Value OEMTableID Value
      APIC   HP      30CC   
      FACP   HP      30CC   
      HPET   HP      30CC   
      BOOT   HP      30CC   
      MCFG   HP      30CC   
      TMOR   HP      30CC   
      SLIC   HPQOEM  SLIC-MPC
      SSDT   HP      30CC   
      SSDT   HP      30CC   
      SSDT   HP      30CC   
      SSDT   HP      30CC   
      SSDT   HP      30CC   

     

    Tuesday, August 11, 2009 3:56 PM

Answers

  • Hello randbey,

      The problem is that your Vista's Software Licensing Service has stopped. Vista uses this service to check itself and confirm it is Genuine. When the service is stopped, Vista is unable to confirm it's own Genuine status and may show Genuine or Non-Genuine. The fact that the Service has stopped is also, most likely, the cause of other issues you may be experiencing (such as not having access to the Control Panel).

      Normally this is not a big problem, since you can just restart the Service. However, we have seen a number of users that receive an error when they attempt to restart the Service. This indicates a more serious 'root cause' to the service having stopped.


      You stated that you tried to restart the service, but didn't say in what way you tried. Below are steps on how to restart the service in a particular way.  When you try it this way (and it fails) it will provides a 'System Error' that should help identify what type of 'sls has stopped' issue you have and options on what to do next.

     
    What I would like you to do is to try to restart the service using the 'Service Restart' steps, below. 
     

    Service Restart steps:

    (If you have access to the Start button):

    1)    Click the Start button

    2)    Type: cmd in the Start Search field

    3)    At the top the Start window, you will see cmd.exe

    4)    Right Click cmd.exe and select Run as Administrator

    5)    Type: net start slsvc

     

    (If you do not have access to the Start button):

    1)    Click the option that launches an Internet Browser

    2)    A Browser will open, type: %windir%\system32 into the address field

    3)    Find the file cmd.exe

    4)    Right Click on the cmd.exe and select Run as Administrator

    5)    Type: net start slsvc

     

    A)   If the error message is "System Error 3, The system cannot find the path specified." or "System Error 2, The system cannot find the file specified": Go to the main Vista Validation forum page http://social.microsoft.com/Forums/en-US/genuinevista/threads/, look in the announcement section and follow the steps found in thread "Fix for ‘Software Licensing service Has Stopped’ on some Vista 64bit systems"

     

    B)   If you receive any other error (System Error 5, System Error 57346 or System Error 54273): These occur as a result of massive file corruption.  We do not know what the root cause of the corruption is, but the likely causes are either Malware Infection or failing Hard Drive. The only resolution we can suggest is reinstall Vista.

     

    C)   If you receive no System Error and the Service start but then stops almost immediately: Something is apparently activity stopping the service. Most likely caused by some other dependent Windows Service or possibly a Malware infection. While the Software Licensing Service, itself, is part of the Anti-piracy sub-system, the running (and stopping) of Windows Services is a Vista core system that I have no insight to and is supported by Vista support at http://support.microsoft.com 

    Thank you,
    Darin MS 
     

    Tuesday, August 11, 2009 7:58 PM

All replies

  • attempts to start software licensing service gets Error 0xc004d10a:0xc004d10a

    Tuesday, August 11, 2009 4:02 PM
  • in windows event viewer for application also get this

    Log Name:      Application
    Source:        Microsoft-Windows-Security-Licensing-SLC
    Date:          8/11/2009 10:57:44 AM
    Event ID:      12291
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      Alison-PC
    Description:
    Key Management Service (KMS) failed to start.
    Info:
    hr=0xC004D10A
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-Security-Licensing-SLC" Guid="{1FD7C1D2-D037-4620-8D29-B2C7E5FCC13A}" EventSourceName="Software Licensing Service" />
        <EventID Qualifiers="16384">12291</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2009-08-11T15:57:44.000Z" />
        <EventRecordID>704</EventRecordID>
        <Correlation />
        <Execution ProcessID="0" ThreadID="0" />
        <Channel>Application</Channel>
        <Computer>Alison-PC</Computer>
        <Security />
      </System>
      <EventData>
        <Data>hr=0xC004D10A</Data>
      </EventData>
    </Event>
    Tuesday, August 11, 2009 4:04 PM
  • Hello randbey,

      The problem is that your Vista's Software Licensing Service has stopped. Vista uses this service to check itself and confirm it is Genuine. When the service is stopped, Vista is unable to confirm it's own Genuine status and may show Genuine or Non-Genuine. The fact that the Service has stopped is also, most likely, the cause of other issues you may be experiencing (such as not having access to the Control Panel).

      Normally this is not a big problem, since you can just restart the Service. However, we have seen a number of users that receive an error when they attempt to restart the Service. This indicates a more serious 'root cause' to the service having stopped.


      You stated that you tried to restart the service, but didn't say in what way you tried. Below are steps on how to restart the service in a particular way.  When you try it this way (and it fails) it will provides a 'System Error' that should help identify what type of 'sls has stopped' issue you have and options on what to do next.

     
    What I would like you to do is to try to restart the service using the 'Service Restart' steps, below. 
     

    Service Restart steps:

    (If you have access to the Start button):

    1)    Click the Start button

    2)    Type: cmd in the Start Search field

    3)    At the top the Start window, you will see cmd.exe

    4)    Right Click cmd.exe and select Run as Administrator

    5)    Type: net start slsvc

     

    (If you do not have access to the Start button):

    1)    Click the option that launches an Internet Browser

    2)    A Browser will open, type: %windir%\system32 into the address field

    3)    Find the file cmd.exe

    4)    Right Click on the cmd.exe and select Run as Administrator

    5)    Type: net start slsvc

     

    A)   If the error message is "System Error 3, The system cannot find the path specified." or "System Error 2, The system cannot find the file specified": Go to the main Vista Validation forum page http://social.microsoft.com/Forums/en-US/genuinevista/threads/, look in the announcement section and follow the steps found in thread "Fix for ‘Software Licensing service Has Stopped’ on some Vista 64bit systems"

     

    B)   If you receive any other error (System Error 5, System Error 57346 or System Error 54273): These occur as a result of massive file corruption.  We do not know what the root cause of the corruption is, but the likely causes are either Malware Infection or failing Hard Drive. The only resolution we can suggest is reinstall Vista.

     

    C)   If you receive no System Error and the Service start but then stops almost immediately: Something is apparently activity stopping the service. Most likely caused by some other dependent Windows Service or possibly a Malware infection. While the Software Licensing Service, itself, is part of the Anti-piracy sub-system, the running (and stopping) of Windows Services is a Vista core system that I have no insight to and is supported by Vista support at http://support.microsoft.com 

    Thank you,
    Darin MS 
     

    Tuesday, August 11, 2009 7:58 PM