none
WHS PP1 no atapi erros With PP2 and PP3 a lot of atapi errors RRS feed

  • Question

  •  

    Hi all, i hope some of you smart guys can help me

    been running whs for a long time now and its allways the same ____. but why no atapi erros in pp1.

    if i do upgrade my system to pp2 it runs unstable and crashes sometimes, i ope some of you smart guys can find me a solution, i also tried to install the xp sata driver and so on i am out of ideas any help is welcome.

    Thx in advance.

    i only install the lan driver

    Gigabyte GA-M57SLI-S4 socket AM2
    AMD box Athlon64 4600+ X2 Dual Core socket AM2

    Apacer 1Gb DDR2 PC6000/800 CL5.0

    4x sata Hd and couple of usb drives

    Tuesday, March 23, 2010 9:18 PM

All replies

  • You can (should) run chkdsk on all the drives in your server, but I'm not sure that will help. I suspect you have either a hardware problem (disk controller, cable, etc.) or a driver problem.
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, March 23, 2010 9:41 PM
    Moderator
  • chdisk is not the solution, and my cables and hardware run fine on PP1.
    Wednesday, March 24, 2010 3:45 AM
  • chdisk is not the solution, and my cables and hardware run fine on PP1.
    What are the exact errors you're seeing?  How do you know it's PP2 (did you do a reinstall of the OS after the problem started)?
    Wednesday, March 24, 2010 3:53 AM
    Moderator
  • I see that you said "i am out of ideas". So what's wrong with running chkdsk on your server's drives per the FAQ I linked even though you don't think it will have any effect? Not that you have to, of course, but it is an idea. Or have you done so already? That would have been useful information.

    Another idea would be to provide us with a little more information about the exact errors you're seeing. More information about your server (what have you installed on it? have you changed anything using remote desktop? etc.) would also be helpful.


    I'm not on the WHS team, I just post a lot. :)
    Wednesday, March 24, 2010 4:31 AM
    Moderator
  • I would run chkdsk on all your drives anyway.  It will not cure the problem but it will help you find the culprit.  After running chkdsk you should find you have a lot more errors on a particular drive.

    Have you got a CD/DVD ROM drive attached - if so remove it for now and see what happens.

    You don't say if the error is on the SATA or USB drives.  ATAPI errors are usually caused by faulty hardware/cables or incorrectly set UDMA modes.  Do you have some spare SATA cables?  Another idea is that PCs suffer from micro vibrations and this can assist in connectors injesting dust over time.  May disconnect your cables (1 at a time so you don't mix them up) and plug them back in - inspecting for any build up of dust.

    DMA mode is used heavily in the storage subsystems so you might want to download memtest86 and run that overnight to ensure you RAM is solid.

    Which model motherboard do you have Rev 1.0, 1.1 or 2.0?

    Also I would revert to the driver than comes from Windows Update unless you know the driver you have solves a particular problem or is more stable.


    --
    Wednesday, March 24, 2010 10:36 AM
  • reinstalled it 2 days ago with only my lan driver installed and one computer connected to whs. I have no windows updates installed for the moment and still no atapi errors.

    it was the event id 9 i think in the event vieuwer. atapi error the device did not respond withing the .....

     

    I ran checkdisk a hundred times. did not do a memtest yet. and the motherboard is rev1.

     

    Now i am gonne install all the updates except PP2 and see if the errors start occuring.

     

    Thx for the response everyone, and i hope we get this fixed.

    Wednesday, March 24, 2010 3:57 PM
  • Actually maybe the problem is a driver that comes down with Windows Update - keep an eye out on any disk controller related driver updates.
    --
    Wednesday, March 24, 2010 5:13 PM
  • ... it was the event id 9 i think in the event vieuwer. ...

    Very useful information. This Microsoft KnowledgeBase article discusses troubleshooting this sort of error. the article is, unfortunately, very general, but that's the nature of this sort of issue: until you know exactly what's causing the problem you have to do general troubleshooting to try to isolate it, and usually once you know the cause, the solution is obvious.

    Proceeding with updates once you've tried some additional troubleshooting is a good idea. As you update your server, please make sure you only install updates that are in the "High Priority" category. These are the only updates that Windows Home Server will install through the Update button in the console, or through Automatic Updates (if you have that turned on). Also, please note as you run updates if any seem to be related to hardware in any way, and if they seem to cause issues once installed.


    I'm not on the WHS team, I just post a lot. :)
    Wednesday, March 24, 2010 5:47 PM
    Moderator
  • If you have your disk(s) set to spin down when they're idle then you may occasionally see Event ID 9 (The device, \Device\Ide\IdePort0, did not respond within the timeout period ) when the disk is slow to spin back up.

    In trying to keep my server's power consumption below 25 W I have deliberately enabled disk spin down so that my 1 TB storage disk, which consumes 10 W, will spin down when not in use. In doing this I will see Event ID 9 in the logs once or twice per day. This hasn't caused any problems after 10 months of operation. Actually it's been 4 years; 3 years and 2 months running Linux and the last 10 months running Windows Home Server.

    Wednesday, March 24, 2010 11:53 PM
  • yeah the spin down thing is true, but that is not the cause, it was massive event id 9, like 5 times a minute.

     

    but i have good news, running PP3 still no atapi errors. but massive dcom errors don't know yet what they mean or how to fix. but if i runs stable i don't care.

     

    So i still don't know the exact cause but it looks like its not PP2 or 3. strange the last time they started after upgrading to pp2, and if they come back ill post it here.

     

    Thx everyone

     

    25 w power consumption is low very low. mine uses like 200 and when starting it peaks to 400.

    Thursday, March 25, 2010 7:27 PM