none
Delay in Loading Data RRS feed

  • Question

  • We developed a small application which uses DataGridView having 4 Rows .

    The content is filled with static data with DataSource

    We observed a strange behavior in Windows10 and Server2016 Operating System.To Display complete  DataGridView having 4 Rows there is a delay of 30-40 secs.

    Same application is running without any delay in Windows7 and Server2008.

    The application is built with  .Net-framework 4.0 and the application is with digital signature.

    If the application is not digital signature there is no delay observed.Can Please help 

    • Moved by Stanly Fan Friday, October 6, 2017 6:55 AM
    Thursday, September 28, 2017 6:50 AM

All replies

  • Hi Madati,

    How do you run the application in Win10 and Win7, Are they all installed Visual Studio? Or you deploy the application and install it in Win10 and Win7 respectively?

    If you publish the application, then what technology do you use? With Clickonce? Or something else?

    If you just run the application in Win10 and Win7 respectively with Visual Studio, then where do you add your database? Maybe the database is in the Server, you can monitor the time from the server to take data, and the time to load the data into datagridview, to determine which process consumes time.

    Regards,

    Stanly


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, September 28, 2017 7:18 AM
  • We will deploy the application using Install shield  with prerequisite 4.0 .Net Framework in respective Operating System.

    There is no database adding from server .The data added in  4 Rows is static Data  for example please see the below code

    StringCollection colPort Mode = new StringCollection();

       colPortMode.Add("Disabled");

    Like these we are adding static data in respectively columns for 4 Rows.

    Delay issue is not Observed in Visual Studio 2010 Box either in release or debug Mode .

    But When the project is built in release mode and the application is Digitally Signed.We are observing Delay of 30-40 secs to Display complete DataGridView that to in Win10 and Server2016 alone.

    Same application working without any delay in Win7 and Server2008

    Thursday, September 28, 2017 10:05 AM
  • Hi Madati,

    I'm afraid this issue is not related to Windows Forms itself, this forum is a developer forum, and I think your problem is more related to Install Shield or Windows 10 and Server2016, it will be more appropriate to ask your question at:

    InstallShield Forum Or: Windows Server 2016 General Forum.

    Note: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; Therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.

    Regards,

    Stanly


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Edited by Stanly Fan Friday, September 29, 2017 2:20 AM
    Friday, September 29, 2017 2:19 AM