locked
Issues configuring CRM Email Router with CRM 2011 online RRS feed

  • Question

  • We are trying to configure the CRM 2011 Email Router (Roll Up 8) with our MS CRM Online Organisation.


    In the Deployment Tab of the email router configuration Manager we have setup a profile to connect to our CRM online organisation:

    Deployment = Microsoft CRM Online

    URL:  https://dev.crm.dynamics.com/orgname**
    orgname** = our organisation name in the lower case -  the same as our organisation

    Username CRMAdmin@xyz.com
    Password: ******

    The above account is in the root business unit and has the System Admin & System Customizer Security Role. We can log into CRM online using https://orgname.crm4.dynamics.com/ without any issue.

    When we try to load data (connect to the CRM organisation) the email returns the following error message...

    "The email router configuration manager was unable to retrieve user and queue information from the Microsoft Dynamics CRM server. This may indicate that the CRM server is busy. Verify that URL https:\\dev.crm.dynamics.com/orgname is correct. Additionally, this problem can occur if specified access credentials are insufficient. To try again, click Load Data. The organisation name in the URL is not valid. To determine the organisation name, start the CRM web application as a user who has the System Customizer role. Click settings, and then click customisations. On the customisation page, click developer resources. The organisation is displayed next to the Organisation Unique name label."

    Anybody have ideas please?

    Wednesday, July 4, 2012 7:46 AM

Answers

  •  Hi MSCRMMAN,

    As it is an Online deployment check for the orgname . orgname  looks like a code and is called the organization Unique Name which can be found at

    Are u using the Unique Name?

    Settings-->Customizations-->Developer Resources --> look for organization Unique Name (looks like a code).

    -crmdev2011

    • Marked as answer by MSCRM MAN Wednesday, July 4, 2012 11:26 AM
    Wednesday, July 4, 2012 10:58 AM
  • If your usual URL says CRM4 then you must be in Europe, and the URL for the email router should also reflect this.

    Also, you don't use anything that resemble the actual name of your organisation, you use the "organisation unique name" which for CRM Online is a long alphanumeric string (looks like and I assume it is a GUID).

    The instructions in the error message tell you where to find this, or take a look here:

    What are the URLs for CRM integration?

    So you have something like https://dev.crm4.dynamics.com/234ABC123...765


    Hope this helps. Adam Vero, Microsoft Certified Trainer | Microsoft Community Contributor 2011


    • Edited by Adam Vero Wednesday, July 4, 2012 11:06 AM
    • Marked as answer by MSCRM MAN Wednesday, July 4, 2012 11:25 AM
    Wednesday, July 4, 2012 11:04 AM

All replies

  •  Hi MSCRMMAN,

    As it is an Online deployment check for the orgname . orgname  looks like a code and is called the organization Unique Name which can be found at

    Are u using the Unique Name?

    Settings-->Customizations-->Developer Resources --> look for organization Unique Name (looks like a code).

    -crmdev2011

    • Marked as answer by MSCRM MAN Wednesday, July 4, 2012 11:26 AM
    Wednesday, July 4, 2012 10:58 AM
  • If your usual URL says CRM4 then you must be in Europe, and the URL for the email router should also reflect this.

    Also, you don't use anything that resemble the actual name of your organisation, you use the "organisation unique name" which for CRM Online is a long alphanumeric string (looks like and I assume it is a GUID).

    The instructions in the error message tell you where to find this, or take a look here:

    What are the URLs for CRM integration?

    So you have something like https://dev.crm4.dynamics.com/234ABC123...765


    Hope this helps. Adam Vero, Microsoft Certified Trainer | Microsoft Community Contributor 2011


    • Edited by Adam Vero Wednesday, July 4, 2012 11:06 AM
    • Marked as answer by MSCRM MAN Wednesday, July 4, 2012 11:25 AM
    Wednesday, July 4, 2012 11:04 AM
  • Yes thanks – it was the combination of GUID and the URL which I had wrong.

    Thanks for replying J

    Wednesday, July 4, 2012 11:26 AM
  • hi,  I am getting  the Same problem,

    I am taking the organization Name From  Settings-->Customizations-->Developer Resources --> look for organization Unique Name.https://dev.crm.dynamics.com/myorgnizationname

    My Incoming Setting are:

    Email server type :Exchange Online ,protocol : Exchange Web Service,Authentication type : Clear text, Use Auto discover -- checked,Access Credentials -- Other Specified , User Name and password of Admin.

    My Outgoing Setting are:

    Email server type :Exchange Online ,protocol : Exchange Web Service,Authentication type : Clear text, Use Auto discover -- checked,Access Credentials -- Other Specified , User Name and password of Admin.

    I tried with Delegate Access and also with Send permissions but it gives me ERROR : 

    ---------------------------
    E-mail Router Configuration Manager
    ---------------------------
    The E-mail Router Configuration Manager was unable to retrieve user and queue information from the Microsoft Dynamics CRM server. This may indicate that the Microsoft Dynamics CRM server is busy. Verify that URL 'https://dev.crm.dynamics.com/orgnizationName' is correct. Additionally, this problem can occur if specified access credentials are insufficient. To try again, click Load Data. (Access is denied.)

    Plz help . its urgent..

    Saturday, December 15, 2012 12:27 PM
  • Hi Christ,

                  Are you using CRM online or CRM on-premise.

    If you're using CRM online, make sure URL. If you are in europe, you should use https://dev.crm4.dynamics.com. (depends on region, you could change it), and also make sure with https & http.

    If you're using CRM on-premise, check the CRM Deployment Manager Properties (whether your URL must be same as WEB ADDRESS in the properties).

    Tuesday, December 18, 2012 1:18 PM
  • Hi,

    we had the same problem. Solution:

    • If you are connecting to Microsoft Dynamics CRM Online and your organization uses Microsoft account, enter:

      • https://dev.crm.dynamics.com/<OrganizationName> where OrganizationName is a placeholder for the actual ID of your organization.
    • If you are connecting to Microsoft Dynamics CRM Online and your organization uses Microsoft Office 365, enter:

      • https://disco.crm.dynamics.com/<OrganizationName> where OrganizationName is a placeholder for the actual ID of your organization.

    If you are in europe, you should use https://disco.crm4.dynamics.com/<OrganizationName>

    Thursday, December 20, 2012 12:14 PM
  • Thank you very much Lukkkk,

    I'm in France and it's been two days that I try to configure a deployment for crm online.

    Thanks to you, my deployment runs well with this url :  https://disco.crm4.dynamics.com/<OrganizationName>

    Thank you very much.

    Friday, December 28, 2012 4:22 PM
  • We have a local exchange server and the dev address just stopped working for us recently after we rebooted our Exchange server.  Switching the "Microsoft Dynamics CRM Server" URL in the email router configuration manager resolved this.

    My old value was: https://DEV.crm.dynamics.com/myorgid

    replacing "dev" with "disco" resolved the issue. 

    So the new, working url is: https://DEV.crm.dynamics.com/myorgid

    Strange that this is the solution for Microsoft Office 365.  Microsoft's cloud services support are so terrible.  You'd think they would make us aware of a change like this?  The forums and phone support are such a joke too.

    Thanks for the suggestion Lukkkk. 

    Tuesday, April 22, 2014 1:31 PM