none
Underscores in code blocks RRS feed

  • Question

  • When inserting code blocks underscores are replaced with spaces:

    This_line_inserted_in_a_code_block

    This_line_inserted_in_a_code_block 

    Altough they look OK when viewed in the editor and before it is submitted. Is there any way to change this?


    /Ruben RJJournal
    Wednesday, June 25, 2008 6:33 PM

Answers

All replies

  • It's actually just how IE7 renders it. Look in Firefox.

    Of course, it definitely needs adjusting to make it look right (and nice) in all browsers.
    Thursday, June 26, 2008 12:56 AM
  • I am using FireFox 2 to view these forums and it renders correctly.  Also checked on FF3 and that too renders OK. You must be useing IE??
    Thomas Lee - MVP
    Sunday, June 29, 2008 3:40 PM
  • Thanks! This one's a known issue. The unfortunate part is the formatter renders it out as an inline style so I can't do much with CSS to fix it, so it may take a little while for us to get this one resolved.
    Rob J, Forums Dev
    Wednesday, July 2, 2008 5:14 AM
  • Rob:

    I'm sorry, but the formatter leaves a *lot* to be desired. I have completely given up using it.

    In fact most features of the Reply apparatus need serious work, IMHO.


    David Wilkinson | Visual C++ MVP
    • Edited by davewilk Thursday, July 3, 2008 1:18 AM word added
    Thursday, July 3, 2008 1:11 AM
  • A fix to this problem is a *must*, Rob, newbies looking at source code in code blocks are just getting confused.  At least when they copy and paste it, they show up but that's not good enough.

    I hereby ask you to reconsider this as a higher priority.
    Wednesday, July 23, 2008 3:47 PM
  • This is now fixed. Thanks!

    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)

    Friday, February 17, 2012 1:24 AM
    Owner