Delete not being repeated on right hand side RRS feed

  • Question

  • Thought the upgrade from V2 Beta to V2 would make the problem disappear, but it doesn't.

    In an echo config, deletions on the LHS are not getting applied to the RHS. Is there some setting somewhere that I've missed?
    Tuesday, December 16, 2008 11:57 AM

All replies

  • The reason for deletes on the LHS to not make it to the RHS would be that there are updates that are made to the  RHS files. Because there is a conflict when applying the deletes from the left on files that have been modified on the right - we do not delete the files.




    Tuesday, December 16, 2008 6:31 PM
  • "The reason for deletes on the LHS to not make it to the RHS would be that there are updates that are made to the  RHS files."

    I run the following test:
    1. Synchronized LHS and RHS.
    2. Wait some minutes then deleted a LHS sub-folder and its files.
    3. Wait some minutes. No updates on RHS.
    4. Echoed LHS to RHS.
    4. Preview answer: "Found 20 files that did not require action."
    5. Run it anyway: "Found 20 files that did not require action."

    Deletes on the LHS did not make it to the RHS, although no updates were made to the RHS.
    What I'm missing?



    Wednesday, December 17, 2008 12:21 AM

    I've noticed the same issue for a while also.


    Nothing changed on the RHS yet deletes are never echoed LHS to RHS.




    Wednesday, December 17, 2008 12:21 PM
  • Agree with the above two replies.

    I did the following:

    1. Copy "My Documents" folder to an external HDD
    2. Set up an echo sync profile with "My Documents" (CSmile as the LHS and "My Documents" (external HDD, FSmile as the RHS
    3. Deleted one or two files on the LHS
    4. Run the sync.

    Deletions are not repeated on the RHS. When I check the external HDD, the files are most definately still there. There has been no alteration of any files on the RHS at all.

    Friday, December 19, 2008 9:23 AM

    I did a test based on the above scenario and have been able to recreate this problem.
    Tuesday, December 23, 2008 11:40 AM
  • I am having a similar problem in 'Synchronize' mode.  I delete folders on Side A.
     Then I Preview expecting SyncToy to suggest I delete the same folders on Side B.
    Instead it tells me to copy those files from Side B to Side A
    This leaves me right back where I started.
    I have just downloaded 2.0 but have used 1.4 extensively and have never had a problem. Any ideas??
    Monday, December 29, 2008 4:34 PM
  • The reason why this test could happen is because

    if you copy same contents in two folders for the folder pair. They are exactly same, so SyncToy figured there is no need to sync them, preview will show nothing,

    ** But because you haven't really run the sync, the files on 2 sides really are different identities to SyncToy even if they are completely same **

    If you did a empty sync anyway, then next time, delete will be synced over.

    Otherwise, if you delete the file on left side, the right side file will win the conflict and delete will not sync over.

    Monday, December 29, 2008 11:38 PM
  • Jin He-

    I don't understand what you mean.

    Two sides exactly the same. Delete some files from the LHS, run the sync and the deletions are not repeated on the RHS. This effectively makes synctoy useless, as it keeps restoring files that you've intentionally deleted.

    Am I doing something wrong? Please tell me how I can set up a sync profile that will mirror the contents of a folder every time I run it. Including deletions. At the moment, the "Echo" function is working like a "Backup" or a "Restore" profile.
    Saturday, January 10, 2009 1:12 PM
  • Hi,

    I'm having the same problem, on the LHS I had a .vb class file which would not compile. I deleted it on my development machine (LHS) and then ran the SyncToy to deploy my website application on our Live server.  The Live server broke and I couldn't work out why.  Then I realised that SyncToy hadn't deleted it from the RHS and so the site broke because the class that broke the application wasn't removed.

    I think this really needs to be fixed, otherwise I might have to use a different tool.

    Wednesday, March 4, 2009 10:59 PM
  • I have the same problem, echo does not do deletes.

    I'm trying to use SyncToy (release) to backup a NAS (LHS) to an external eSATA hard disk (RHS) using Echo. The external hard disk is to be only for the backups with SyncToy so no files are every modified except by SyncToy (so far). I initialized the RHS with XCOPY, tried running SyncToy and it took too many hours so I killed it. I reorganized the share that SyncToy ran so slowly on to archive (RAR) some large blocks of directories to cut the processing. After getting through a painfully slow first full run, no files showed as deleted and a spot check found that none checked were deleted.
    I waited a while and re-ran SyncToy and still no deletions.
    So I waited some more and ran it again, still no deletions.

    Echo does not work.
    Thursday, March 5, 2009 6:22 AM
  • Not sure if this is an actual solution or some random luck.  After manually copying my files from the LHF to the RHF and Echo not deleting properly, I temporarily changed the action from Echo to Synchronize.

    The preview said it would delete all the files in the RHF and copy new files from the LHF.  I ran the process and change the action back to Echo.  Now it seems to work just fine.

    It seems like it wasn't getting an accurate record of the files in the RHF until I ran synchronize.  Again, not sure if this is a good solution for everyone, but it worked for me.
    • Proposed as answer by jdg0928 Wednesday, March 11, 2009 8:51 PM
    Wednesday, March 11, 2009 8:51 PM
  • Hi,

    @MICROSOFT: What about an update? Or will there just be this workaround?

    Does anybody knows a similar tool, that works?



    Friday, March 13, 2009 7:09 PM
  • I have the same issue. I just downloaded the latest version 2 of SyncToy and have never used it before. I am running XP Pro SP-3 and have a C:\Pix drive on left and F:\Pix drive USB External on right. First synced C:Pix to a new folder on F:. Then deleted a file and Syntoy wanted to copy the file back from F:. I tried it in syncronize and echo. It needs to do this or I need a new program. Any experience with Goodsync?
    Thursday, March 26, 2009 12:46 AM
  • I use a program to file synchronization, which is called File Sync. File Sync: why you need it? (http://www.fileutilityblog.com/archives/188) May be because of its efficiency. That is why I use this program and haven't any problems. Did you use it?
    Wednesday, October 21, 2009 7:21 PM
  • Good one jdg0928 - worked for me. A real pity MS cannot get it right. Hopefully a new version will arrive resolving this serious bug.

    So, when you make a new Folder Pair, first run them synchronised, then change to Echo, and it should work ok.

    When it works, a brilliant program, and central to my backup routine.
    Saturday, January 23, 2010 3:40 AM