none
Problem with read-only files RRS feed

  • Question

  • This is not so much a question as a bug report, I hope someone on the Dev team reads it.

    I was syncing some files between a Win 7 x64 machine and OS X 10.6.1 (Samba share) using v 2.0.100.0 and several files failed saying "can't write to destination", however writing any other files to the same destination folder worked fine.

    Anyway, long story short, the issue was that the _source_ files were marked read only.  Now this is either a bug because you should be able to create a new read only file, or a bad (misleading) error message as it was the source not destination that was read-only.  Fixed permissions and everything ran fine.
    Tuesday, October 6, 2009 5:54 AM

Answers

  • Hi -


    SyncToy is designed to handle read-only files at the source. It will copy over the correct attributes and any updates to the files should flow to the other side and then the correct attributes applied. So far we have been unable to repro this in our lab - we will continue to see if we can find the problem. Thanks for reporting the issue.

    Deepa
    Deepa ( Microsoft Sync Framework)
    Wednesday, October 7, 2009 5:33 PM
    Moderator

All replies

  • Hi -


    SyncToy is designed to handle read-only files at the source. It will copy over the correct attributes and any updates to the files should flow to the other side and then the correct attributes applied. So far we have been unable to repro this in our lab - we will continue to see if we can find the problem. Thanks for reporting the issue.

    Deepa
    Deepa ( Microsoft Sync Framework)
    Wednesday, October 7, 2009 5:33 PM
    Moderator
  • Hi -


    SyncToy is designed to handle read-only files at the source. It will copy over the correct attributes and any updates to the files should flow to the other side and then the correct attributes applied. So far we have been unable to repro this in our lab - we will continue to see if we can find the problem. Thanks for reporting the issue.

    Deepa
    Deepa ( Microsoft Sync Framework)

    I have encountered this issue as well using SyncToy 2.1 going from Win7 -> Linux NAS.

    Any "read-only" file on the Win7 side (has read-only attribute ticked) fails to copy to the NAS.

    I believe this is because SyncToy creates the file on the NAS side without any write permissions and can't successfully copy the file over.

    I can get around this by either removing the "read-only" attribute on the Win7 side (uncheck box) or by adding the "force create mode 700" directive to my smb.conf (Samba config file). The latter option basically forces the write permission on every file copied via Samba. This allows SyncToy to successfully copy the read-only file over.

    It appears this is a bug in SyncToy. If the file is marked read-only then SyncToy is unable to copy/update it on the target side via Samba.
    Saturday, January 2, 2010 12:56 AM
  • I too find this problem with syncing read only files on the source to the destination. I am using Windows 7 or XP and syncing to FreeNAS which is a Linux based NAS. I find the only way this works is to remove the read only from the source and retry. Seems to me that it is a sync toy issue and I have not found any other work around.

    Vance
    Saturday, February 13, 2010 10:43 PM
  • Hi - This thread has details about the problems that you are having. http://social.microsoft.com/Forums/en-US/synctoy/thread/237a18d3-d1a8-4759-8c25-97e33a4a2989/ Thanks Deepa
    Deepa ( Microsoft Sync Framework)
    Tuesday, February 16, 2010 8:17 PM
    Moderator