locked
Port Forwarding Windows Domain Error or Problem RRS feed

  • Question

  • When I try to go to my windows domain by the name: htttps://*****/homeserver.com it brings me to a apge saying the certificate  is bad.  If I continue it brings me to (useing the  above domain name) my router's home page. 192.168.0.1

    However, if I enter the IP address of the page it connects with no problem

    Also, at start up on my client machine I get a message that port forwarding may not be correctly configured. 

    Any idea what could be going on?

    Thanks

    Kevin
    Thursday, March 11, 2010 1:19 PM

Answers

  • Hi,

    You are trying to reach your homeserver from inside your private network but you are giving it a fully qualified domain name (FQDN) that points to your public IP address.  That public IP address is your router.  If you try the FQDN from outside your home (i.e. web cafe, mobile phone browser) you should see the Windows Home Server page come up - that is if you set it up correctly.

    That leads to your second question that port forwarding is not setup correctly.  You should switch on UPNP on your router and try to configure remote access once again.  Depending on your ISP you may or may not be able to have a server on port 80, 443 or 4125 - which are all needed for remote access.

    If you can't setup UPNP on your router or don't know where to find it PortForward is a good resource:
    http://portforward.com/


    Cheers,
    Al
    --
    Thursday, March 11, 2010 5:34 PM

All replies

  • Hi,

    You are trying to reach your homeserver from inside your private network but you are giving it a fully qualified domain name (FQDN) that points to your public IP address.  That public IP address is your router.  If you try the FQDN from outside your home (i.e. web cafe, mobile phone browser) you should see the Windows Home Server page come up - that is if you set it up correctly.

    That leads to your second question that port forwarding is not setup correctly.  You should switch on UPNP on your router and try to configure remote access once again.  Depending on your ISP you may or may not be able to have a server on port 80, 443 or 4125 - which are all needed for remote access.

    If you can't setup UPNP on your router or don't know where to find it PortForward is a good resource:
    http://portforward.com/


    Cheers,
    Al
    --
    Thursday, March 11, 2010 5:34 PM
  • I hear what you are saying, but the link is from the  Windows Home Server Setting page.  It brings up IE with a certificate error. Why would this be?  I don't think that has happened in the past.  If I put the IP address in of the page it brings it up. What occurs on you machine when you click this link? 

    Looking at the port forwarding page of my router there are a lot of enteries. Many of them say: Teredo UDP.  At this point the only thing I know is that the Port Forwarding Error notice brings up WHS when clicked.

    Thanks
    Friday, March 12, 2010 1:06 AM
  • I hear what you are saying, but the link is from the  Windows Home Server Setting page.  It brings up IE with a certificate error. Why would this be?  I don't think that has happened in the past.  If I put the IP address in of the page it brings it up. What occurs on you machine when you click this link? 

    It works for me, but it depends on the router.  For example, if I put http://xxxxx.homeserver.com (no s in https) from within my LAN, I only get my router setup.  Please try it from outside your local network (and preferably not your place of employment either as some businesses block some of those ports) as Al suggested (a friend's house, a local Starbucks, etc.)

    Looking at the port forwarding page of my router there are a lot of enteries. Many of them say: Teredo UDP.  At this point the only thing I know is that the Port Forwarding Error notice brings up WHS when clicked.

    Thanks
    In that case, you could try deleting all of the entries in your router, disable uPnP in the router, and then set up the 3 ports yourself.
    Friday, March 12, 2010 1:56 AM
    Moderator
  • A certificate must exactly match the hostname is has been issued to.  If it doesn't then you will get the warning.

    Your setup might be working fine on say port 443 but not 80 as you ISP may block you from having servers on Port 80 - you should check with your ISP or post who you are with here and someone might know.


    --
    Friday, March 12, 2010 10:05 AM
  • I am on Verizon FIOS.
    Saturday, March 13, 2010 12:43 AM
  • What 3 ports would I have to set up?
    Saturday, March 13, 2010 12:43 AM
  • What 3 ports would I have to set up?
    The 3 Al mentioned (80, 443, and 4125).
    Saturday, March 13, 2010 12:46 AM
    Moderator