locked
Error Importing Partner Potal Customisations RRS feed

  • Question

  • Hi,

    After importing the PRM customisations .zip, I get the following messge. https://photos-1.dropbox.com/i/xl/GPlYyIkJ_0JTNIQj-4AyITzJaQxNQupV_GYngtQM_u8/14853284/1297904400/6f581a9

    While uploading the PRM customisations .zip package I get an error advising that the CRM dynamics encountered an error. I can see the customisation solution imported but when I publish it I noticed that the "Membership and Events" tab does not show up.

    Here is the log file after upload: (NOTE: For security ressons I changed tpart of he orgID & UserID to xxxx)

    Microsoft Dynamics CRM Error Report Contents
    
    
    
    <CrmScriptErrorReport>
    
     <ReportVersion>1.0</ReportVersion>
    
     <ScriptErrorDetails>
    
    	<Message>Access is denied.
    
    </Message>
    
    	<Line>1</Line>
    
    	<URL>/_static/_controls/SolutionWizardController/SolutionWizardController.js?ver=1260476026</URL>
    
    	<PageURL>/tools/solution/import/SolutionImportWizard.aspx</PageURL>
    
    	<Function></Function>
    
    	<CallStack>
    
    	</CallStack>
    
     </ScriptErrorDetails>
    
     <ClientInformation>
    
    	<BrowserUserAgent>Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; Media Center PC 6.0; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; MS-RTC LM 8; .NET4.0E; MS-RTC EA 2)</BrowserUserAgent>
    
    	<BrowserLanguage>en-us</BrowserLanguage>
    
    	<SystemLanguage>en-gb</SystemLanguage>
    
    	<UserLanguage>en-gb</UserLanguage>
    
    	<ScreenResolution>1920x1200</ScreenResolution>
    
    	<ClientName>Web</ClientName>
    
     <ClientTime>2011-02-15T22:17:53</ClientTime>
    
     </ClientInformation>
    
     <ServerInformation>
    
     <OrgLanguage>1033</OrgLanguage>
    
     <OrgCulture>2057</OrgCulture>
    
     <UserLanguage>1033</UserLanguage>
    
     <UserCulture>2057</UserCulture>
    
     <OrgID>{7B490BBD-E99B-4313-9144-xxxxxxxxxxxx}</OrgID>
    
     <UserID>{24E40C25-A343-4C3F-8235-xxxxxxxxxxxx}</UserID>
    
     <CRMVersion>5.0.9688.69</CRMVersion>
    
     </ServerInformation>
    
    </CrmScriptErrorReport>
    
    
    
    <CrmScriptErrorReport>
    
     <ReportVersion>1.0</ReportVersion>
    
     <ScriptErrorDetails>
    
    	<Message>Access is denied.
    
    </Message>
    
    	<Line>1</Line>
    
    	<URL>/_static/_controls/SolutionWizardController/SolutionWizardController.js?ver=1260476026</URL>
    
    	<PageURL>/tools/solution/import/SolutionImportWizard.aspx</PageURL>
    
    	<Function></Function>
    
    	<CallStack>
    
    	</CallStack>
    
     </ScriptErrorDetails>
    
     <ClientInformation>
    
    	<BrowserUserAgent>Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; Media Center PC 6.0; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; MS-RTC LM 8; .NET4.0E; MS-RTC EA 2)</BrowserUserAgent>
    
    	<BrowserLanguage>en-us</BrowserLanguage>
    
    	<SystemLanguage>en-gb</SystemLanguage>
    
    	<UserLanguage>en-gb</UserLanguage>
    
    	<ScreenResolution>1920x1200</ScreenResolution>
    
    	<ClientName>Web</ClientName>
    
     <ClientTime>2011-02-15T22:18:17</ClientTime>
    
     </ClientInformation>
    
     <ServerInformation>
    
     <OrgLanguage>1033</OrgLanguage>
    
     <OrgCulture>2057</OrgCulture>
    
     <UserLanguage>1033</UserLanguage>
    
     <UserCulture>2057</UserCulture>
    
     <OrgID>{7B490BBD-E99B-4313-9144-xxxxxxxxxxxx}</OrgID>
    
     <UserID>{24E40C25-A343-4C3F-8235-xxxxxxxxxxxx}</UserID>
    
     <CRMVersion>5.0.9688.69</CRMVersion>
    
     </ServerInformation>
    
    </CrmScriptErrorReport>
    
    
    
    

    Regards,

    Abby

    • Edited by Abby_Doc Wednesday, February 16, 2011 12:45 AM edit url
    Wednesday, February 16, 2011 12:39 AM

Answers

  • Oh yeah, the documentation is wrong. We'll fix that before releasing the portals. Thanks for reporting it!

    I cannot see the images on dropbox aren't loading for me, can you email them to palakk microsoft.com?

    Thanks
    - Palak

    • Marked as answer by Abby_Doc Saturday, February 19, 2011 12:16 AM
    Friday, February 18, 2011 7:57 PM
  • Hi Abby,

    The uninstall issue is a known problem and will be fixed soon. The solution does uninstall correctly though, so the process should still work as expected.

    For the currency issue, that is a bug and will be fixed in the final version of the portals. In the mean-time, before publishing the process, you can just open that particular email template, scroll to the bottom and delete the value in the "Currency" field. It is set to US dollar but doesn't need to be set to anything.

    Thanks!
    - Palak

    • Marked as answer by Abby_Doc Saturday, February 19, 2011 12:15 AM
    Friday, February 18, 2011 11:42 PM

All replies

  • Hi Abby,

    The warning about mismatched versions is expected since the online and on premise version numbers are different. Do you have admin permissions to the org where you are importing the customizations?

    - Palak

    Thursday, February 17, 2011 10:29 PM
  • Hi Palak,

    I thought so but just wanted to provide the information

    Yes, I have the SYSTEM ADMIN role in Dynamics CRM.

    Regards,

    Abby

     

    Thursday, February 17, 2011 10:43 PM
  • Hi Abby

    Is the solution imported sucessfully? If so yu can download the Log file after import (Import Job Downlaod).. You can also query the Import Job from advanced find and export to Excel and send to me ajithg microsoft.com. 

     


    Thanks AjithG - MSFT
    Friday, February 18, 2011 5:09 AM
  • Hi Ajithg,

    Well I think there must have been an issue with the CRM online system when I tried to import the solution several times previously.

    So today I tried again and this time I managed to import the solution but with a different error (See Image Link: https://photos-1.dropbox.com/i/xl/PnYdgiEuNasyoyZUskMRQYIkig2Urcn9BXWdApwGf4U/14853284/1298124000/4eb94d6)

    I investigated further and found that the issue had to do with the fact that my CRM System Local default currency is UK with £GBP (See Image Links: https://photos-4.dropbox.com/i/xl/Ymrk-utjjkvecp7BYsCwdPQNhBfDUBWxEvUo-a3iM64/14853284/1298124000/8246f55)

    https://photos-3.dropbox.com/i/xl/pNUQ4tZZMN_qUK0j3xN8zn5lkCgTnD2xknN_E8-V-as/14853284/1298124000/bbf3b93

    The solution is exported from a US local so I added the $US currency to the system, uninstalled the solution but got an error during uninstall (See Image Link: https://photos-5.dropbox.com/i/xl/5SFEs5tFyvUQ66HelunKVXbxjRbBCPpiQvXvOH6pAfY/14853284/1298127600/6527108)

    I refreshed my browser and the solution had been deleted from the solutions section. So, I went ahead and imported the solution again and this time it imported with no errors but when I published the installation I found that I could only see the "Content Management" tab in the navigation pane but NOT the "Membership & Events" tabs.

    Thanks.

    Abby

    Friday, February 18, 2011 2:30 PM
  • Hi Abby,

    Which "Membership & Events" tab are you referring to? Did you create a custom tab that's missing after the portal install? Microsoft's version of the PRM portal does not come with Membership functionality. You have to manage events through Marketing -> Campaigns.

    Thanks
    - Palak

    Friday, February 18, 2011 7:16 PM
  • Hi Palak,

     

    Thanks for that. I am guessing the documentation of the PRM solution is wrong.

    I quote "Once the import process is completed, refresh your browser. The navigation pane of Microsoft Dynamics CRM includes the Content Management and Membership & Events tabs."

    Been cracking my brain :)

    In that case my import was successfully after the currency was resolved.

    Anyideas about the uninstall issue?


    Cheers - Abby

     

    Friday, February 18, 2011 7:54 PM
  • Oh yeah, the documentation is wrong. We'll fix that before releasing the portals. Thanks for reporting it!

    I cannot see the images on dropbox aren't loading for me, can you email them to palakk microsoft.com?

    Thanks
    - Palak

    • Marked as answer by Abby_Doc Saturday, February 19, 2011 12:16 AM
    Friday, February 18, 2011 7:57 PM
  • Hi Palak,

    Ok, great.

    I have emailed the images to you as requested.

    Thanks - Abby

    Friday, February 18, 2011 8:08 PM
  • Hi Abby,

    The uninstall issue is a known problem and will be fixed soon. The solution does uninstall correctly though, so the process should still work as expected.

    For the currency issue, that is a bug and will be fixed in the final version of the portals. In the mean-time, before publishing the process, you can just open that particular email template, scroll to the bottom and delete the value in the "Currency" field. It is set to US dollar but doesn't need to be set to anything.

    Thanks!
    - Palak

    • Marked as answer by Abby_Doc Saturday, February 19, 2011 12:15 AM
    Friday, February 18, 2011 11:42 PM
  • Hi Palak,

    Ok, thats great thanks.

    Best Regards,

    Abby

    Saturday, February 19, 2011 12:14 AM