locked
Disable Alert notification for adding a user to your Contact List RRS feed

  • Question

  • We've rolled out about 20 Office Communicator clients and are getting ready to roll out about 200 more.  We want to disable the Alert that notifiies you that you have been added to someone elses Contact list. 

    The client side settings are located under Tools, Options, Alerts, General Alerts, and the "Notify me when someone adds me to his or her contact list" should be unchecked.  By default this option is checked. 

    How can we globally uncheck this checkbox?

    Thanks all,
    Dave
    Wednesday, January 7, 2009 4:19 PM

Answers

All replies

  • This can be set globally via Group Policy; the communicator.adm file contains a policy setting to control the "NotificationsForNewSubscribers" client registry value.
    http://technet.microsoft.com/en-us/library/bb963959.aspx

    If you add the communicator.adm template to the Group Policy Object Editor then you can apply these changes globally.  If you want users to not see any messages then configure the setting as Disabled.  This will turn off notifications for all OC clients and also gray-out the checkbox in their OC client Options so it cannot be re-enabled by an individual user.
     
    Take a look at this thread as well for more info.
    http://social.microsoft.com/forums/en-US/commmunicatorsetup/thread/ed1a9192-0ba2-4801-a35b-7ece948ec994/


    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Wednesday, January 7, 2009 5:05 PM
    Moderator
  • I've added the communicator.adm template, but cannot find the NotificationsForNewSubscribers in the GPO.  I have disabled "Show notifications for new presence subscribers"... is that the same thing or something totally different and I should leave it alone?

    I have found the NotificationsForNewSubscribers text in the actual communicator.adm file, but how do I edit it?  The default shows:

    POLICY !!PolicyNotificationsForNewSubscribers
        EXPLAIN !!ExplainText_NotificationsForNewSubscribers
        VALUENAME "NotificationsForNewSubscribers"
            VALUEON   NUMERIC  1
            VALUEOFF  NUMERIC  0
        END POLICY

     But how do I edit that bit, if I even need to?  And I think there are more than one of these entries.

    Thanks,
    Dave

    Wednesday, January 7, 2009 6:56 PM
  • I was also expecting that to take effect once I rebooted and logged back in... but I am still able to Check that checkbox.  Once I add the Template (communicator.adm), do I need to do anything special to implement it?

    Sorry for the newbie questions, kinda new to OCS.

    Thanks,
    Dave
    Wednesday, January 7, 2009 7:13 PM
  • I guess it just took time to replicate/propagate/enable/work/whatever... All is working as expected now.

    Thank for you help Jeff!

    Dave
    Wednesday, January 7, 2009 9:24 PM
  • No problem Dave.  Patience is a good thing when working with Group Policies :)  One tip is to use the gpupdate command on the client to speed up the application of policy settings.  Also you don't want to edit the .adm template files, just select the options as you discovered.
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Wednesday, January 7, 2009 10:01 PM
    Moderator
  • One last thing...  Currently we have no outside presence (Federated?), so... will disabling this Alert (which now works as expected) include outside vendors?  If so, how can I differentiate the two, internal vs. external?

    Once we open OCS to the outside world, I'd like the Alerts to be enabled for anyone from the outside world, while bypassing the Alert for any "Company" (inside) people... is that possible via the GPO's?

    Dave
    Thursday, January 8, 2009 3:59 PM