locked
[CRM2013] "Record Unavailable" message when re-importing an organization RRS feed

  • Question

  • Hi,

    I am running into an issue while importing an organization into CRM2013 using a CRM2011 database backup.

    We are in the process of upgrading from CRM 2011 to CRM 2013.  After importing an organization for the first time, I ran into some issues where the CRM pages were not displaying properly, so I have decided to remove the organization from deployment manager, delete the database from the database server, and do a re-import of the organization.  Even though there were issues with the initial import, I was able to browse the CRM pages.

    While the re-import worked fine, I was unable to bring up the organization on the browser after the import.  I get this error:

    Record Is Unavailable

    The requested record was not found or you do not have sufficient permissions to view it.

    This is happening when tested on different computers and different user accounts so the issue should be on the server side.

    One thing to note is that when importing the organization, the user mapping process was unable to map certain users from the existing database (likely because the users are no longer listed on active directory so the import wizard cannot pick up the user accounts), but there were no options to remove these entries from the import, aside from mapping these users manually.  I've ignored the user mapping error as a result but the import was successful regardless.

    Any ideas why I am now unable to bring up any pages in CRM at all?

    Friday, April 7, 2017 7:38 PM

Answers

  • Assuming you are performing an upgrade on separate infrastructure meeting all of the hardware and software requirements set out by the Planning Upgrade from CRM 2011 to CRM 2013....

    Is your sql database backup any good, did you verify when backing up.

    When you restored the sql database into the new Sql Server was that successful.

    Have you set up your CRM active directory accounts correctly with the appropriate permissions to file system and the creation of server principle names and membership to Performance Groups. All this is mentioned in the link above.

    When using the Deployment Manager and checking its settings is everything as it should be. 

    Do you have SSRS set up correctly, if you do an import and SSRS isnt set up you will have issues.

    What did the Import Organisation log files say, there should be some information there.

    You mentioned the mapping of the user has errors, this isnt an issue so long as 1 user who has Sys Admi priviledges is mapped to one of your Deployment Administrators.

    • Marked as answer by SL. _ Tuesday, April 11, 2017 8:08 PM
    Saturday, April 8, 2017 4:53 AM

All replies

  • Assuming you are performing an upgrade on separate infrastructure meeting all of the hardware and software requirements set out by the Planning Upgrade from CRM 2011 to CRM 2013....

    Is your sql database backup any good, did you verify when backing up.

    When you restored the sql database into the new Sql Server was that successful.

    Have you set up your CRM active directory accounts correctly with the appropriate permissions to file system and the creation of server principle names and membership to Performance Groups. All this is mentioned in the link above.

    When using the Deployment Manager and checking its settings is everything as it should be. 

    Do you have SSRS set up correctly, if you do an import and SSRS isnt set up you will have issues.

    What did the Import Organisation log files say, there should be some information there.

    You mentioned the mapping of the user has errors, this isnt an issue so long as 1 user who has Sys Admi priviledges is mapped to one of your Deployment Administrators.

    • Marked as answer by SL. _ Tuesday, April 11, 2017 8:08 PM
    Saturday, April 8, 2017 4:53 AM
  • Thanks, manually mapping a few admin users including myself worked for me.  I also chose to map users manually during the import process, maybe that also made a difference.
    Tuesday, April 11, 2017 8:08 PM