none
An exception of type 'System.ArgumentException' occurred in test.dll and wasn't handled before a managed/native boundary RRS feed

  • Question

  • i have a problem with generating a PDB file for an external dll, my application breaks with this message error

    An exception of type 'System.ArgumentException' occurred in test.dll and wasn't handled before a managed/native boundary

    thanks for your contribution

    Thursday, December 14, 2017 9:54 AM

All replies

  • Hi amine 2,

    >>i have a problem with generating a PDB file for an external dll, my application breaks with this message error

    According to your description, it seems that your application has a external dll, which does not handle the exception and throw a 'System.ArgumentException' exception. but I am not sure what is a your issue. could you please describe it in detailed.

    If you want to debugger external dll and step into external dll, you need have external dll source code.

    Best regards,

    Zhanglong Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, December 15, 2017 9:55 AM
  • hi Zhanglong Wu,

    honestly i do not know where the problem came from, i tried to import an external dll in my project and the solution compiles perfectly but when i open the window concerned the application crashes without any exception and an error message appears that says the PDB file was not generated for my dll.

    best regards,

    Friday, December 15, 2017 3:08 PM
  • Hi amine 2,

    Could you please share a simple demo via OneDrive, which I could reproduce the issue on my side. it will be beneficial to resolve the issue.

    Note: please remove primacy information before upload the sample. 

    Best regards,

    Zhanglong Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, December 18, 2017 9:13 AM
  • hello 

    here is my code xaml 

    <Page
        x:Class="App2.MainPage"
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        xmlns:local="using:App2"
        xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
        xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"
        mc:Ignorable="d"
          xmlns:syncfusion="using:Syncfusion.UI.Xaml.Schedule">

        <Grid Background="{ThemeResource ApplicationPageBackgroundThemeBrush}">
            <syncfusion:SfSchedule x:Name="schedule" VerticalAlignment="Stretch" HorizontalAlignment="Stretch"
                    ScheduleType="Week"
                    IsHighLightWorkingHours="True"
                    CurrentTimeIndicatorVisibility="Visible"
                    TimeMode="TwentyFourHours"
                    TimeInterval="ThirtyMin"
                    MinorTickVisibility="Collapsed"
                    FirstDayOfWeek="Monday"
                    CurrentTimeIndicatorLocation="OnDay"
                    NonWorkingHourBrush="#338D92A2"                   
                    NonWorkingDays="Sunday,Saturday" 
                    WorkStartHour="9" 
                    WorkEndHour="18" 
                    AppointmentSelectionBrush="Transparent">

            </syncfusion:SfSchedule>
        </Grid>
    </Page>

    I just add a reference to syncFusion that's all what i did


    • Edited by amine 2 Monday, December 18, 2017 4:22 PM
    Monday, December 18, 2017 3:23 PM
  • Hi amine 2,

    >>here is my code xaml 

    What kind of project template you are using, UWP, xamarin UWP, or others, it seems that you use 3rd-party control. I would suggest that you could post your issue on 3rd-party forum

    https://www.syncfusion.com/forums/winrt

    Thanks for your understanding and cooperation.

    Best regards,

    Zhanglong Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, December 19, 2017 2:56 AM
  • Hi Zhanglong Wu,

    thanks for your help

    Tuesday, December 19, 2017 9:27 AM